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COMODO

Creating Trust Online®

1. Comodo IceDragon — Introduction

Comodo IceDragon is a fast, secure and versatile Internet Browser based on Mozilla core and infused with
Comodo's unparalleled level of security.

Guide Structure

This guide is intended to take you through the installation, configuration and use of Comodo IceDragon.
« Comodo Dragon - Introduction
« System Requirements
« Download And Install Comodo IceDragon
» The Basics

+  Start Comodo IceDragon
» Set IceDragon as your Default Browser
« Set Your Homepage
« Search the Internet
«  Customize the Toolbar
«  Open Recently and Most Visited Websites
» View Browsing History
« Set Fonts, Languages and Encoding
»  Configure IceDragon Updates
» Portable Version
» Uninstall IceDragon
+ Tabbed Browsing

+ Use Tabs
»  Customize Your 'New Tab' Page
» Tab Settings

+ Bookmarks

» Create Bookmarks

+ Find and Edit Bookmarks

» Manage Bookmarks

»  Bookmarks - Import, Export and Back up
» Privacy And Security

+  Private Browsing

» Delete Browsing History and configure History settings

« Allow/Block pop-up windows

» Manage Cookies

» Block Websites from Tracking your Browsing History

» View and Manage Permission Settings

« Configure Suggestions when Entering a Website Address
« Manage Cache

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 5



Manage Add-on permissions

Manage Passwords

SSL Certificates and Secure Connections

Manage SSL Certificates and HTTPS Security

Force Secure Connections

Website Security Indicators

Disable accessibility indicator setting

Configure IceDragon performance and browsing settings

Network Proxy settings

+  Downloads

Download a File

Change Download Location
View Download History
Clear Download History

e Introduction to Add-ons

Download and Install Add-ons

+ Install Add-ons from Local Storage
«  Configure Updates to Add-ons
Manage Extensions

Customize the Appearance of IceDragon
Manage Plugins

» Tools and other Features

Customize Applications for Opening Different File Types
Search Within Page Content

Form Autofill

Keyboard and Mouse Shortcuts for Comodo IceDragon
Manage IceDragon in Safe mode

Scan Websites for Malware and Blacklist Using Web Inspector
Set up Comodo IceDragon sync information

View Digital Rights Management

Improve IceDragon Performance Settings

«  Web Developer Tools

Open the Tools console

Inspect Page Elements

Use the Web Console

Remove Inconsistencies with HTML, CSS and Javascript
View and Run Experimental Style Sheets on a Webpage
Improve Web Page/Web Application Performance
Memory Tool

Network Monitoring

COMODO

Creating Trust Online®

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved



Comodo IceDragon - User Guide / comooo

/

*  Developer Toolbar
» Use the WebIDE
« Browser Console
* Responsive Design View
+ Eyedropper
*  Run Experimental Java Scripts on Page
» View Page Source
« Service Workers
»  Connect Remote Device
« Add More Web Development Tools
«  Work Offline
+ Troubleshooting

«  Error: “"This Connection is Untrusted”
* Report a Bug

2. System Requirements

To ensure optimal performance of Comodo IceDragon, please ensure that your PC complies with the minimum
system requirements:

« Windows 8/8.1/7/ Vista/ XP
+ 128 MB RAM
40 MB Hard Disk Space
See Download And Install Comodo IceDragon to download and install the IceDragon.

3. Download And Install Comodo
IceDragon

You can download the IceDragon setup file from: http:l/icedragq_n.comodo.com/
After downloading the file, double click icedragonsetup.exe @ to start the installation wizard.
Step1 - End User License Agreement

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 7
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COMODO IceDragon Setup

License Agreement

@ FPlease review the license terms before installing Comodo IceDragon
Py 58.0.0.11

Press Page Down to see the rest of the agreement.
COMODO ICE DRAGON END USER AGREEMENT

THIS AGEEEMENT CONTAINS A BINDING ARBITRATION
AND CLASS ACTION WAIVER CLAUSE

IMPORTANT-PLEASE READ THESE TERMS CAREFULLY BEFORE APPLYING FOR,
ACCEPTING, OR USING COMODO ICE DRAGOMN. BY USING, APPLYING FOR, OR
ACCEPTING THE ACCOUNT, SOFTWARE OR SERVICES OR BY CLICKING OM | ACCEPT
BELOW. YOU ACKMOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, THAT YOU
LUNDERSTAND [T, AMD THAT YOU AGREE TO BE BOUND BY ITS TERMS. IF YOU DO NOT
AGREE TO THESE TERMS, DO NOT CLICK "ACCEPT" AMD DO MOT APPLY FOR, ACCEPT,
DR USE COMODOD ICE DRAGOMN.

If you accept the term of the agreement, click I Agree to continue. You must accept the agreement
to install Comodo IceDragon.

The EULA screen of the setup wizard is displayed. Complete the initialization phase by reading and accepting the
End User License Agreement (EULA).

»  Click 'l agree' button to continue the installation.
«  Click 'Cancel' button to abort the installation.

Step 2 - Select Installation Folder

The next screen allows you to select where you want to install Comodo IceDragon. The default installation path is
C:\Program Files(x86)\Comodo\lceDragon.

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 8
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COMODO IceDragon Setup
Choose Install Location

E Choose the folder in which to install IceDragon.

Setup will install IceDragon in the following folder. To install in a different folder, click Browse and
select another folder. Click Install to start the installation.

Destination Folder

| C:\Program Files (x86)\Comodo‘\IceDragon

[ Import From Firefox

[ Portable version (user profile is stored in destination folder)

Space required: 50 MB
Space available: 6274 MB

»  Click 'Browse' to choose a different installation location.

» 'Import from Firefox' — Copies your bookmarks, history, passwords and other data from Firefox into
IceDragon.

« 'Portable version (user profile is stored in destination folder)' — The portable version saves all user profile
data to the IceDragon folder instead of the Windows 'user' folder. This allows you to copy the IceDragon
folder to a USB drive, plug it into any computer and access your personalized version of the browser. See
Portable Version help page for more details.

«  Click 'Next' to move onto the next stage of the installation wizard.

Step 3 - Installation

Next, IceDragon will begin installing. The progress will be displayed as followed:

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 9
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COMODO IceDragon Setup

Installing

) Please wait while IceDragon is being installed.
®

I

Extract: omni.ja... 23%

+  The 'Installation Complete' dialog will appear once setup is complete:
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COMODO IceDragon Setup
Completing the Comodo IceDragon Setup

Comodo IceDragon 58.0.0.11 has been installed on your computer.

Click Finish to close Setup.

+ Run Comodo IceDragon

+ Make Comodo IceDragon my default browwser

«  Leave 'Run Comodo IceDragon' enabled to start browsing with IceDragon immediately.

»  Leave 'Make Comodo IceDragon my default browser' selected to make Comodo IceDragon your default
browser. If you want to keep your current browser as default, deselect the checkbox.

+  Click 'Finish'.

*  You will also be offered the opportunity to set your search engine provider to Yahoo (or Yandex in Russia,
Ukraine, Romania, Kazakhstan and Turkey):

Comodo IceDragon

Your browser is installed and ready to use

Improve your browsing experience

We recommend keeping your browser up to date for the best perfformance, the
best features and to prevent your computer from being at risk!

Set Yahoo! as my home page, new tab and default search engine (applies to
all supported browsers).

«  Choosing Yahoo/Yandex as your default search engine means:

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved "
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« When you enter a search item into the address bar of a supported browser, the search will be carried
out by Yahoo/Yandex

«  A‘Search with Yahoo/Yandex’ menu entry will be added to the right-click menu of supported browsers.
» Yahoo/Yandex will be set as the default search engine in the ‘Search’ box of supported browsers

» The instant ‘search suggestions’ that you see when you start typing a search item will be provided by
Yahoo/Yandex

«  Click 'Decline' to cancel the enhancements.

4. The Basics

This section of the guide explains how to launch, configure and use Comodo IceDragon to its full potential.
Click the following links to find out more:

+ Start Comodo IceDragon

» Set IceDragon As Your Default Browser

+ Set Your Homepage

« Search The Internet

« Change Search Options

»  Customize the Toolbar and the Menu

»  Open Recently And Most Visited Websites In IceDragon

« View Browsing History

» Set Fonts, Languages And Encoding

»  Configure IceDragon Updates

» Portable Version

« Uninstall IceDragon

4.1.Start Comodo IceDragon

There are two different ways to start Comodo IceDragon:

«  Start Menu
« Desktop
Start Menu

You can launch Comodo IceDragon via the Start Menu.

»  Click Start and select All Programs > Comodo > IceDragon > Comodo IceDragon

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 12



Comodo IceDragon - User Guide / comooo

/

Recently added

o &
+# Comodo IceDragon
- : 2
«# Uninstall Comodo lceDragon

Y Dragon Help Page

Desktop

» Just double-click the Comodo IceDragon icon on your desktop.

A

o

&

omodo
12eDragon

Further reading related to the topic of this page:
» Set Your Homepage
»  Open Recently and Most Visited Websites in IceDragon

»  Set IceDragon As Your Default Browser

4.2.Set IceDragon as your Default Browser

If you have more than one browser installed, it's likely that you'll want to pick one as your 'go-to' browser for
everyday use.

This means that it will automatically be used to view websites when you click a link in, say, an email or IM
conversation.

To do this:
«  Click the hamburger/'Open Menu' button at the top-right corner

«  Select 'Options' > 'General' then click 'Make Default' button.

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 13
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Eile Edit View History Bookmarks Tools Help — | e
¥ Options x | +
c ce..gon  aboutpreferences o » =

£+ Most Visited @ Getting Started 33\ Latest Headlines
£ Find in Options

# CGenera>

Q Startup

v Always check if lceDragon is your default browser
Y IceDragon is not your default browser Make Default...

Aﬂ When IceDragon starts

Q

» Leaving the check 'Always check if IceDragon is your default browser ' box enabled will instruct IceDragon
to check whether or not it is the default browser every time you start the software.

Related to this page:

» Set Your Homepage

4.3.Set Your Homepage

You can configure IceDragon to open at a specific page, or set of pages, by default. You can also make it start with a
blank page or with whatever pages were open at the end of your last session.

Click the following links for more help:
«  Configure startup
*  Home page
Configure startup
+  Click the hamburger/'Open Menu' button at the top-right corner.

»  Select 'Options' > 'General'.

+  Scroll to 'When IceDragon starts'.

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 14
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L Find in Options

Startup

¥ Always check if lceDragon is your default browser

'. IceDragon is not your default browser Make Default...

When lceDragon starts

® Show your home page

S WP O

Show a blank page

Show your windows and tabs from last time

«  Show your home page — Opens your home page every time you start Ice Dragon. See 'Configure Home
page' for more details on setting up your favorite web page as home page.

»  Show a blank page - Ice Dragon will open at a blank page.

»  Show your windows and tabs from last time - Opens the page(s) you had open at the end of your last
browsing session.

Configure Home page

You can set your favorite web page as your home page using one of the following methods:
Manually

»  Click the hamburger/ 'Open Menu' button at the top-right corner
»  Select 'Options' >'General'

»  Type the URL of your desired homepage in the 'Home Page' field:

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 15



Comodo IceDragor__1_______;_,_,LJ-Se"r"’GUi_d e/ EOMORO

/
/

£ Find in Options

Startup

v Always check if lceDragon is your default browser

'. IceDragon is not your default browser Make Default...

& QW P O n

When lceDragon starts

® Show your home page
Show a blank page

Show your windows and tabs from last time

| https.//www.comodo.com

Use Current Page Use Bookmark... Restore to Default

From the currently displayed page
«  Open the page you want to use as your home page in IceDragon
«  Click the hamburger/ 'Open Menu' button at the top-right corner
«  Select 'Options' > 'General'
«  Click the 'Use Current Page' button in the 'Startup' section

You can also set your home page by dragging the favicon or lock icon and dropping it onto the 'Home' button. The
favicon/lock is the icon on the left of the website address bar.

File Edit View History Bookmarks Tools Help — O o

-ﬁ- Opticns C Comodo | Global Leaderin C X +

&« & . . Comodo Security Solutions, Inc. (US) W Q, Search »

L} Most Visited GJ Getting Started 33 Latest Headlines

From your bookmarks

«  To select a web page from your stored bookmarks, click the hamburger/'Open Menu' button at the top-right
corner then select 'Options' > 'General’ and click 'Use Bookmark'.
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Set Home Page X

Choose a Bookmark to be your Home Page. If you choose a folder, the

Bookmarks in that folder will be opened in Tabs.

[#] Bookmarks Toolbar
Bookmarks Menu
£y Other Bookmarks

Ok Cancel

«  Select your favorite page from the list and click 'OK'".

Set Default Home page

If you want to return to using Yahoo/Yandex as your home page, click the hamburger/'Open Menu' button at the top-
right corner then select 'Options' and click 'Restore to Default'.

4 4.Search the Internet

The Comodo IceDragon address bar also serves as a search box. By default, keywords typed into the address bar
will use Yahoo/Yandex as the search engine:

+  Enter your keywords or phrases into the address bar.

« To search, click the arrow at the right side of the address bar or press 'Enter' on the keyboard.

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 17
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File Edit Yiew History Bookmarks Teools Help _ O '
-I:I- Options ¥ | C Comodo | Global Leaderin . % -+
<« c ‘ Q. como - o ‘ » =

Q, como — Search with Yahoo! US

C COMODO — https://help.comodo.com/admin/product-285-show.ht...
C help.comodo.com — https://help.comodo.com/admin,/product-443...
C COMODO — https://help.comode.com/admin/myproducts.php

C COMODO — https://help.comodo.com/admin/product-120-show.ht...
C help.comodo.com — https://help.comode.com/admin/product-289...
O\ como hacer el amor

0\ como descargar videos de youtube

O\ como descargar minecraft

O\ como dice el dicho

Search for como with:

«  When you start typing a website address in the address bar, the browser automatically searches your
browsing history and your bookmarks and, provides auto-complete suggestions from them. This allows you
to easily find pages you have previously visited.

*  You can change the default search engine as per your preference. Please see 'Change Search Options'
for more details.

Click the links below for different ways to search the internet:
« Search adding to address bar
» Search using the Search box in the navigation tool bar
«  Search within a webpage
» the internet for a keyword from within a webpage

Search adding to address bar

IceDragon lets you to split the search bar and address bar.
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»  Click the hamburger/'Open Menu' button at the top-right corner
»  Select 'Options' >'Search'

»  Select 'Use the address bar for search and navigation' box or 'Add search bar in toolbar'

£ Find in Options

Search

Search Bar

Use the address bar for search and navigation

® Add search bar in toolbar

Search using the Search box in the tool bar

Comodo IceDragon can also display a dedicated search box to the right of the address bar. The search box is not
displayed by default. To add it:

+ Right-click anywhere on the file menu or navigation bar and select 'Customize'
OR

»  Click the hamburger/'Open Menu' button at the top-right corner then select the 'Customize' button

- O x
-n- Options x ‘ C Comodo | Global Leaderin C. X | ,# Customize IceDragen X + W
¢ o[
U@ Bookmarks Toolbar tems I R Sk
Drag your favorite items into the toolbar or overflow menu. Overflow Menu
C._) n = (4] ’y Drag and drop items here to keep them within reach
but out of your toolbar...
History Synced Tabs Mew Private Save Page
Window
Q ] @ &
Find Open File Sidebars Add-ons é

N

«  This will open the 'Customize Toolbar' panel. This panel allows you to simply drag the items you want onto
the navigation bar
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«  Drag the 'Search' box to the navigation tool bar.
«  Click 'Exit Customize'. The search box will appear in the navigation tool bar.
» By default, the search box uses Yahoo/Yandex.

- To change this, click the magnifying glass in the search bar and select 'Change Search Settings'.

ik you for Downloadin: X -ﬁ- Options X +
@ Q)search ‘ =
e
S Google Search
Search with: )
P FindinOpt 9 @
a fe
@ v
w i
ch and navigation
EEhangeSearch Settings )

By default, the search box uses Yahoo/Yandex.

«  That will open the 'Default Search Engine' under the 'Search' tab in the 'Options' dialog with list of
alternatives.

»  Select your favorite search engine from the drop-down.
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Default Search Engine

Choose the default search engine to use in the address bar and search b

& Google ®

Yahoo! US
G |
, in address bar results
™ Bing
J& @Mail.Ru
4. Amazon.com
jines that appear below the address b

A Ask Web Search
©@ DuckDuckGo

wvord.

W Twitter

W Wikipedia (en)

® Migtpvmka Mozilla
i eBay

Yahoo

Yahoo!

—: AT LUT LT

Search within a webpage

To search for a specific keyword/phrase from within a webpage:
»  Click the hamburger/'Open Menu' button at the top-right corner then select 'Find in This Page'
Or

e Press Ctrl + F on the keyboard.

A search box will appear at the bottom-right of the window:

User Rating

Find in page | ~ | \.:J Highlight All Match Case  Whole Words
e

»  Enter your search phrase and press 'Enter'. The first occurrence of the phrase will be highlighted on the
page.
« Tofind other occurrences, press 'Enter' again or use the up/down buttons beside the search box.

+ If you want to see all occurrences, click 'Highlight All'.

Search the internet for a keyword from within a webpage
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«  Highlight the word/phrase using your mouse, right click and select Search <your default search engine > for
“<selected keyword>".

& Motloggedin Talk Contributions Create account Login

Article Talk Read Edit View history |Search Q
Higgs boson
WIKIPEDIA 88
The Free Encyclopedia From Wikipedia, the free encyclopedia
Main page The [gl[sEEER] is an elementary particle in the Higgs boson
Contents Standard Mo Copy
Featured content quantum exc Select All

Current events
Random arfidle fundelamental Search Goegle for "Higgs boson”
physics theol View Selection Source

Donate to Wikipedia
1960s, that |

Wikipedia store Inspect Element (Q)
) glectromagnem- e mres e ror=roro-rorstenT
Interaction ) )
Help value almost everywhere. The question of the Higgs
About Wikipedia field's existence has been the last unverified part of
Community portal the Standard Model of particle physics and,
Recent changes according to some, "the central problem in particle
Contact page %] The presence of this field, now

+  Highlight the word/phrase using your mouse, copy using right click options or pressing Ctrl + C and paste it
in to the address bar or the search box.

+  Highlight the word/phrase using your mouse and drag it and drop in the address bar or the search box.

Further reading related to the topic of this page:
+ Bookmarks
+ View Browsing History

+ Downloads

4.5.Change Search Options
« Change the search engine used for keywords entered in the address bar
»  Turn keyword search off
» Configure URL Suggestions

To change the search engine

* Type about:config inthe address bar and press 'Enter'.

A warning will open:
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This might void your warranty!

Changing these advanced settings can be harmful to the stability, security, and performance of this
application. You should only continue if you are sure of what you are doing.

v Show this warning next time

| accept the risk!

«  Click 'l accept the risk!'

«  Type 'keyword' in the search field then double click in the Keyword.URL entry in the configuration page.

File Edit View History Bookmarks Tools Help

- O g
-I:I- COptions X | aboutconfig x +
<« C @ ce..gon  abouticonfig v | | Q Search =
£+ Most Visited @ Getting Started 3\ Latest Headlines
Search: = keyword x
Preference Name - Status Type Value 2=
C|DkeywordBackup. URL default string
ClDkeywordRetrived default boolean  false
keyword.URL modified  string http://go.mail.ru/distib/ep/?product_id=%7B39D7816A-6...
keyword.enabled default boclean  true

«  Alternatively, right-click on Keyword.URL and select 'Modify'
«  Type the URL of your desired search engine
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Enter string value >

9_. keyword LURL
=

http://go.mail.ru/distib/ep/? product_id="%:7B39D78

QK Cancel

Examples:
- To use Yandex Search engine, type “http://search.yandex.com/search?p="
« To use Bing search engine, type “http://www.bing.com/search?q="
- To search Wikipedia for the keyword, type “http://en.wikipedia.org/wiki/”
« Click 'OK'
- Toreset to Yandex search engine, erase the content in the keyword.URL dialog and click 'OK'’

To turn keyword search off

« Type about:configinthe address bar and press 'Enter' from the keyboard
«  Click 'l accept the risk!" in the warning dialog to view the About Config page

«  Type Keyword in the search bar to reach the item 'keyword.enabled'

»  Double click on the item to change the value of the item to 'false’

The keyword search from the address bar will be stopped. To enable the feature again, follow the same procedure to
change the value to 'true'.

Configure URL Suggestions

Comodo IceDragon displays a list of suggestions as you start typing a URL in the address bar by searching matching
strings from your browsing history and bookmarks. You can configure the items to be searched for providing
suggestions.

To configure suggestions
»  Click the hamburger/'Open Menu' button at the top-right corner.
»  Click 'Options' > 'Privacy & Security'.

» 'Address Bar' - Leave all check boxes enabled to draw suggestions from your browsing history, bookmarks
and open tabs.
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Address Bar

When using the address bar, suggest
v Browsing history

v Bookmarks

v QOpen tabs

Change preferences for search engine suggestions

Enable or disable search suggestions
You can enable or disable search suggestions in two ways:
« through the Search bar
« through the Search engine
Enable or disable search suggestions through the Search bar
« Right-click on the 'Search' bar
«  Click on a provider's logo to select another search engine
Enable or disable search suggestions through the search engines manager
+  Click the hamburger/'Open Menu' button at the top-right corner.
«  Click 'Options' > 'Search' tab.
OR
+ Right-click on the 'Search' bar
»  Click 'Change Search Settings' from the drop-down
«  Select/ deselect the check 'Provide search suggestions' box to enable / disable search suggestions.

«  Enable 'Show suggestion in location bar results' will also show suggestions when you search from the
IceDragon address bar.

Default Search Engine

Choose the default search engine to use in the address bar and search bar.
G Google l

¥ Provide search suggestions

v Show search suggestions in address bar results

To add a specific search engines
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»  Open the website
«  Click on the magnifying glass €& on the 'Search' bar
— O >

C‘? ynufpbe.cam 4

5 Google Search

(O https://www.youtube....
youtube.com .
youtube,com/activate
youtube.com activate
youtube.com.ua
youtube.comou
youtube.com akTneaTop
youtube.com/tv_help
youtube.com/tv_feed...
youtube.commp

Search for youtube.... with:

H &  a
Pr @
W W i

nﬂ Add “YouTube"

Change Search Settings

It will appear in your built-in search options:
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@ youtube.com =3

& Google Search

https:/fwww.youtube...,
youtube.com

-_—

youtube.com/activate
youtube.com activate
youtube.com.ua

k]

youtube.comou
youtube.com akTueatop
youtube.com/tv_help
youtube.com/tv_feed...
youtube.commp

Search for youtube.... with:

d} Add YouTube"

B o a
2@
W W i

Change Search Settings

«  And in your 'Default Search Engine' list.
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Show search suggestions in address bar results

One-Click Search Engines

Choose the alternative search engines that appear below the address bar and search

bar when you start to enter a keyword.

Search Engine Keyword
@ DuckDuckGo
Yahoo

W Twitter

LS LA

W Wikipedia (en)

® nNiatpumka Morzilla

i eBay
Yahoo!

v+ YouTube Video Search v

Restore Default Search Engines Remove

v
v

COMODO

Creating Trust Online®

To hide search engines
»  Click the hamburger/'Open Menu' button at the top-right corner then 'Options' > 'Search' tab
OR
Click on the magnifying glass in the 'Search' bar on your toolbar
«  Click 'Change Search Settings'

»  Uncheck the mark next to each search engine under the 'One-Click Search Engines'
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Google *
Provide search suggestions

¥ Show search suggestions in address bar results

One-Click Search Engines

Choose the alternative search engines that appear below the address bar and search

bar when you start to enter a keyword.

Search Engine Keyword

v @ DuckDuckGo
v Yahoo

v o Twitter

v W Wikipedia (en)

® MNiatpvmka Mozilla

v Wl eBay

v Yahoo!

v+ YouTube Video Search ,
Restare Default Search Engines Eemove

To remove search engine
«  Click the hamburger/ 'Open Menu' button at the top-right corner then 'Options' > 'Search' tab
OR
«  Click on the magnifying glass in the 'Search' bar on your toolbar and click the '‘Change Search Settings '
«  Select the search engine you are want to delete

«  Click 'Remove' to remove from your list
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One-Click Search Engines

Choose the alternative search engines that appear below the address bar and search

bar when you start to enter a keyword.
Search Engine Keyword
v @ DuckDuckGo
v Yahoo
v W Twitter

v W Wikipedia (en)

v ® MNigrpumka Mozilla

v Yahoo!

+" I YouTube Video Search

Restore Default Search Engines

+  Click 'Restore Default Search Engines' to add a default search engine back to the list.

4.6.Customize the Toolbar and the Menu

The IceDragon toolbar contains shortcuts to items such as your homepage and bookmarks. The content of the
toolbar is fully customizable.

To add or remove items on the toolbar
- Right-click anywhere on the file menu or navigation bar and select 'Customize'
OR
+  Click the hamburger/ 'Open Menu' button at the top-right corner> 'Customize'

This will open the 'Customize Toolbar' panel. This panel allows you to simply drag the items you want onto the
navigation bar.
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File Edit Vie Histo Bookmarks Tools Help — O e

C Cloud Antivirus | Comodo Fre ‘ -ﬂ- Options % | , Customize lceDragon X + W

> ¢ @[]

[#]) Bookmarks Toolbar lterns

Drag your favorite items into the toolbar or overflow menu. Overflow Menu
- = ~ items here to keep them within reach
Email Link Options Forget f your toolbar...
Developer Print MNew Window N “\JI
e = [\
Full Screen Bookmarks Library
Menu
¥ ]
Downloads Flexible Space
v
[ Title Bar Drag Space Toolbars  ~ |Z| Themes ~ “*| Density ~ Restore Defaults

- Toadd a tool, drag it from the dialog and drop on the toolbar. See table below for descriptions of icons

- Toremove a tool, drag it from the toolbar and drop it into the 'Customize Toolbar' interface

»  Click on the 'Title Bar' i display or hide the title bar

»  Check show / hide in the Toolbars' drop-down to configure visibility of the 'Menu Bar' or 'Bookmarks' toolbar

- To setatheme, click the Theme' drop down to 'Manage' or 'Get more Themes'. You will be taken to
IceDragon about:addons or Firefox add-ons webpage

»  Click 'Restore Default' to return IceDragon toolbars to their original state
»  Click 'Done' for your settings to take effect.

Table of Icons and their Descriptions

Icon Description

X Cuts the selected text from the form fields of the
currently displayed page and copies to the clipboard

Uy Copies the selected text from the currently displayed
page to clipboard

& Pastes the text in the clipboard to the selected form field
in the current page
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Zooms out/Zooms in the currently displayed page

Opens a new Comodo IceDragon window

Opens a new private window

Opens the History sidebar that show a list of recently
visited pages

|~ -/
E Prints the currently displayed page

1EI Displays the current page in Full Screen view

Find item in the current page

Opens Options interface

Opens Add-ons interface that shows a list of your
Appearence

Opens the web developers tools interface

¥ O ©

Q Inserts a search box to the navigation toolbar.

Opens the Downloads dialog that shows the list of
previous downloads and progress of the current
download

&

Enables subscription of RSS feeds from the currently
displayed page.

2

Switches the IceDragon window to Tab Groups view.

Opens the Bookmarks window that shows a list of your
bookmarks.

X
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A Opens the Firefox market place

Saves the currently opened page on html format

Provides a quick access to the file from your computer

Provides a quick access to the fonts Unicode ranges

Opens a new Comodo IceDragon tab

Opens the Bookmarks or History Sidebar

Shares by an interesting web page through the email
directly from the open IceDragon window.

A O P

Shares links to webpages or specific items from a page

4.7.0pen Recently and Most Visited Websites

If you accidentally closed a page without bookmarking and decide you need to see it again, then you can use the
'Most visited' and 'Recently Closed Tabs' features.

When you open a blank new tab in IceDragon, you will see thumbnails of your most visited sites so you can quickly
re-open them.

To view recent and most visited websites:
«  Click the icon at right of your open tabs:

File Edit View History Bookmarks Tools Help

@ MNew Tab x |+

c Q‘ Q Search or et

£+ Most Visited @ Getting Started )\ Latest Head||

©
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A tab will open containing thumbnails of your fifteen most visited sites.

To set the browser displays the most visited sites

* Inthe address bar, type about : config and click 'Enter'. "This might void your warranty!" warning
page will appear

»  Click 'l accept the risk!
»  Type browser.newtab.url
»  Double-click on it
Or
+ Right-click he string value > 'Modify'
«  Change the value to about:newtab and click 'OK'.

To disable the browser displays the most visited websites

* Inthe address, type aabout : config and click 'Enter'. "This might void your warranty!" warning page
will appear

«  Click 'l accept the risk!
»  Type browser.newtab.url
»  Double-click on it
Or
+  Right-click on the string value > 'Modify'
«  Change the value to about:blank and click 'OK'

« To view recently closed tabs, click the hamburger/ '‘Open Menu' button at the top-right corner then select
"History'

«  Toopen all recently closed tabs in a new tabbed window, click the hamburger/'Open Menu' button at the
top-right corner then select 'History' and select 'Restore Closed Tabs'.

Further reading related to the topic of this page:
+ Use Use Tabs

» CustomizieYour 'New Tab' Page

4.8.View Browsing History

Comodo IceDragon will store a log of web pages that you have visited for the past 10 weeks. From time to time you
may find it useful to look back through your history in order to revisit a particular site.

Please note, that Comodo IceDragon stores your browsing history only when it is used in standard mode and not in
Private Browsing mode.

Also, it does not store your browsing history when visiting secure websites. Comodo IceDragon also makes it easy
for you to manually delete your browsing history and thus further safeguard your privacy. See Delete your
Browsing History for more details.

This section explains how to view your browsing history.
« View a quick list of past fifteen pages

«  View full browsing history
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To view a quick list of your browsing history

«  Click the hamburger/ 'Open Menu' button at the top-right corner
+  Select 'Library' > 'History".

Alist of web pages that you have browsed in the recent past will be displayed.

W
L4 History

—] ~
E0 View History Sidebar

| @ Clear Recent History...
M Recently Closed Tabs >
] Recently Closed Windows >

Recent History

(13) YouTube

youtube.com - MNowck B Google

My search bar is gone - how to add i..
Comode lceDragon Help Guide - Int...
antiv - Mownck B Google

Google

coma - Mowck 8 Google

Office 365 Login | Microsoft Office
Bing

Cloud Antivirus | Comodo Free Proa...
Free Internet Security for Windows O...
Free Internet Security for Windows O...
Business Antivirus | Internet Security ...
Free Antivirus | Quick Virus Removal ..

Antivirus for Windows 10 | Free Antiv..,

AARARAANNNCQQeeNn@e o @

Comodo Free Antivirus Download | ..

Show All History

+  Click on the page you want to re-visit.

You can also see the pages that you have visited in your present browsing session by clicking and holding down the
forward and backward arrows adjacent to the address bar. Hover over a result and release the mouse key to switch
to that page.
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View full browsing history

«  Click the hamburger/ 'Open Menu' button at the top-right corner
« Select 'Library' > "History' > 'Show All History'.

A library window will open:

— O 5 _ O % - O X
w = fug = v o =
£ Signinto Sync < Library £ Histary
| '
l ) . ) ~
E3 New Window Ctrl+N 5 D View History Sidebar
e MNew Private Window Ctrl+Shift+P N @ Clear Recent History...
a Restore Previous Session * Downloads 5 B Recently Closed Tabs X
Zoom - e M Synced Tabs ’ B Recently Closed Windows >

Edit Recent Highlights Recent History

C comopo 0 (15) YouTube
>
COMODO 5 youtube.com - Mowck B Google
C y g
& Add-ons Ctrl+Shift+A i )
_3} - C Cloud Antivirus | Comodio Free Proa... @ My search baris gone - how to add .
ptions .
. C Comodo IceDragon Help Guide - Int...
,/ Customize... C Free Internet Security for Windows Q. - .
i . . 5 antiv - MNowuck & Google
C Business Antivirus | Internet Security ...
Open File... Ctrl+0 5 Google
Cc Free Antivirus | Quick Virus Rergoval ... -
Save Page As... Ctrl+5 & como - Mouck B Google
é Print... I'] Office 365 Login | Microsoft Office
m Bing
Q, Find in This Page... Ctrl+F -
C Cloud Antivirus | Comedo Free Proa...
More > . )
[C Free Internet Security for Windows O...
Web Developer > . )
[C Free Internet Security for Windows O...
(7 Hel >
@ i [C Business Antivirus | Internet Security ...
(D Exit Ctrl+Shift+Q C Free Antivirus | Quick Virus Removal ...
v IC Antivirus for Windows 10 | Free Antiv...
W

C Comodo Free Antivirus Download | ...

5 comodo antivirus - Mowck B Google

e Protection | Comodo BOCL... Ll

A\ Show All History

Double-click on the time period for which you want to see the browsing history. You can choose from yesterday, the
previous week and previous months.
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&) Library = O .
) Organize - Views~ g Import and Backup - 12 Search History
w @ History Location
@ Today https:/fwww.comodo.com/home/browsers-toolbars/icedragon-browser.php 2
@ Yesterday https:/fwww.google.com/searchg=about*3Aconfigllie= utf-28oe=utf-B8clien..,
@ Last 7 days https://www.google.com/search?q=about+config&lie= utf-8&ce=utf-88iclient=f...
(© This month https://www.google.com/search?q=about+%D0%BF%D0%E5%01 %80%D0%E5. .
@ March https:/fwww.google.com/search?g=procedurelie=utf-880e=utf- B8 client=firef...
@ January https://cdn.download.comodeo.com/cis/download/installs/ 1000/ partners/ cispre...
@ December 2017 https:/fantivirus.comodo.com/downloadfwin-10-thank-you.phpfprod=win-108..,
@ Movember 2017 https:/fwww.google.com/search?g=dowlcad+antivirus+ comodo&lie= utf-88oe,.,
(© Older than & months https://www.comodo.com/
¥ Downloads https://search.yahoo.com/yhs/search;_ylt=Awrlz849ruFalBoAcQOPxCt.;_ylu=X3...
 Tags https://search.yahoo.com/yhs/search;_ylt=AwrlzBkSruFaHU4ABWOPxCt.;_ylu=X3...
~ | All Bookmarks https://searchyahoo.comfyhs/search;_ylt=A2KLfaEaruFaezMAyDEPxCt._yle=X1..,
~ [] Bookmarks Toolbar e o e VPR PP N S
4L+ Maost Visited Mame: | (15) YouTube |
) Latest Headlines Location: | https://www.youtube.com/ |
Bookmarks Menu Tags: | Separate tags with commas | b
@ Other Bookmarks

The list of visited pages for that time period will be displayed.
»  Double click on the webpage you want to re-visit.
Further reading related to the topic of this page:
»  Delete Browsing History
+ Use Tabs

4.9.Set Fonts, Languages and Encoding

Comodo IceDragon lets you change the way web pages are shown on your screen. You can configure the fonts,
color and language of page content.

«  Configure fonts and colors
« Configure language

To configure fonts and colors

+  Click the hamburger/ 'Open Menu' at the top-right
»  Click 'Options' > 'General'

+  Click the 'Default fonts' drop-down under 'Fonts & Colors' then select the font and font size that you want
the browser to display.
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£ Find in Options

Language and Appearance

Fonts & Colors

Default font  Default (Times New Roman) * Sjize 16 - Advanced...

Colors...

»  Click 'Advanced' next to the font options to open a new box with detailed choices for configuring fonts.

Fonts X
L]
Fonts for Latin -
Proportional = Serif *  Size 16 A
Serif  Default (Times Mew Roman) -
Sans-serif  Default (Arial) -
Monospace  Default (Courier New) * Size 13 -

Minimum font size  MNone -

v Allow pages to choose their own fonts, instead of your selections above

< >

oK Cancel Help

»  Deselect the check box 'Allow pages to choose their own fonts, instead of my selections above', to
disable the browser from using the fonts and colors as set by the websites and to display the pages
with your font/color choices.

« To change the character encoding language, click the 'Fallback Text Encoding' in the "Text Encoding for
Legacy Content' drop-down.

»  Click 'Colors' beneath the 'Advanced' button to open the colors interface box.
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Colors X

Text and Background Link Colors

Text B Unvisited Links ]
Background L1 visited Links ]

Use system colors v Underline links
Qverride the colors specified by the page with your selections above
Only with High Contrast themes ~
oK Cancel Help

Click on the color patch and select the desired color from the palette to change the colors in which the text,
background and links will show.

Link Colors

B Unvisited Links:

N o
NEE [ ENEEN
EEET ENEEEn
| [ [ ] f ] |
EEENEEEEEE
AN EEEEEN
HEEEEEEEEE

‘Override the colors specified..." - will force web pages to use your display settings when rendering pages.
This is especially useful for people with visual disabilities.

To configure the language

Click the hamburger/ 'Open Menu' at the top-right
Click 'Options' then 'General'
Click 'Choose' button under the 'Language' section.

The 'Languages' screen:
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2 Find in Options

Language
Choose your preferred language for displaying pages Choose...

v Check your spelling as you type

Languages

Web pages are sometimes offered in more than one language.

Choose languages for displaying these web pages, in order of

preference
English/United States [en-us] Move Up
English [en] e
Eemove
Select a language to add... 2 Add
OK Cancel Help

« The languages that are currently added to the browser are listed in the order of their usage preference.

« Toadd a new language to the browser, click the drop-down button beside 'Select a language to add...",
select your desired language from the drop-down, click 'Add'".

« To change the order of preference of languages to be used by the browser, select the language and use
‘Move Up' and 'Move Down' keys.

- Toremove a language from the browser, select the language and click 'Remove'".
«  Click 'OK" for your changes to take effect.

To set a language as your a default
+  Click the hamburger/ 'Open Menu' at the top-right

»  Click 'Options' > 'Languages'
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File Edit View History Boockmarks Tools Help

#— Options X +

&« C o ceDragon  aboutpreferences#languages %

¥ Most Visited 0 Getting Started ) Latest Headlines

2 Find in Options

-ﬁ- General Languageg
Q Search

n Privacy & Security

2 Search

Language =« | Action
R . . ”~

S Firefox Account ‘= Chinese (Simplified) Set as default

‘& English Current
Ibﬂ Languages

& French Set as default

‘= German Set as default

‘= ltalian Set as default

‘& Portuguese Set as default

‘= Romanian Set as default

‘= Russian Set as default
@ IceDragon Support

‘&= Spanish Set as default

«  Select the language and click 'Set as default'

«  Click 'OK" to restart IceDragon for the settings to take effect.

4.10.  Configure lceDragon Updates

To make sure you benefit from the latest feature and security updates, Comodo IceDragon automatically downloads
updates when it detects that a new version of the browser is available.

» By default, the updates will be downloaded in the background and installed automatically when one is
available or when you restart IceDragon.

«  The notification to restart IceDragon and install the update will be displayed if the updates has been waiting
to be installed for more than 24 hours.

To configure updates automatically
«  Click the hamburger/ 'Open Menu' button at the top-right corner
«  Click 'Options' > 'General' panel.

« 'lceDragon Updates' - Select 'Automatically update search engines' to receive automatic updates to your
search engines. Enabled = default.
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'I:I' General
Q Search

@ Privacy & Security Version 58.0.1 (32-bit) What's new

lceDragon Updates

Keep lceDragon up to date for the best performance, stability, and security.

9 e DT v Automatically update search engines

Pe Languages IceDragon updates:
® Automatically install updates (recommended; improved security)
Check for updates, but let me choose whether to install them

Mever check for updates (not recommended: security risk)

If automatic updates are disabled then IceDragon will not silently install updates. Instead, you will be alerted when
updates are available via the notification bar.

To configure updates manually
»  Click the hamburger/ 'Open Menu' button at the top-right corner then select 'Options'
»  Click the 'lceDragon Updates' panel under the 'General' tab
»  Check the 'Automatically install updates (recommended: improved security)' box to automatically

downloads and installs updates

«  Check for updates, but let me choose whether to install them to choose a moment when to download
and install updates. You can download them at a later time, if you do not choose to do that

»  Never check for updates (not recommended: security risk) to will not check for updates. Note: If this
setting is selected, it will disable you from receiving critical security updates that may keep you safe
online unless you frequently do a manual check for updates.

You can configure updates for add-ons and extensions by clicking the hamburger button at top-right then 'Add-ons' >
'Extensions’.

«  Click the gear icon then select 'Check for Updates' or 'View Recent Updates'.

Search all add-ons jo
*
,@ Get Add-ons

Check for Updates
View Recent Updates ated -
*- Extensions ) e
Install Add-on From File...
== Widevine C... Debug Add-ons .

..o/ Themes Play back prote.. Update Add-ons Automatically

-— . Beset All Add-ons to Update Automatically
- ptions Always Activate ~

This plugin is au... More
P@ Dictionaries

ﬁ Legacy Extensions

*} Recent Updates
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4.11.  Portable Version

Comodo IceDragon can also be installed in portable mode. As the name suggests, portable mode allows users to
quickly launch and use their pre-configured Comodo IceDragon on any computer without the need to install, import
bookmarks or modify settings.

In portable mode, the user profile (configuration data) is written to the IceDragon installation folder instead of the
Windows ‘user’ folder on the local machine. Therefore, by simply copying the installation folder to another drive
(such as a USB fob or a drive on another computer), you will be able to launch and use your personalized Comodo
IceDragon.

Portable mode must be selected during the installation process:

COMODO IceDragon Setup
Choose Install Location

E Choose the folder in which to install IceDragon.

Setup will install IceDragon in the following folder. To install in a different folder, click Browse and
select another folder. Click Install to start the installation.

Destination Folder

| C:\Program Files (x86)\Comodo\IceDragon

[ Import From Firefox

[ Portable version (user profile is stored in destination folder)

Space required: 50 MB
Space available: 6274 MB

There are a few differences to setup if portable mode is selected:
»  The Installer does not write anything to the Windows registry
* Uninstaller is not created

«  User profile is stored in the "User Data" folder inside the main Comodo IceDragon installation folder.

412.  Uninstall IceDragon

»  Click 'Start' > 'Settings' > 'Control Panel'
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« Inthe list of currently installed programs, click '‘Comodo IceDragon'

» Inthe 'Control Panel', select 'Programs and Features', double-click 'Uninstall/Change'

OR
+  Click Start > All Programs > Comodo > IceDragon > Uninstall Comodo IceDragon.

Recently added

4 Comodo lceDragon
%4 Uninstall Comodo lceCiragon

3 Dragon Help Page

Expand *~

The 'Uninstall Comodo IceDragon' dialog will open:
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COMODO IceDragon Uninstall

Uninstall Comodo IceDragon

@ Remove Comodo IceDragon from your computer.

Comodo IceDragon will be uninstalled from the following folder. Click uninstall to start the
uninstallation.
Uninstalling from

i C:\Program Files (x86)\Comodo'\IceDragon

[ Remove user profile

Uninstall

« By default, you will be provided a choice to save your IceDragon profile data in your computer.

« Ifyou plan to install IceDragon again at a later time, IceDragon will use this profile data to configure
your new installation.
 If you do not wish to retain or transfer your browser settings, select the checkbox '‘Remove user profile'.

The screen displays the selection of the folder in your hard drive for installing Comodo IceDragon. The
default installation location is C:\Program Files (x86)\Comodo\lceDragon.

e Click 'Uninstall' button to run the uninstallation.

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 45



COMODO

Creating Trust Online®

COMODO IceDragon Uninstall

Uninstalling

@ Please wait while IceDragon is being uninstalled.

BExecute: C:\Program Files (x86)\Comodo\IceDragon'certsentry_setup.exe fu IceDragon

« On completion, click 'Finish' to close the window.
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COMODO IceDragon Uninstall
Completing the Comodo IceDragon uninstallation

Comodo IceDragon 58.0.0.11 has been uninstalled from your computer.

Click Finish to close Setup.

5. Tabbed Browsing

This section explains how to use tabs to view websites in Comodo IceDragon. Click the following links to find out
more:

+ Usetabs
»  Customize Your New Tab Page
« Tab Settings

5.1.Use Tabs

Each time you open a web-page in Comodo IceDragon it will display what is known as a 'tab'.
- Multiple tabs can be opened at once. Each tab contains a different webpage.
»  Click any tab to switch straight to that page.
»  Click the 'new Tab' button to open a blank tab.
»  Click the 'X" button on the right of the tab to close a tab.
» Toopen anew tab, click the icon, which is next to the last tab:
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File Edit View History Bookmarks Tools Help

@ MNew Tab x |+

c Q‘ Q Search or et

£+ Most Visited @ Getting Started )\ Latest Head||

©

« Torearrange tabs, left-click on a tab, hold-down the mouse button then drag the tab to its new position

« When you open a new, 'blank' tab, it will display a list of your most visited websites for your easy access:

»  Customize Your 'New Tab' Page
» Tab Settings

5.2.Customize Your 'New Tab' Page

» By default, when you open a new tab you will see a list of your most visited websites.
»  However, you can make the 'New Tab' page display whatever pages you want.

« Each website is displayed as a tile. Tiles can be deleted and rearranged as you see fit.
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File Edit View History Bookmarks Tools Help _ =] =
C Comodo| Global Leaderin C. X | @) New Tab x | +
(e ‘m‘ Q, Search or enter address E =
£} Most Visited @ Getting Started 33 Latest Headlines
© A
Q, Search the Web -
28 TOPSITES v Edit | @
— -
- w A
e . - - DOMAIN CENTRAL
C = v = [ waC
= V
help.comao... one.comodo web.archive archive comodogroup.c... domaincentral
2> HIGHLIGHTS v
e
GoodNewsNetwork
BLOGMOZILLA GOODNEWSNETWORK HELP.COMODO
Progressive Web Apps are Good News, Inspiring, COMOoDO
here. What's the big deal? | Positive Stories - Good
The Firefox Frontier MNews Network
The web is the largest software Your daily source for enly good
W Bookmarked Wy Bookmarked W Bookmarked
Lf Survey Says, Firefox Loves Oddballs! Read the results of our annual Firefox survey and get to know your fellow Firefox fans.
W

To add a site to the new tab page
» Openanew tab
Click bookmarks icon on the Toolbar menu then select 'Show All Bookmarks' to open the 'Library" window
+  Select a bookmark and drag it to the new tab page
To pin /unpin top sites
e Openanew tab
»  Place your mouse over a tile
e Al **= will appear in the top-right corner of the tile

«  Click the icon then select 'Pin' to lock or unlock the page
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Q. Search the Web —

28 TOP SITES ~ Edit | @

oI [? Openina New Window

-

help.comodo one.comode ©2 Openin a New Private Window
X Dismiss
A _
DOMAIN CENTRAL| T Delete from History
ur

wal

comodogroup.c.., demaincentral

To rearrange top sites
«  Simply click and drag the tile into the position you prefer.

as TOP SITES ~ Edit | @

-

help.como one.comodo archive
p- ' DOMAIN CENTRAL
— -
A
DOMAIN CENTRAL domaincentral
wal
comodogroup.c. domaincentral

To open a tile in a new window
»  Hover the mouse cursor on a tile

+  Click the three-dot icon at top-right
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»  Select 'Open in a New Window'
To open a tile in a new private window
»  Hover the mouse cursor on a tile
»  Click the three-dot icon at top-right
«  Select "Open in a New Private Window' to avoid saving in your browsing history.
To remove a tile
»  Hover the mouse cursor on it
«  Click the three-dot icon at the top-right corner
+  Click 'Dismiss'
To delete a tile from history
»  Hover the mouse cursor on a tile
»  Click the three-dot icon at top-right
»  Select "Delete from History' to remove a site from your browsing history.
To customize your top sites section
There are the following options available: 'Edit' and 'New tab Preferences'.
«  Hover your cursor over the tile and click 'Edit'
»  Click 'Add' button and type a name for the site and a URL to pin a specific site to top sites
+  Click 'Add' to save your settings.
»  Click 'Show More' / 'Show Fewer' button to add /remove a row of top sites
+  Click 'Done' for the settings to take effect.
Customize New Tab Preferences
This lets you configure sites to be viewed on a new tab.
« Hover your cursor over the tile and click the @ icon
OR
«  Click the cog icon at the upper-right
«  Check 'Search box to display the search text box in the new tab
»  Check Top Sites' to access the most visited sites

»  Select 'Show two rows' to view more rows of top sites

»  Select 'Highlights' to enable sites you have recently visited or bookmarked. You will see: Top sites, media,
an animated GIF.

* You can: Bookmarks, Save to pocket to manage articles, (save, remove or open article in a new tab).
«  Select 'Snippets' to view the 'Progressive Web Apps'

»  Click 'Done' for the settings to take effect.
To reset the page to show blank thumbnails, clear the browsing history. To do this,
+  Click the hamburger/ 'Open Menu' button at the top-right corner

+  Click 'Library' > 'History' > 'Clear Recent History' > select 'Clear Now' button.

5.3.Tab Settings

The following sections explain more about:
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«  Configure tab settings

» Restore previous session from the homepage

» Restore the previous session from the main menu

» Re-open tabs from your last session when you next start IceDragon

» Use right-click options

To configure tab settings

»  Click the hamburger/ 'Open Menu' button at the top-right corner

»  Click 'Options' > 'General' button:

Tabs
Ctrl+JIab cycles through tabs in recently used order
v Open new windows in a new tab instead
Warn you when closing multiple tabs
v When you open a link in a new tab, switch to it immediately

Show tab previews in the Windows taskbar

»  CTRL+Tab cycles through tabs in recently used order — Lets you use Ctrl+Tab to view open tabs one at
atime.

«  Open new windows in a new tab instead - This option allows you to determine whether links from other
applications or from web pages are opened in a new window or a new tab in the most recent window.

»  Warn you when closing multiple tabs — You will get an alert when trying to close multiple tabs. This is
useful if accidentally try to close the browser while background tasks are in-progress.

«  When you open a link in a new tab, switch to it inmediately - Check this option to load and display the
page in a new foreground tab.

»  Show tab previews in the Windows taskbar - Check this option to show a separate preview for each tab.

To restore a tab or a window from the homepage menu

+  Click the hamburger/ 'Open Menu' button at the top-right corner
»  Click 'Options' > 'General'

* Inthe 'Home page' area, click 'Restore to Default!
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£ Find in Options

When IceDragon starts

Show your home page

Show a blank page

® Show your windows and tabs from last time

Home page

https.//www.comodo.com

Use Current Page Use Bookmark... Eestore to Default

To restore from the main menu

«  Click the hamburger/ 'Open Menu' button at the top-right

«  Select 'Restore Previous Session'

— O >
o,
N
v ozl = |
£3 Signinto Sync
£ New Window Ctrl+ M
&2 New Private Window Ctrl+5hift+P
Zoom — W% 4
Edit &
Library

To re-open the tabs from your last session when you next start IceDragon
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»  Click the hamburger/ 'Open Menu' button at the top-right corner
»  Select 'Options' > 'General' tab

«  Under 'Startup' select 'Show your windows and tabs from last time' from the 'When IceDragon starts'

General

Startup

v Always check if IceDragon is your default browser

. IceDragon is not your default browser Make Default...

When IceDragon starts

Show your home page
Show a blank page

@Shmw your windows and tabs from last time

Right-click options

» Right-click on any tab to open a context-sensitive menu:

Jiew History Bookmarks Tools Help

b4 :#! Good Talks - Inspiring Podca: X +
e Beload Tab
3 ﬁ} @ & https:/fwww.goodne Mute Tab

sited @) Getting Started 33y Latest Headlines Pin Tab
Duplicate Tab

. Move to Mew Window

ey S5end Tab to Device >

Talks Good Gifts Reload All Tabs
Bookmark All Tabs...

Close Tabs to the Right
Close Other Tabs

Undo Close Tab

vod Business  Good Health  GMN Podcast Elose Tab
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* Reload Tab - Refreshes the page
»  Mute Tab - Turns off the sound of a particular tab
« Pin Tab - Pins the tab to left of the browser window
» Duplicate Tab - Copy a URL in current tab and open it in a new tab
*  Move to New Window - Opens a tab in a new window
+ Send Tab to Device — Send tab from your desktop to your mobile devices:
« Signinto Sync - To use a setting on any computer that has IceDragon installed.

« Reload All Tabs — Reopens last closed tab in the same tab location of the browser window
» Bookmark All Tabs — All tabs that are currently open in the browser will be bookmarked
+ Close Tabs to the Right - Closes tabs to the right
»  Close Other Tabs - Closes all other tabs
« Undo Close Tabs - Undoes closed tabs through a toolbar button or the right-click context menu
+ Close Tab - Closes the tab

Further reading related to the topic of this page:

+ Use Tabs

»  Customize Your 'New Tab' Page

6. Bookmarks

Bookmarks are an easy way to save links to your favorite web-pages so you can quickly visit them later. This section
shows you how to create, edit and manage bookmarks. Click the following links to find out more.

»  Create Bookmarks
+ Find and Edit Bookmarks
» Manage Bookmarks

« Import and Export Bookmarks

6.1.Create Bookmarks

There are multiple ways to create a bookmark:
Method 1
When on a webpage that you want to bookmark, simply click the star at the right of the address bar:
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File Edit View History Bookmarks Tools Help

-I:I- Opticns x

:#2 Good Talks - Inspiring Podca: X +

< c @ @ @& https://www.goodnewsne ser @ ww @ =4 =

L3 Most Visited el Getting Started 33\ Latest Headlines

File Edit View History Bookmarks Tools Help

-I:I- Opticns x

:#2 Good Talks - Inspiring Podca: X +

h J
<« c ‘@' @ & https:/fwww.goodnewsne see 0 -,@ E.

I+ Most Visited ﬁ Getting Started 3 Latest Headlines

Once bookmarked, the star will change color to blue.

On all subsequent visits to bookmarked pages, you will see this blue star.

By default, a bookmark will be created in the 'Other Bookmarks' folder.

Click the star to open option menu which allows you to modify bookmarks:

File Edit View History Bookmarks Tools Help

-I:I- Dptions X | i=2 Good Talks - Inspiring Podca: X +

< c @ (@ & https://www.goodnewsne we

£+ Most Visited @ Getting Started 33 Li

* Page Bookmarked ~

Wl = Good Talks - Inspiring Podcasts and Spe

-

g
»
[
i

Jo

Good News Good Talks Gg Folder |{<Other Bookmarks il
Tags: | Separate tags with commas | o
Done Bemowve Bookmark

You can remove the bookmark or change the folder in which the bookmark is saved.
Method 2
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* In the '‘Bookmarks' menu bar, select '‘Bookmark This Page'
Method 3
To bookmark all open tabs at once,
»  Right-click on any tab and select 'Bookmark All Tabs..."' on the context sensitive menu
»  Next, assign a name for the set of bookmarks and specify the folder in which they should be saved
»  Click 'Add Bookmarks' to save your bookmarks.
Method 4
You can import bookmarks from other browsers.
Method 5
Drag and drop a link or URL onto the 'bookmarks' button on the right of the address bar.
Method 6
Use the keyboard short cut CTRL+D to bookmark the page you are currently viewing.
The following links contain further reading on bookmarks:
+ Find and Edit Bookmarks
» Manage Bookmarks

» Import and Export Bookmarks

6.2.Find and Edit Bookmarks

The bookmark bar under the address bar displays all your bookmarked pages and folders.
If you have not docked the bookmark bar, follow the steps given below:

File Edit View History Bookmarks Tools Help

- I >
omodo lcelragon Browser :#2 Good Mews, Inspiring, Positive
Comodo IceDragon B X | 222 Good News, Inspiring, Positive X | =+
< c ‘@' (D @ https;//www.goodnewsnet see @ oww T » =
ost Visite etting Starte rom Internet orer
i} Most Visited c Getting 5 d E F | Expl
— F o

»  Dock the bookmark bar

» Add bookmarks to the bookmarks toolbar

* Relocate bookmarks on the bookmarks toolbar
» Right-click options

+ Edit bookmarks

* Delete bookmarks

To dock the bookmark bar
»  Click the hamburger/ 'Open Menu' button at the top-right corner then select 'Customize'
»  This will open the 'Additional Tools and Features' page

»  Click the "Toolbars' drop-down at the bottom and enable 'Bookmarks Toolbar'

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 57



Creating Trust Online®

Comodo IceDragon - User Guid e comMono

Click the 'Done' button or close the tab

The new toolbar will immediately appear below the address bar
Add bookmarks to the hookmarks toolbar

Open the web page to be added to the bookmarks toolbar

Click and simply drag the web site icon on to the bookmarks toolbar in the 'Location' bar
File Edit View History Bookmarks Tools Help

-I:I- Options x

222 Good Talks - Inspiring Pc X

< c @

o
g
I
43

[

s
O
Relocate bookmarks on the bookmarks toolbar
»  Click the bookmark or folder and drag it into new position.
Right-click options on the bookmark bar
The following options are available when you right-click on the bookmark bar:
«  OpenAllin Tabs
*  New Bookmark
*  New Folder
*  New Separator
+ Paste
To edit bookmarks
+  Click the blue star on the address bar
File Edit View History Bookmarks Tools Help — 0O %
$¢ Options ¥ | 222 Good Talks - Inspiring Podcz- % | =+
<« ¢ ‘@' @ & https://www.goodnewsne (Ll

-}
e
»
[z
i

4t Most Visited @) Getting Started S Li

* Page Bookmarked ~

] Q

[WEl AN Good Talks - Inspining Podcasts and Spe

Good News  Good Talks  Gg Folder: | [\Other Bookmarks Y
Tags: | Separate tags with commas | hd
Done Remowve Bookmark
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«  Name - Bookmarks label.

»  Folder — Default folders to store your bookmark (Bookmarks Toolbar, Bookmarks Menu, Other Bookmarks).
Click the arrow beside the drop-down to specify a different folder or create a new folder.

- Tags - Set tags for the bookmark. Tags can be searched from the IceDragon address bar.
»  Click the arrow button to expand the 'Folder' / 'Tags' or to create a new folder.
To delete bookmarks
«  Open the page in your bookmarks
Click the star icon and click 'Remove Bookmark' button
Please note: When you delete a folder, all the bookmarks in the folder will also be deleted.
To set the toolbar icon
«  Click the hamburger/ 'Open Menu' button at the top-right corner then select 'Customize'
»  Drag the bookmarks tool to the bookmarks tool bar
»  Click the 'Done" button to appear in the bookmarks tool bar.
To show/hide the bookmarks toolbar
«  Click the hamburger/ 'Open Menu' button at the top-right corner then select 'Customize'

»  Uncheck the 'Bookmarks Toolbar' in the "Toolbars' drop-down.

6.3.Manage Bookmarks

Comodo IceDragon allows you to organize your bookmarks. From here you can edit, delete or rename bookmarks
and folders.

To organize your bookmarks
»  Click the 'Show your bookmarks' icon next to the address bar
«  Select 'Show All Bookmarks'

The 'Library" interface will be displayed.
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L+ Most Visited 0 Getting Started 33y Latest Hea B

View Bookmarks Sidebar .
E ¢ Show All Bookmarks Ctrl+5Shift+B L
]
|:E Bookmarks Toclbar 3
Good News  Good Talks  Good Giff /&, Other Bopkmarks >
I} Recently Bockmarked b
£} Recent Thgs b
L J
& Library = O x
' Organize - Views = g Importand Backup = | © Search Bookmarks
A @ History Location
@ Today http://www.google.com.ua/search?q=minya+gtoyz+c+.n. %2 Cf&ie= utf-8&oe.. ™
@ Yesterday http:/www.zisman.ca/lmpress/index.html
@ Last 7 days https://sps.comodo.net/marketing/Shared %200 ccuments/Forms/DispForm.a...
@ This month http://www.positivessl.com//ssl-certificate- products/ssl/ssl-warranty. html

@ March
@January

@ December 2017
@ Movemnber 2017
@ Older than & months
3 Downloads
o Tags
~ gl All Bookmarks
~ [%] Bookmarks Toolbar
L Most Visited
:'\'h Latest Headlines
Bookmarks Menu
@ Other Bookmarks

http:/fwww.comodo.com/partners/comodo-partner-program.php
http:/fwww.kinopoisk.ru/level/4/people/301682/7
https://sps.comodo.net/marketing/Shared %:200ocuments/Forms/Alllterns.as...
http://help.comodo.com/
http://help.comeodo.com/topic-167-1-330-4244-5pecial-Features.html
http://maketecheasier.com/more-google-chrome-omnibox-tips-and-tricks/2...
http://dev.chromium.org/user-experience/omnibox

http:/fwww.enterprisessl.com//ssl-certificate-corporate/ssl- certificate- contact....

L EE | ] Lo 1 [T A - P ..

Mame: | Creating presentations using OpenOffice's Impress |

Location: | http:/fwww.zisman. ca/lmpress/index.html |

Tags: | Separate tags with commas | e

w More

From here you can:

«  Search bookmarks

» View/ sort bookmarks

* Rename / edit bookmarks
* Delete a one bookmark

*  Delete multiple bookmarks
*  Move a bookmark

To search bookmarks
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»  Enter the bookmark name in the search box in the 'Library' interface
Or
«  Enter the bookmark name in the search box from the Side bar.

2 Search Boockmarks

To view / sort bookmarks
«  Click the Bookmark button and select 'Show All Bookmarks'

«  Click the 'Views' button to open menus which allow you to sort bookmarks by various criteria, and to add
additional columns to the bookmarks table.

»  Alternatively, right-click on the 'Bookmarks Toolbar' folder and select 'Sort By Name'
To rename a folder, bookmark or edit its address
»  Select the bookmark you want to edit
»  Click the star icon and change the name of the bookmark in the 'Edit This Bookmark' dialog
OR

+  Click the 'Show your bookmarks' icon next to the address bar. Select a bookmark from the list and edit its
name or URL using the fields at the bottom of the interface

To add a new bookmark folder

«  Select the location you want to add new bookmark folder in the left side

+  Click the 'Organize' menu and select 'New Folder'

*  You can also right-click on the desired location and add a new folder from the menu.
To delete bookmarks or folders

«  Click on the staricon in the 'Location' bar

«  Click the 'Remove Bookmark' button

OR

«  Click the 'Show your bookmarks' icon on the right of the address bar

+  Select 'Show All Bookmarks' to open the 'Library' window

« Inthe left pane, click on the folder you want to view (its content appears in the right pane.)

«  CTRL+click to select multiple items

» Right click on the selected items and select 'Delete’ (or click 'Organize' > 'Delete’)

To move bookmarks

Just click and drag a bookmark or folder to another destination to the folder list in the left side.

6.4.Bookmarks - Import, Export and Back up

You can import bookmarks from other browsers, to export bookmarks to HTML and automatically create backups of
your bookmarks on a daily basis (allowing you to restore them at any point).

Click the following links for more help:
* Import bookmarks

» Import bookmarks from any browser as a HTML file
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»  Export bookmarks
» Restore from backup
To import bookmarks from Microsoft Edge and Internet Explorer
+  Click the 'Show your bookmarks' button
+  Select "Show All Bookmarks'

+  Click the 'Import and Backup'

vz u |mport and Backup - 10 Search Bookmarks

Loc Backup...

http Restore > be+.nS62Cf8le=
http Import Bookmarks from HTML...

http Export Bookmarks to HTML... ents/Forms/Dis
http ssl/ssl-warrant

Import Data from Another Browser...

-program.php

v kinopaisk.ru/level/4/peaple 301627

»  Select 'Import Data from Another Browser'.

| .
Import Wizard >

Import Settings and Data @ ‘

| Import Options, Bookmarks, History, Passwords and other data from:
! (®) Microsoft Edge
| () Microsoft Internet Explorer

Please ensure the selected browser is closed before continuing. |

< Back Mext = Cancel

»  Select the browser from which you want to import then the specific items you wish to import:
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Import Wizard

Items to Import

Select which itermns to import:

Cookies
Browsing History
Favorites

= Back Mext =

Cancel

« Cookies: Small files stored on your computer by websites you have visited that contain information
about your preferences while on that website. Cookies are used for such things as keeping you logged

in to a website and to save your site preferences
«  Browsing History: Alist of URLs that you have recently visited

« Favorites: (also known as 'Bookmarks'). Imports your bookmarks from the source browser

«  Click the 'Next' button then click 'Finish' at the confirmation dialog:

Import Wizard

Import Complete

P

X

The following itemns were successfully imported:
Cookies
Browsing History

Favaorites

< Back Finizh

Cancel
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Bookmarks from the other browsers will now be available in Comodo IceDragon in a folder named 'From Internet
Explorer' or 'Microsoft Edge'.

» To view and access your bookmarks, simply click the bookmarks button.

»  All Bookmarks (including any imported) will be listed in the menu:

Eile Edit View History Bookmarks Tools Help — 0 e
222 Good Mews on this Day in Hist: X -l:- Options x | +
& o @ B nhttps://www.goodne E] e & w o n =

4} Most Visited (@) Getting Starteq” [ From Internet Explorer

E .._. Q

To import bookmarks from any browser as a HTML file

»  Click the 'Show your bookmarks' button then 'Show All Bookmarks'

»  Click the 'Import and Backup' tab on the 'Library’

»  Click 'Import Import Bookmarks from HTML'

» Navigate to the HTML file saved in your computer and click 'Open’.
To export bookmarks

»  Click the 'Show your bookmarks' button then 'Show All Bookmarks'

»  Click the 'Import and Backup' tab on the 'Library'

»  Select the 'Export Bookmarks to HTML'

»  Choose a location where you want the bookmarks to be saved and click the 'Save' button
To restore from backup

+  Click the 'Show your bookmarks' button then "Show All Bookmarks'

+  Click the 'Import and Backup' tab on the 'Library'

»  Click 'Restore'. Select the backup from which you want to restore

«  The dated entries are automatic backups.
« 'Choose File..." lets you restore from a manual backup.
The 'Revert Bookmarks' dialog will appear, click 'OK'.

Revert Bookmarks >

9_. This will replace all of your current bookmarks with the backup. Are you sure?
=

QK Cancel

After choosing a backup, your bookmarks will be restored.
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This section explains how to configure privacy and security settings in Comodo IceDragon as per your browsing
requirements. By default, lceDragon is designed to ensure your private data remains safe and secure while browsing
online.

Click the links to find out more:

+ Private Browsing

+ Delete browsing history and configure history settings

+ Allow/block pop-up windows

« Manage cookies

+ Block websites from tracking your browsing history

+ View and manage permission settings

+ Configure suggestions when entering a website address
« Manage Cache

+ Manage Add-on Permissions

+ Manage passwords

+ SSL Certificates and Secure Connections

«  SSL/HTTPS security settings
« Force Secure Connections
«  Website Security Indicators
» Disable accessibility indicator setting
»  Configure IceDragon performance and browsing settings

»  Network Proxy settings

7.1.Private Browsing

In a private browsing session, IceDragon will not keep any browser history, search history, download history, web
form entries, cookies, passwords or temporary internet files. This helps improve your overall security by removing
any local copies of internet activity. However, any files you download and bookmarks you make will be kept.
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Eile Edit View History Bookmarks Tools Help — 0 oy
e Private Browsing x | + @
G Q’ Search or enter address 3 E

4} Most Visited @) Getting Started From Internet Explorer

Private Browsing with Tracking Protection
When you browse in a Private Window, IceDragon does not save:

® cookies

® temporary files

lceDragon will save your:

* bookmarks ® downloads

Private Browsing doesn’t make you anonymous on the Internet. Your employer or
Internet service provider can still know what page you visit.

Tracking Protection ®

Some websites use trackers that can monitor your activity across the Internet. With
Tracking Protection lceDragon will block many trackers that can collect information
about your browsing behavior.

See how it works

Learn more about Private Browsing.

To start a Private Browsing session
«  Click the hamburger / 'Open Menu' button on the right and select 'New Private Window'
«  Start browsing as normal by opening a bookmark or searching from the address bar

* Amask icon is shown at top-right while in 'Private Browsing' mode:

File Edit View History Bookmarks Tools Help — | e
@rivate Browsing x | + Q
¢ Search or enter address r =

4L Most Visited @) Getting Started [ From Internet Explorer

«  Tracking Protection — Turn tracking protection on to block website elements that could track your browsing
activity. See Block Websites From Tracking Your Browsing Activities for more detailed information.
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Enable Private Browsing Permanently

If you want all your browsing sessions to be kept private, you can enable private browsing permanently.
«  Click the hamburger/ 'Open Menu' button at the top-right corner
»  Click 'Options' > 'Privacy & Security' tab

»  Click the 'lceDragon will' drop-down > select 'Use custom settings for history'

History

lceDragon will ~ Use custom settings for history e
Remember histo
Always use "y

Mever remember history
v Remerr

Use custom settings for history
¥ Remember search and torm history

v Accept cookies from websites Exceptions...
Accept third-party cookies  Always .
Keep until they expire v Show Cookies...
Clear history when lceDragon closes Settings...

«  Enable 'Always use private browsing mode'.

IceDragon will  Use custom settings for history @
@Mways use private browsing mode

Remember my browsing and download history

Remember search and form history

v Accept cookies from websites Exceptions...
Accept third-party cookies  Always B
Keep until | close IceDragon Show Cookies...
Clear history when IceDragon closes Settings...

« Restart IceDragon at the prompt to enable the feature.
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7.2.Delete Browsing History and Configure History Settings

Comodo IceDragon speeds up access to websites that you visit regularly by caching the sites you visit, files you
have downloaded, temporary internet files and site preferences.

This page explains how to clear browsing history and configure history settings.
»  Delete Browsing History
»  Configure History Settings
Delete browsing history
+  Click the hamburger/ 'Open Menu' button at the top-right corner
«  Select 'Library' > 'History' > 'Clear Recent History'

x |+

v ‘

[=
1]

'Y History

0 View History Sidebar

(%) Clear Recent History...

M Recently Closed Tabs >
B} Recently Closed Windows >

-

Recent History
; i C Comodo | Global Leader in Cyber Securi..,

go.microsoft.comy/fwlink/p/TLinkld=25...

« Inthe 'Clear Recent History' dialog, select the period that you want to clear history from the 'Time range to
clear' drop-down box.

« Leaving this at the default of 'Everything' will clear all history information in your browser.
+  Click 'Details' to display the items from which you can select for the history information to be removed.
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Clear Recent History >
Tirne range to clear: | Last Hour s
# | Details Last Two Hours

Last Four Hours
Today

Browsing & Down
Form & Search Hi
Cookies Everything
Cache

Active Logins

[] Offline Website Data

[] Site Preferences

Clear Mow Cancel

+  Select the items you wish to delete and click ‘Clear Now'. The following items can be deleted:
»  Browsing and Download History — Browsing history is the list of websites that you've visited and the
download history is the list of files that you've downloaded.

- Form and Search History — Form history are the list of terms that you've entered in web page forms

and these terms will be listed in a drop-down menu in the Auto Form Fill as you start entering the first
few letters in the form field.

« Cookies - Cookies are small pieces of information sent by websites that you've visited which are
stored by your web browser. Cookies are used by these websites to store your preferences about that
website (for example, if you ask a website to 'Keep me logged in' or similar, it is the cookie that keeps a
record of this preference).

« Cache - The cache memory stores temporary files, such as of web pages that you've visited, which will
help to load the pages much faster when you are visiting any of them once again.

« Active Logins - Authenticated sessions that are still active, that is, if you've logged into a website that
requires authentication, are called active logins.

- Offline Website Data - If you've saved a webpage as 'Web Page, complete' in the save as option in
the 'File" menu, you can view the page even if you are not connected to the internet.

- Site Preferences - Settings configured by you for certain websites such as zoom level and
permissions.

Configure history settings
The 'Privacy and security' section of 'Options' allows you to specify default 'History" settings for IceDragon.
To configure these settings

»  Click the hamburger/'Open Menu' button at the top-right corner

«  Select 'Options' then the 'Privacy and security' tab

+ Inthe 'History" section, specify default behavior in the 'lceDragon will:" drop-down
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History

lceDragon will  Use custom settings for history e

G e Remember history

Mever remember history

v Remem

Use custom settings for history
v Remember search and form history

v Accept cookies from websites Exceptions...
Accept third-party cookies  Always .
Keep until they expire bl Show Cookies...
Clear history when IlceDragon closes Settings...

The options available are:

«  Remember history — The browser will always remember history and you have to clear it manually as
explained in the first half of this page.

«  Never remember history — The browser will never store any history.
+  Use custom settings for history — If you select this, you have the following options:

«  Always use private browsing mode — If you select this option, IceDragon will always open in private
browsing mode. See 'Private Browsing' for more details.

+ Inthe 'Always use private browsing mode' select 'Accept cookies from sites'. This allows the browser to
accept first-party and third-party cookies from the websites that you visit.

- The 'Exceptions...' option configures which websites are allowed, blocked or for that session only to
use cookies irrespective of whether you choose 'Accept cookies from sites' or not.
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Exceptions - Cookies x

You can specify which websites are always or never allowed to use cookies. Type the exact address of
the site you want to manage and then click Block, Allow for Session, or Allow.

Address of website:

Block Allow for Session Allo
Site Status
http://accounts.google.com Allow
http://addons.mezilla.org Allow
Eemove Site Eemowve All Sites
Cancel Save Changes

Enter the exact address of the website in the 'Address of website' field' and select any of the options:
»  Block — The browser never allows any cookies from that website.
«  Allow for Session — The browser allows cookies for that session only and not stored.
«  Allow - The browser allows cookies and stores the cookies permanently until cleared manually.
«  Select site you want to remove a site from the list and click the 'Remove Site' button.
- Toremove all the sites, click the 'Remove All Sites' button from the exceptions list.

«  To view the cookies that are stored in your browser, click the 'Show Cookies' button.
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Cookies x

‘ b lSearch

The following cookies are stored on your computer

Site ~ | Cookie Name
bt &
acuityplatform.com
adaptv.advertising.com
addthis.com
adform.net

adhigh.net

Name: <no cookie selected >
Content: <no cookie selected >
Host: <no cookie selected =
Path: <no cookie selected =
send For: <no cookie selected =

Expires: <no cookie selected =

Remove Selected Remove All Close

In the 'Cookies' screen, you can view the details of the cookies.
To delete cookies
«  Select the site whose cookies you want to delete and click 'Remove Selected'

»  Click 'Remove All' to delete all cookies.

7.3.Allow/Block Pop-up Windows

Many websites open pop-up windows to show adverts and other messages.

While many of them are used for genuine purposes (for example, banking sites use pop-ups for login screens and
providing warnings), some may be used for malicious purposes like injecting rootkits, keyloggers and other malware.
Other pop-ups can just be plain annoying adverts.

«  Comodo IceDragon blocks pop-up windows by default.

»  You can configure IceDragon to allow or block pop-ups as you wish and can add exceptions so that pop-
ups from selected websites are always allowed.

«  When a website tries to open a pop-up, IceDragon shows a message telling you the pop-up was blocked.

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 72



Comodo IceDragon - User Guide / comooo

/

To configure pop-up windows
«  Click the hamburger/ 'Open Menu' button at the top-right corner
»  Select 'Options' then 'Privacy and Security'
»  To block pop-up windows, make sure the 'Block pop-up windows' box is enabled:

Permissions

& Location Settings...
MM Camera Settings...
& Microphone Settings...
a Motifications Learn mare Settings...

Pause notifications until lceDragon restarts

@ck pop-up wi@ Exceptions...

v Warn you when websites try to install add-ons Exceptions...

Prevent accessibility services from accessing your browser Learn more

« To permanently allow pop-ups from all websites, deselect the check-box (not recommended)

»  To add exceptions for pop-ups, click 'Exceptions'
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Allowed Websites - Pop-ups ) 4

You can specify which websites are allowed to open pop-up windows. Type the exact address of

the site you want to allow and then click Allow.

Address of website

Website Status

Remove Website Remove All Websites

Cancel Save Changes

«  Enter the URL of the website for which you want to allow pop-ups permanently in the 'Address of website'
field and click 'Allow'

The site will be added to the list of websites which are allowed to show pop-ups. All the pop-up windows opened by
this website will be allowed regardless of your setting in 'Block pop-up windows' check box.

«  Click 'Save Changes'.

7.4.Manage Cookies

«  Cookies are small files stored in your browser by websites that you've visited. They contain information
about your website preferences and can sometimes be used to authenticate you.

- For example, if you ask a website to 'Remember me' or similar, it is the cookie that keeps a record of
this preference.
»  Most cookies are stored for the worthwhile purpose of service improvement, but they can also be used to
track you and record data. Examples:
«  Session cookies allow a website to remember your page changes and selections as you move from
page-to-page. A shopping cart is a good example of this usage.

«  Asearch engine may store cookies to fetch your search history and will display targeted adverts to you
on various web-pages you visit.

+  Some malicious sites may use cookies to log sensitive information about you. Hackers could, in theory,
intercept a cookie sent from your browser to a website and extract sensitive data.

«  To maintain your privacy and security, you need to clear cookies from your browser periodically and
evaluate your overall policy regarding allowing or blocking cookies.

« By default, IceDragon accepts cookies from the websites you visit. You can configure it to allow or block
cookies , or to accept/block cookies on a per-site basis.

Click the links below for more help:

+  Clear Cookies
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«  View and remove stored cookies individually
+  Allow / block cookies
«  Add exceptions for storing cookies

Clear cookies

Cookies are deleted when you clear your browsing history.
If you want to manually clear cookies:
«  Click the hamburger/'Open Menu' button at top-right.
«  Select 'Options' > 'Privacy and Security'.
» (o to the 'History' section
» 'lce Dragon will' section. Select one of the following:

»  'Never Remember History' - Ice Dragon will delete all cookies and browsing history when you close the
browser.

« 'Remember History' - Ice Dragon will retain cookies and browsing history from websites you visit
+ 'Use Custom Settings' — Choose exactly which items are remembered by Ice Dragon.
Remember History
If 'Remember history' is chosen,
« To delete the browsing history along with the cookies click the link 'clear your recent history'

+ To delete cookies individually, click the link 'remove individual cookies'. The cookies dialog allows you to
remove cookies individually. See 'View and remove stored cookies individually' for more details.

Never remember history
If 'Never remember history' is chosen,

«  Cookies are automatically deleted, along with your browsing history, when you close Ice Dragon. You can
manually delete them by the hamburger button > 'Library' > 'History' > ‘Clear recent history'

Use custom settings for history
If 'Use custom settings for history' is chosen,

»  Click 'Show Cookies'. The 'Cookies dialog allows you to remove cookies individually. See 'View and
remove stored cookies individually' for more details.

View and remove stored cookies individually

The 'Cookies' dialog displays a list of cookies stored in your browser and enables you to remove them selectively.
To access cookies dialog

»  Click the hamburger/ 'Open Menu' at the top-right

»  Choose 'Options' > 'Privacy and security' > 'History'

»  Select 'Remember History' for 'IceDragon will:'

«  Click the 'remove individual cookies' link

OR
+  Select 'Use custom settings for history' for 'lceDragon will:', click ‘Show Cookies' button
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Cookies x

0 tSearch

The following cookies are stored on your computer

Site - Cookie Mame

»comodo.com

doubleclick.net

Mame: <no cookie selected »
Content: <no cookie selected =

Host: <no cookie selected

o

Eemove Selected Remove All Close

The dialog displays the list of stored cookies stored by different websites you have visited.
+  Select a cookie to view details about it in the lower pane.
« To delete a cookie, select it and click 'Remove Selected'.
« Toremove all the cookies at once click 'Remove All'.
«  Click 'Close'.

Allow / block cookies
«  Click the hamburger/ 'Open Menu' button at the top-right corner the select 'Options' > 'Privacy and Security'.

«  Under History' for 'IceDragon will:', select 'Use custom settings for history' from the drop-down:
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IceDragon will  Use custom settings for history B

D Always use private browsing mode

¥ Remember my browsing and download history

gﬂemember search and form history

v Accept cookies from websites

Accept third-party cookies  Always i

Keep until = they expire v

Clear history when lceDragon closes

Exceptions...

Show Cookies...

Settings...

To allow cookies from the websites

Leave the 'Accept cookies from sites' checkbox selected.

If you want to allow third-party cookies, that is the cookies set by other applications or websites through the

website you visit, select the 'Accept third-party cookies:' checkbox.

Select the time period for the life time of the third-party cookies from 'Keep until' drop-down:

- they expire — Third-party cookies will be stored in your browser till their life time as set by the website

» I close IceDragon - Third-party cookies will be removed once you end your browsing session

To block cookies from the websites

Deselect the 'Accept cookies from sites' checkbox

Add exceptions for storing cookies

Click the hamburger/ 'Open Menu' button at the top-right corner then select 'Options' > 'Privacy and

Security'".

Under 'History' for 'lceDragon will', select 'Use custom settings for history' from the drop-down.

Click 'Exceptions' beside 'Accept cookies from sites' checkbox.
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Exceptions - Cookies X
You can specify which websites are always or never allowed to use cookies. Type the exact address "
of the site you want to manage and then click Block, Allow for Session, or Allow.
Address of website
Block Allow for Session Allow

Website Status
http://addons.mozilla.org Allow
http.//ads.adtrustedmediz.com Block
https://accounts.google.com Allow

L
Remove Website Remove All Websites
Cancel Save Changes

»  Enter the url of the website for which you want to allow or block cookies permanently.

«  Click 'Block' to stop the cookies from the site. Regardless of whether the checkbox 'Accept cookies from
sites' is checked or not, the cookies from this site will be blocked.

«  Click 'Allow for Session' to allow the cookies from sites and remove them when IceDragon closes.

+  Click 'Allow' to allow the cookies from the site. Regardless of whether the checkbox 'Accept cookies from
sites' is checked or not, the cookies from this site will be allowed.

The website will be added to the list with the 'Allow', Allow for Session or 'Block status' as specified.
« To remove a specific website from the exceptions list
«  Select the website and click 'Remove Website'
» To remove All websites at once from the exceptions list, click 'Remove All Websites'

«  Click 'Save Changes'
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7.5.Block Websites from Tracking your Browsing Activities

To configure tracking protection:
+  Click the hamburger icon
«  Click 'Options'
Click 'Privacy and Security'
«  Scroll down to the 'Tracking Protection' section

Some websites record the browsing activities of visitors. For example, a web site may track your activity to find your
interests and display relevant content and advertisements. While this can make for a more personalized online
experience, it can also allow websites to build a potentially invasive profile of your online activity.

Tracking protection prevents known trackers from from recording your online behavior. A shield icon
appears in the address bar whenever Ice Dragon blocks a tracker.

» The 'Tracking protection' section lets you configure how you want to deploy this feature:

Tracking Protection

Tracking is the collection of your browsing data across multiple websites.
Tracking can be used to build a profile and display content based on your

browsing and personal information.

Use Tracking Protection to block known trackers Exceptions...
Learn more
Change Block List...
Always

® Only in private windows

MNever

Send websites a "Do Mot Track” signal that you don't want to be tracked

Learn more

® Only when using Tracking Protection

Always

« 'Always' - Ice Dragon will block trackers at all times in both normal and private browsing sessions.

« 'Only in private windows' - Ice Dragon will allow trackers in normal sessions but block them in private
sessions.

Tracking protection is automatically enabled in private browsing sessions. Disabling it will apply only to the current
session. It will be re-enabled when you begin your next session.

«  'Never' - Trackers are permitted in both normal and private browsing sessions.
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» 'Do Not Track' - An Ice Dragon setting that tells websites you visit that you do not want them to monitor or
record your behavior.

« 'Only when using Tracking Protection is enabled' - Will send the 'Do not track' command if tracking
protection is active for your browsing session.

« 'Always' - Will send the 'Do not track' command to every site you visit during both regular and private
browsing sessions.

« Exceptions — A shield icon that appeared in your address bar indicates a blocking tracker on a site. All sites
that allowed tracking list in the 'Exceptions — Tracking Protection' dialog.

- Toremove a site from exceptions
+  Click the shield icon again and click 'Enable Protection’
OR
+ Inthe 'Exceptions — Tracking Protection’, select a site and click 'Remove Website'
- Toremove all sites from exceptions, click 'Remove All Websites'
+  Click "Save Changes' to save settings.

7.6.View and Manage Permission Settings

+ By default, Ice Dragon will ask your permission every time a site requests your location, or to access your
camera/microphone, or to send you notifications.

»  You can allow or block the request as you deem appropriate.

- Permission settings let you view all websites that have made such requests, and view/modify your settings
for each site.

« Tip. You can view the permissions you have given to a specific site by clicking the information icon next
to the address bar:
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ee ﬁ Q Search

Secure Connection

verified by: Google Inc

& Page Info - https://hangouts.google.com/ l -
y  pm = oI __f'l\
ﬂ Eu @ ==
General  Media P iszi Security

Permissions for: https:/fhangouts.google.com

Activate Plugins
Adobe Flash (® Use Default (O Always ask (O Allow (O Hide (O)Block

Access Your Location

Use Default Always Ask Allow Block
Install Add-ons

[4] Use Default Allow Block
Load Images

[4] Use Default Allow Block

Open Pop-up Windows

[4] Use Default Allow Block
Override Keyboard Shortcuts

[4] Use Default Allow Block
Receive Notifications

To access permissions settings
+  Click the hamburger icon
«  Click 'Options'
Click 'Privacy and Security'

«  Scroll down to the 'Permissions' section

'!:I' General

Q search Permissions
& Privacy & Security ® Location Settings...
9 Firefox Account ) s LEIE
§ Microphone Settings...
PO Languages
E Notifications Learn more Settings...

Pause notifications until IceDragon restarts
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» Location - Determines whether or not a website is allowed to request and learn your current location. You
can revoke this permission for all sites you visit or for specific sites.

«  Camera/ Microphone — Manage permissions for a specific or all pages to which it is allowed / blocked to
use camera / your microphone. This applies to video or image / recording sites available.

» Notifications — Set whether or not to receive notification from a website. A website which is allowed to send
notifications can send you in-browser messages related to their services. These are shown even if you are
not on their website at the time.

«  Pause natifications until IceDragon restarts — You will not be sent any more notifications during this
session. Notifications will only resume after Ice Dragon is restarted.

7.7.Configure Suggestions when Entering a Website Address

» Ice Dragon uses your browsing history and bookmarks to provide suggestions when you start typing an
address in the address bar.

«  Simply click on one of the suggestions to visit that page.

Eile Edit View History Bookmarks Tools Help _ O w0

¥ Options ¥ | @ MNewTab X | +
c @ ‘ 2 poll —)‘ » =

Q poll — Search with Google

Q. pollardi

O\ pollution

Q pollotenchegg
Q poll

Q pollyanna

pollock

i)
L)

Click the following links to find out more:
«  Configure suggestions
«  Exclude a website from suggestions
«  Exclude a single webpage from suggestions

Configure Suggestions

IceDragon allows you the select the sources from which suggestions are drawn, or to stop suggestions altogether.

«  Click the hamburger/ 'Open Menu' button at the top-right corner then select 'Options' > 'Privacy and
Security'
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Address Bar
When using the address bar, suggest

Browsing history
v Bookmarks

v QOpen tabs

Change preferences for search engine suggestions

»  Under 'Address Bar', select the option for 'When using the location bar, suggest'

»  Browsing History - Provides suggested sites from your browsing history only.
»  Bookmarks - Provides suggested sites from your bookmarked sites only.
«  Open tabs — Provides suggested sites from open tabs only.

Exclude a website from suggestions

Allows you configure IceDragon to block suggestions from a specific website.
+  Click the hamburger/ 'Open Menu' button at the top-right corner and select 'Library' > 'History'.
«  Click "Show All History" at the bottom of the menu.
« Inthe 'Library' interface use the 'Search History' at top-right to find a web site.
» Right-click on a website page and select 'Forget About This Site' from the context sensitive menu.
« Ice Dragon will no longer suggest pages from the website.

Exclude a single webpage from suggestions

- Type a part of the webpage address in the address bar.

= Hover your mouse cursor over the suggestion you want to exclude and press 'Delete' key from the
keyboard.

1.8. Manage Cache

The cache is a repository used to store web pages, images and other web content so that the page loads
faster on future visits.

- The cache can grow quite large over time as it is used to store data from every website you visit.
»  Periodically clearing the cache will free up space on your computer.
- This is also useful to remove corrupt data that is causing pages to load incorrectly.
Clear the cache
»  Click the hamburger/ 'Open Menu' button at top-right
»  Select 'Options' > 'Privacy and Security'
«  Scroll to 'Cached Web Content'
«  Click 'Clear Now'
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Cached Web Content

Your web content cache is currently using 28.9 MB of disk spate

Override automatic cache management

Limit cache to 350 ME of space

Cached Web Content Management

Comodo IceDragon stores web pages you visit in a dedicated cache so that the page loads quicker when you visit it
in future. The default disk space for the cache storage is 350 MB.

»  You can re-configure the disk space allotment for the cache storage through 'Cached Web content' settings.

Cached Web Content

Your web content cache is currently using 2.1 MB of disk space Clear Now

@verride automatic cache management

Limit cache to 350 - MB of space

Change the default disk space for cache storage

+  Click the hamburger/ 'Open Menu' button at top-right

«  Select 'Options' > 'Privacy and Security'.

«  Check the 'Override automatic cache management' box under the 'Cached Web Content'.

+  Specify the new disk size (in MB) in the 'Limit cache to' combo box.
Automatically clear the cache

«  Click the hamburger/ 'Open Menu' button at top-right

«  Click 'Options' > 'Privacy and Security'.

« (o to the 'History' section.

+ 'lceDragon will' - Select 'Use custom settings for history'

«  Enable 'Clear history when IceDragon closes'

«  Click the 'Settings' button next to it
»  Make sure the 'Cache' box is checked:
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History
IceDragon will:| Use custom settings for history -
Always use private browsing mode

v | Remember my browsing and download history

v | Remember search and form history

v | Accept cookies from sites Exceptions...
Accept third-party cookies: | Always ~
Keep until:| they expire = Show Cookies...

Settings...

@Ieag history when IceDragon closes
...--""""f

Settings for Clearing History / x

When I quit IceDragon, it should automatically clear all:

History
v | Browsing & Download History v | Cookies
v' | Active Logins v | Cache

v | Form & Search History

Data
Site Preferences Offline Website Data

Ok Cancel Help

+  Click 'OK' to apply your changes.
Offline Web Content and User Data Management

Some websites store user data on your computer for offline use. You can delete this offline data if required.
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History
lceDragon will  Use custom settings for history ht
Always use private browsing mode

¥ Remember my browsing and download history

v Remember search and form history

v Accept cookies from websites Exceptions...
Accept third-party cookies  Always bt
Keep until  they expire - Show Cookies...

@Jea[ history when lceDragon closes

e
Settings for Clearing History x

When | quit IceDragon, it should automatically clear all

History
Browsing & Download History v | Cookies
Active Logins v | Cache

Form & Search History

Data

Site Preferences @gfﬂine Website Data

QK Cancel Help

To remove site data from storage
«  Click the hamburger/ 'Open Menu' button at top-right
+  Click 'Options' > 'Privacy and Security'
+  Go to the 'Site Data' section.
+  Select 'Clear All Data'
»  Click 'Settings' to open the 'Settings — Site Data' dialog
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Settings - Site Data X

The following websites store site data on your computer. IceDragon keeps data from websites with
persistent storage until you delete it, and deletes data from websites with non-persistent storage as

space is needed.

© kearch websites

Site Status Storage o
vars.hotjar.com 64.0 KB
www.comodo.com 64.0 KB
en.softonic.com 48.0 KB

« The interface shows list of sites that have stored their data. You can search the list for a specific
username or website by entering it fully or partially in the search bar.

«  Select the site whose data you want to delete and click 'Remove Selected'
«  Click 'Remove All' to delete all site data.

+ Click 'Save Changes'.

To remove the cache from the About Config page
* Type about : configinthe address bar and press 'Enter'.

A warning will open:
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This might void your warranty!

Changing these advanced settings can be harmful to the stability, security, and performance of this
application. You should only continue if you are sure of what you are doing.

v Show this warning next time

| accept the risk!

«  Click 'l accept the risk!'
The configuration page will open:

- Type 'browser.cache' in the search field then double click in the browser.cache.disk.enable and
browser.cache.memory.enable entry.

«  Alternatively, right-click on browser.cache.disk.enable and browser.cache.memory.enable and select

‘Toggle'.

File Edit View History Bookmarks Tools Help — O e
-l:!- Options ¥ | abouticonfig x |+

« ¢ ce..gon  aboutconfig o » =
I+ Most Visited T Getting Started [5] From Internet Explorer

Search:  ©

Preference Name - Status Type Yalue =}
browser.cache.compression_level default integer 0 &
browser.cache.disk.capacity maodified  integer 358400
browser.cache.disk.enable default boolean  true
browser.cache.disk.filesystem_reported maodified  integer 1
browser.cache.disk.free_space_hard_limit default integer 1024
browser.cache.disk.free_space_soft_limit default integer 5120
browser.cache.disk.max_chunks_memory_usage default integer 10240
browser.cache.disk.max_entry_size default integer 51200
browser.cache.disk.max_pricrity_chunks_memao... default integer 10240
browser.cache.disk.metadata_memory_limit default integer 250
browser.cache.disk.preload_chunk_count default integer 4
browser.cache.disk.smart_zize.enabled default boolean true
browser.cache.disk.smart_size.first_run modified boolean false
browser.cache.disk.smart_size.use_old_max default boolean true
browser.cache.dizk_cache_ssl default boolean true v
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«  Switch to 'false' value and restart the browser.

7.9.Manage Add-on Permissions

Add-ons are small pieces of software designed to expand the functionality of Ice Dragon. Add-ons are broadly
classified as:

» Extensions - Add new features to the browser. Examples include extensions to auto-update Facebook
profiles, analyze your typing skills, detect website trackers, compare prices from different e-merchants and
more.

» Appearance - Customize how the browser should appear by applying themes and styles.

+  Plugins - Support different kinds of file types from the internet. For example, to open .pdf files, play video
and audio files, play online games and so on.

See 'Introduction to Add-ons' for more details.
While most add-ons are genuine, some may be harmful, injecting rootkits, key-loggers and other malware.
Ice Dragon lets you choose the level of permission that websites have to install add-ons:
Click the links below for more help:
«  Allow/block automatic installation of Add-ons by websites
« Add exceptions for automatic Add-on installations
To configure automatic installation of add-ons
1)
«  Click the hamburger/ 'Open Menu' button in the top-right corner
+  Select 'Options' > 'Privacy and Security' > 'Permissions'

Permissions

& Location Settings...
MM Camera Settings...
& Microphone Settings...
a Motifications Learn mare Settings...

Pause notifications until lceDragon restarts

v Block pop-up windows Exceptions...
v Warn you when websites try to install add-ons Exceptions...

Prevent accessibility services from accessing your browser Learn more
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»  Warn you when sites try to install add-ons' - If enabled, you will see an alert if a site tries to install
an add-on. You can decide whether to allow or block it.

«  Click the hamburger/ 'Open Menu' button at the top-right corner
«  Select 'Options' > 'Privacy and Security' >'Security'

Security

Deceptive Content and Dangerous Software Protection

v Block dangerous and deceptive content Learn more

v Warn you about unwanted and uncommon software

- Block dangerous and deceptive content (aka 'Phishing’, malware, attack sites, unwanted software) -
Blocks unknown and sites,unwanted files and downloads. An alert will be displayed you if you try to connect
to a dangerous site.

- 'Block dangerous downloads' detects malicious executable files

«  'Warm me about unwanted and uncommon software' alerts about potentially unwanted and uncommon
downloads

To add exceptions for automatic installation of Add-ons
+  Click the hamburger/ 'Open Menu' button at the top-right corner then select ‘Options' > ‘Security'
+  Click 'Exceptions' beside the 'Warn me when sites try to install add-ons' checkbox

Allowed Websites - Add-ons Installation x

You can specify which websites are allowed to install add-ons. Type the exact address of the site -

you want to allow and then click Allow.

Address of website

Allow
Website Status
https://addons.mozilla.org Allow
https://testpilot.firefox.com Allow
L
Remove Website Remove All Websites
Cancel Save Changes

The exceptions dialog will open:
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»  Enter the url of the website for which you want to allow add-ons.

«  Click 'Allow". Regardless of whether the checkbox 'Warn me when sites try to install add-ons' is checked or
not, the add-ons from this site will be allowed for automatic installation.

The website will be added to the exceptions list with the 'Allow' status.
- Toremove a website from the exceptions list,

«  Click 'Exceptions' beside 'Warn me when sites try to install add-ons'.

- Select the website and click 'Remove Site'.

- Toremove all the sites from the exception list, click 'Remove All Sites'.
+  Click 'Save Changes'.

7.10.  Manage Passwords

+ lceDragon can securely remember your usernames and passwords and automatically enter them the next
time you visit a website.

+  This can be a great time saver but is not recommended for shared computers or public computers.

This page explains how the 'Remember' system works from a user point of view before explaining how you can
configure advanced password settings.

The following links provide more help on:
» The 'Remember Password' prompt
+  Configure the 'Remember Password' option
» Configure Exceptions
» View and manage stored passwords
» Use a master password

The 'Remember Password' prompt

When you enter your username and password in a log-in form, IceDragon will offer to remember your password.
«  Forthe browser to save your password, select 'Remember'

»  For additional options click the drop-down arrow beside 'Remember’
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Edit View History Bookmarks Tools Help

COptions x + Google Accounts x |+

-
8
o

X ‘Q‘ @, B https://accounts.google.com see
Most Visited (C Getting Starte:.j Would you like lceDragon to save this login for

. . oogle.com?
ading, please wait __. 9903

| testuser720@gmail.com |

[]Show password

Mever Save |

« Don't Save - Select this option if you don't want to save the password right now, but want to be asked
again the next time you visit.

« Never Save - Select this option if you do not want to save the password for the site. The password you
entered will not be saved and the site will be added to the exception list (see below). IceDragon will not offer
to save your password the next time you visit the site.

Configure 'Remember Password' options

«  Click the hamburger/ 'Open Menu' button at the top-right corner
»  Select 'Options' > "Privacy and Security' > '‘Browser Privacy'.

«  'Remember logins and passwords for websites' - Disable if you do not want IceDragon to auto-fill logins and
passwords.
«  Exceptions - Add websites for which IceDragon should not remember your username and password.

«  Saved logins - Alist of all the websites for which IceDragon has saved the username/password. You
can remove or import sites as required.
»  Use a master password — If enabled, IceDragon will require you enter a password before it will auto-
complete your username and password on a login page.

Browser Privacy

Forms & Passwords

¥ Remember logins and passwords for websites Exceptions...

Saved Logins...

Use a master password Change Master Password...
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Configure Exceptions

«  Websites for which you chose 'Never Remember Password' at the prompt are added to exclusions.

«  The passwords for these sites will not be saved and the 'Remember Password' prompt will not appear after
logging in to these sites in future.

*  You can view and remove sites from the exclusion list as follows:
To view exception logins
«  Click the hamburger/ 'Open Menu' button at the top-right
«  Select 'Options' > 'Privacy and Security' > Browser Privacy'
«  Click 'Exceptions' beside 'Remember logins and passwords for websites'

The 'Exceptions - Saved Logins' dialog will open:

Exceptions - Saved Logins X

Logins for the following websites will not be saved

Address of website

Block

Website

http://faccounts.google.com

Eemove Website Remove All Websites

Cancel Save Changes

« Toremove a site from exceptions, select the site and click 'Remove Website'.
« Toremove all sites from exceptions, click 'Remove All Websites'.

View and Manage Stored Passwords

Click the hamburger/ 'Open Menu' at the top-right then select 'Options' > "Privacy and Security' > Browser
Privacy'

»  Click 'Saved Logins' under the 'Forms & Passwords'

The 'Saved Logins' interface shows list of sites that have stored passwords associated with them. You can search
the list for a specific username or website by entering it fully or partially in the search bar.
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Saved Logins x
© kearch
Logins for the following sites are stored on your computer
Site ~ | Username Last Changed &
G https://accounts.google.com testuser720@gmail.com 473072018
Remove Remove All Import... Show Passwords
Close

» To delete a stored password, select the website and click 'Remove'.
»  To delete all stored passwords, click 'Remove All'.
«  Toimport your login from another browser, click 'Import'.
« To view a password saved for the site, click 'Show Password' and enter the master password in the dialog.
»  Click 'Hide Passwords' to conceal the password.
»  Click 'Close' to exit the 'Saved Logins' interface.
Set a master password
« If you have asked IceDragon to remember your usernames and passwords, then they will be automatically
entered whenever you visit the site.

«  While this is convenient, it can be a security risk if someone else uses your computer. They could visit the
login page of one of your websites then automatically gain access to your account.

The master password feature overcomes this by requiring you enter a password before IceDragon will auto-
populate your login credentials.

Important: Do not forget your master password. If you do, you will not be able to access your saved passwords.
To specify a master password

«  Click the hamburger/ 'Open Menu' button at the top-right corner

«  Select 'Options' > "Privacy and Security' > Browser Privacy'

»  Check the 'User a master password' box.

The 'Change Master Password' dialog will open:
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Change Master Password X

A Master Password is used to protect sensitive information like site passwords. If you
create a Master Password you will be asked to enter it once per session when lceDragon

retrieves saved information protected by the password.

Current password: (not set)

Enter new password: | |

Re-enter password:

Password quality meter

Please make sure you remember the Master Password you have set. If you forget

your Master Password, you will be unable to access any of the information protected

by it.

OK Cancel

+ Enter a password to authenticate in the 'New password' box and then repeat it. Click 'OK'

Password Change Succeeded >

i} Master Password successfully changed.

oK

+  Click 'OK' for the settings to tale effect.
+You can change your master password as frequently as you would like to ensure that it remains secret.
Change the master password
»  Click the hamburger/ 'Open Menu' button at the top-right corner
«  Select 'Options' > "Privacy and Security' > Browser Privacy' > Forms and Passwords'
«  Click 'Change Master Password'":

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 95



Comodo IceDragor__1_______;_,_,LJ-Se"r"'G"'i]"i_d € coMong!

Change Master Password X

A Master Password is used to protect sensitive information like site passwords. If you
create a Master Password you will be asked to enter it once per session when IceDragon

retrieves saved information protected by the password.

Current password: ‘ |

Enter new password:

Re-enter password:

Password quality meter

Please make sure you remember the Master Password you have set. If you forget

your Master Password, you will be unable to access any of the information protected

by it.

OK Cancel

«  Type your current password, then enter your new password and re-enter it in the 'Re-enter password' field.
+  Click 'OK" in the confirmation dialog.

«  Click 'OK' for the settings to rake effect.
In order to change your forgotten master password, reset it .

Warning note: All your saved usernames and passwords will be removed after resetting your master password.
In the 'Location’ bar, enter the following,

chrome://pippki/content/resetpassword.xul
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Eile Edit View History Bookmarks Tools Help

-I:I- Opticns

b4 Reset Master Password

x |+

<« C @

@ chrome://pippki/content,/res
LF Most Visited (C Getting Started [ From Internet Explorer

ses wu Ty

i"‘x If you reset your master password, all your stored web and e-mail passwords, form data, personal
S®S certificates, and private keys will be forgotten. Are you sure you want to reset your master password?
Reset Cancel
+  Click 'Reset'.

To remove the master password

«  Click the hamburger/ 'Open Menu' at the top-right corner

Select 'Options' > 'Privacy and Security' > 'Browser Privacy'

Uncheck 'User a master password' box under the 'Forms and Passwords'

»
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Remove Master Password 4

Your Master Password is used to protect sensitive information like site
passwords.
If you remove your Master Password your information will not be

protected if your computer is compromised.

You must enter your current password to proceed:

Current password:‘ |

Remove Cancel

«  Type you current password in the The 'Remove Master Password'
+  Click 'Remove'

* Inthe warm dialog, click 'OK' to confirm your removal.

7.11.  SSL Certificates and Secure Connections

«  Whenever you make a secure connection to a website, the beginning of the URL will change from HTTP to
HTTPS (with the ‘S’ standing for secure).

«  Apadlock will also appear at the left of the address. This indicates that the page is using a TLS/SSL
certificate to encrypt all communications between you and the site.

«  However, not every type of certificate should be trusted to the same degree.

There are three main types of certificate — Domain Validated (DV), Organization Validated (OV) and Extended
Validation (EV).

Domain Validated (DV) — These certificates are the lowest cost means of securing a website but do not provide
authentication or validation of the business behind the website. DV certs are issued after the applicant has proven
they control the domain for which the certificate is intended. Applicants can validate domain control using fast, online
methods, such as responding to a challenge-response email. EV and OV similarly require domain control validation,
but also require the applicant to supply business documentation to confirm their identity.
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File Edit Wiew History Bookmarks Tools Help

- O >
WaorkFlowy - Organize yourbr- % | <
< => C @ #. https;//workflowy.com see @ ww T » =
LF Most Visited T Getting 5Sta ‘ Site Security

]
E & workflowy.com
Secure Connection

Verified by: COMODO CA Limited

. -
I I r More Information ¥

r

Organization Validation (OV) — These certificates include full business and company validation from a certificate
authority using currently established and accepted manual vetting processes. Because of this requirement, these
certificates provide significantly higher levels of trust and security than DV SSL certificates but are not validated to

the stringent standards set by the CA/B forum and do not possess the ability to turn the address bar green in the
latest browsers.

File Edit Wiew History Bookmarks Tools Help

- O >
\?} WildBerries.ru — Muteprer-mar X | =

« c Q’ @'@ = https:/fwww.wildberries.ru e

o v ﬁ )}
¥ Most Visited Getting 5ta
C 9

L4 Site Security

& www.wildberries.ru

Secure Connection

Verified by: COMODO CA Limited .
500 py r!

More Information

Extended Validation (EV) — EV certificates are validated to the strong guidelines set by the CA/B Forum, an
independent standards body consisting of major browser providers and certificate authorities. EV certificates are only
issued after in-depth background checks have been carried out on the applicant company. Because of this, EV
certificates provide the highest levels of security and trust to end-users. To reflect this higher level of trust, IceDragon

shows a green indicator if a site has an EV certificate. The indicator contains the name and address of the company
that owns the website, and the name of the CA who issued the certificate.
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File Edit Wiew History Bockmarks Tocols Help _ O w0

= S5 Certificate #1 Secure Socks X +

<« X @ & C.. [GB) | https://www.ins see G ww T »

LF Most Visited (C Getting Sta < Site Security

Instant SSL & Comodo ¢A 18 266 636

Secure Connection
by comoDO snal +1 703 581 63,

You are securely connected to this site, owned
by: 2 SSL Enterpri

Comodo CA Ltd
Google Chrome plans "salford hat Now or @&
Greater Manchester, GB

verified by: COMODO CA Limited

S5L Certificate

More Information

Trust between the person using the browser the website they are connected to is only possible when two stages of
validation are completed.

1. Verification that the certificate applicant owns the domain name of the website.
2. Verification that the certificate applicant is a legitimate and legally accountable business.

Step 2) is carried out by a Certificate Authority (CA) such as Comodo or Symantec. A CA employs human operatives
to carry out strict vetting of the applicant’s business and legal standing. Only once this layer of company validation
has been completed can a website be truly ‘trusted’.

Users can tell an EV certificate because the name of the company that owns the site is shown in green text next to
the URL. You can also click the lock to view complete details. The following screenshot shows the certificate on
instantssl.com, which is operated by Comodo.

7.12.  Manage SSL Certificates and HTTPS Security

«  Comodo IceDragon uses TLS/SSL certificates to encrypt data in transit between the browser and the
website you are connected to.

«  For example, when you make a purchase online, the order form will be secured with a website SSL
certificate. You can tell when you are on an encrypted connection because the website address will
begin with https:// rather than http:// (with the 's' standing for secure).

»  Other indicators include a padlock in the address bar and, in the case of Extended Validation certificates,

the address bar itself will change color to green. The lock indicates that confidential information such as
credit card details are securely encrypted and cannot be intercepted en-route by a thief.

«  Website SSL certificates also contain authentication information about the website owners, including the
company name and physical address. This allows you to verify that the website you are connected to is
owned and operated by a legitimate company. Please visit http://www.instantssl.com for more details.

«  Personal, client and email certificates are used to authenticate people, encrypt communications and
digitally sign documents. For more details, please visit https://www.instantssl.com/ssl-certificate-
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products/personal-authentication-certificate.html
To manage personal and website certificates
+  Click the hamburger/ 'Open Menu' button at the top-right
«  Select 'Options' > 'Privacy and Security' > 'Security'
+  Select the 'Certificates' tab

'ﬁ' General

Q Search ¥ Warn you about unwanted and uncommon software

et i I P

v Block dangerous and deceptive content Learn mare

ﬂ Privacy & Security
Certificates

ks Firefox Account When a server reguests your personal certificate
Select one automatically

Pe Languages
® Askyou every time

Query OCSP responder servers to confirm the current View Certificates...

® IceDragon Support validity of certificates S P

Websites usually request a personal certificate as part of a two-factor authentication scheme. The website requires
you to enter your username/password as usual, plus present your personal certificate.

+ If you want IceDragon to select one automatically from its certificate store, choose 'Select one
automatically'.

+ If you want to manually select the certificate yourself when a website asks for a personal certificate, select
'Ask me every time'

*  'Query OCSP responder servers..." - If enabled, Ice Dragon will run an Online Certificate Status Protocol
(OCSP) check of every SSL certificate it encounters. OCSP checks establish whether or not the certificate
has been revoked or not.

The 'Certificates' configuration settings enables you to:
« View and manage certificates
«  Configure security modules that store certificates and passwords
View and manage certificates
+  Click 'View Certificates' under 'Certificates’.
The 'Certificates Manager' window will be opened. The 'Certificates Manager' has the following tabs:
« Your Certificates
» People
« Servers
» Authorities
« Others

Your Certificates

The "Your Certificates' area lists your personal/client/secure-email certificates.
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Certificate Manager X

Your Certificates People Servers Authorities Others

You have certificates from these organizations that identify you

a

Certificate Name Security Device Serial Number Expires On

~COMODO CA Limited

B R TR Software Security Device TR RO 0 B WA ). Tuesday, June 13, 2017
=pliys i @comodo.com  Software Security Device MRS A A S B ... Wednesday, August 22, 2012
View... Backup... Backup All... Import... Delete...

oK

The dialog enables you to:
» Import your certificate from your local storage to your browser
» View the certificate details
«  Backup your certificate(s)
» Delete expired or revoked certificates
Import your certificate

You might have stored your personal authentication, client or secure-email certificate downloaded from a
Certification Authority (CA) or the one provided by your Network Administrator in your computer. You can import and
install the certificate into your browser through the 'Certificate Manager'.

To import your certificate
«  Click 'Import' from the 'Certificate Manager' > "Your Certificates' interface
«  Browse to the location where you stored your certificate and click 'Open’

You will be prompted for entering the password you entered while storing the certificate in your computer.

Password Required x

9_. Please enter the password that was used to encrypt this certificate backup:
=4

QK Cancel

»  Enter the password that was used while storing the certificate and click 'OK'
Your certificate will be imported to the certificate store of the browser.
View Certificate Details

- To view the certificate, select the certificate and click 'View'.
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The general information and detailed information on the certificate will be shown under the respective tabs in
‘Certificate Viewer' dialog.

Certificate Viewer “Suips i ",

General Dirtnils

Could mot werily this certilicate becmsie it hat expinad

lssued Te

Commen Name (TN Valles Sataansd

Organication (30 Comodo Group Inc

Onganicstional Ung (OU) <ot Part Of Certificabes

Seripl Humber SR Bl el s PO

lssuad By

Commen Name (CN) COMODO Client Authentication and Secure Errail CA

Organization [0 COMODO LA Limited
Onganicational Lnk (DU <Pet Par OF Cartificates

Periud of Vabdity

Cerbifscabe Viewer “Wel

v Bt ™ E
(Ganeial Details

Certificate Hierarchy
AddTrust Extemal Rook
w UTH-LISERFirst-Cliert futhenticstion snd Emal
~ COMODO Cheni Authenbcation aed Secure Email CA
uliya Bashiortova
Certificate Fields
= OMANDG Cleent Autthenticstion snd Secure Emad Ca 5
wCatificate
‘ersion
Serial Mamber
Cortificate Sagrurune Algerthen

Begins On Fridarg, June 13, 2198 lssuer

Expins O Tusiday, lune 13, 2007 alidity

Fingerprinty et Bafers W
SH4-256 Firgemrint ' . y

EHAT Fingergent ha TaE BAE RS ANl . Ta S E-A P

Export..

Store a Backup of a certificate

You can store a backup of your certificate(s) for safe-keeping. The backup enables you to re-install them if you have
to uninstall and re-install the browser.

To backup a certificate
«  Select the certificate and click 'Backup...'
+ Navigate to a safe location in your local computer or your network and enter a file name
+  Click 'Save'

You will be prompted to enter a password for the backup. Your certificate will be stored in the backup in an encrypted
form with this password. In order to restore your certificate, you need to enter this password.

Choose a Certificate Backup Password >

The certificate backup password you set here protects the backup file that you are about to create, You
rust set this password to proceed with the backup.

Certificate backup password: | P |

Certificate backup password (again): | ,.....,..,..,....| |

Important: If you forget your certificate backup password, you will not be able to restore this backup
later. Please record it in a safe location,

Password quality meter

] Cancel
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«  Type a password and re-enter it for confirmation in respective fields. Choose the password as a mixture of
alphanumeric characters, upper and lower case letters and special characters. The password quality meter
shows the strength of the password you have chosen.

« Click 'OK'".
- To backup all you certificates at once, click 'Backup All..." and follow the same procedure.
Delete a certificate

«  Select the certificate to be deleted and click 'Delete’.

Delete your Certificates et

Are you sure you want to delete these certificates?

E: FIVT TIPS TR PR S [

If you delete one of your own certificates, you can no lenger use it to identify
yourself,

QK Cancel

«  Click 'OK" in the confirmation dialog.

Note: If you delete your currently active certificate, you will not be able to use it for identifying yourself to the
websites that require it.

People

The 'People’ tab lists other people's client and email certificates. You usually obtain these by receiving a signed email
from the person in question. These certificates are necessary if you want to encrypt messages/email you send to the
contact. Likewise, they will need your certificate to encrypt messages they send to you.

Certificate Manager x

Your Certificates People Servers Authorities Others

You have certificates on file that identify these people

Certificate Name Expires On E-Mail Address ]
~COMODO CA Limited
Brian Smith Sunday, July 6, 2014 brian@dns.com
~5tartCom Ltd.
o A —— Sunday, May 12, 2013 [ T ——
View... Import... Export... Delete...

OK
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The dialog enables you to:
« View the certificate details
« Import other person's certificate from your local storage to your browser
» Export a certificate
« Delete expired or revoked certificates
View the Certificate
« To view the certificate, select the certificate and click 'View'".

The general information and detailed information on the certificate will be shown under respective tabs in 'Certificate
Viewer' dialog similar to that of your certificate. Please see View the Details of the 'Certificate’ in the previous
section.

Import other person's certificate to your browser

In addition to other people's certificate's certificates automatically stored in your browser, you can manually import
some people's certificates with whom you may communicate through encrypted channel. For example, you can
export your contact's certificate to your local storage and import into IceDragon browser.

The procedure is same as importing your own certificate. Please see Import your certificate in the previous
section.

Export Other People's Certificates

You can export other people's certificate from IceDragon to a safe place, for safe keeping and for importing from
other browsers or email clients.

To export a certificate
+  Select the certificate
«  Click 'Export' and navigate to a safe location in your computer or your network.
«  Click 'Save'

Remove a Certificate

«  Select the certificate and click 'Delete’.

Delete E-Mail Certificates >

Are you sure you want to delete these people's e-mail certificates?

Brian Smith

If you delete a person's e-mail certificate, you will no lenger be able to send
encrypted e-mail to that person.

QK Cancel

+  Click 'OK"in the confirmation dialog.

Server Certificates

The 'Server Certificates' tab lists root certificates that are pre-embedded in IceDragon or have been imported by the
user.
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Certificate Manager *®
Your Certificates People Servers Authorities Others
—
You have certificates on file that identify these servers
Certificate Name Server Lifetime Expires On &

w Digilotar

DigiMatar Roat CA " Permanent Monday, March 31, 2025
wDigilotar BV,

CigiMatar PEloverheid CA Organisatie - G2 * Permanent Maonday, March 23, 2020

Delete Add Exception...
OK

This interface allows you to:

+ View the certificate details — The procedure is similar to view your own certificates. Please see View the
Details of the Certificate for more details.

- Export Server Certificates - Export and save server certificate in a safe location for future use, example,
for importing to other browsers or email clients. The procedure is similar to exporting other people's
certificates. Please see 'Export other people's certificates' for more details.

« Import Certificates from local storage — Import server certificates stored locally in your system or in your
network into the browser. The procedure is similar to importing your own certificates. Please see 'mport
your certificate ' for more details.

+ Delete certificates — Delete expired and unwanted certificates. The procedure is similar to deleting other
people's certificates. Please see 'Delete other people’s certificates' for more details.

+ Add Exceptions — Some of the websites may use a certificate that has not been issued by a trusted CA. If
you visit those websites, Comodo Ice Dragon will display a warning:
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Your connection is not secure

The owner of expired.badssl.com has configured their website improperly. To protect your information
from being stolen, lceDragon has not connected to this website.

Leam more...

Report errors like this to help Mozilla identify and block malicious sites

-

expired.badssl.com uses an invalid security certificate.

The certificate expired on Monday, April 13, 2015, 2:59 AM. The current time is Friday, April 27, 2018,
5:41 PM.

Error code: SEC_ERROR_EXPIRED_CERTIFICATE

Add Exception...

« Ifyou trust the site, click 'Advanced' > 'Add Exception' and proceed with adding this site as an exception.

The 'Add Exceptions' interface allows you to add such trusted websites in advance, to be exempted from the security
check.

«  Click 'Add Exception' in the 'Servers' tab of the 'Certificate Manager' dialog to add a website manually.
«  Type the url of the site to be exempted from the security check and click 'Get Certificate'.

The browser fetches the certificate, checks for its legitimacy and displays its status.
« Ifyou trust the site, click 'Confirm Security Exception'.

The website will be added to the exceptions and transactions through it will be allowed by the website even if the
certificate is not trusted.

Authorities

The 'Authorities' tab displays the root certificates of trusted CAs that are pre-embedded in Comodo IceDragon.
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Certificate Manager x

Your Certificates People Servers Authorities Others

You have certificates on file that identify these certificate authorities

Certificate Name Security Device "B
~AC Camerfirma 5.4, G
Chambers of Commerce Root - 2008 Builtin Object Token
Global Chambersign Root - 2008 Builtin Object Token
~AC Camerfirma 5A CIF AB2743287
Camerfirma Chambers of Commerce Root Builtin Object Token
Camerfirma Global Chambersign Root Builtin Object Token
wACCY W
View... Edit Trust... Import... Export... Delete or Distrust...
oK

This interface allows you to:

« View the certificate details — The procedure is similar to viewing your own certificates. Please see View
the Details of the Certificate for more details

«  Configure Trust Settings — Configures the level up to which the other authorities' certificate and its issuer
can be trusted.

«  Select the certificate and click 'Edit Trust' in the 'Authorities' tab
The 'Edit CA certificate settings' dialog configures Trust Settings on the CA that has issued this certificate.

Edit CA certificate trust settings x

The certificate "COMODO ECC Certification Authority” represents a Certificate Authority.

Edit trust settings:

This certificate can identify websites.

This certificate can identify mail users.

[] This certificate can identify software makers.

QK Cancel

»  Select the entities that can be authenticated by this CA and click 'OK'.

« Import Certificates from local storage — Import server certificates stored locally in your system or in your
network into the browser. The procedure is similar to importing your own certificates. Please see 'Import
your certificate' for more details.

«  Export Server Certificates — Export and save server certificate in a safe location for future use, example,
for importing to other browsers or email clients. The procedure is similar to exporting other people's
certificates. Please see 'Export other people's certificates' for more details.

« Delete or Distrust certificates — Delete expired and unwanted certificates. The procedure is similar to
deleting other people's certificates. Please see 'Delete other people's certificates' for more details.

Others

The 'Others' tab displays certificates that do not fall under any of the other categories. You can View, Export and
Delete certificates from this interface.
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Certificate Manager X

Your Certificates People Servers Authorities Others

You have certificates on file that do not fit in any of the other categories

a

Certificate Name Security Device

View... Export... Delete..

OK

Configure Security Modules that store Certificates and Passwords

Comodo IceDragon contains built-in security modules to store your passwords and certificates securely. In addition
for enhanced security, you can use external security devices like smart cards to store your certificates and
passwords, and configure IceDragon to fetch your certificates and passwords from them.

Security modules

A Security Module or a PKCS#11 module is a program to manage encryption and decryption using the PKCS #11
standard. A PKCS #11 module can control a software security devices as well as hardware security devices like a
smart card or token, in a reader inserted into a slot dedicated for the module

By default, Comodo IceDragon has two internal PKCS#11 security modules.
« NSS Internal PKCS #11 Module that controls two types of security devices:

«  Generic Crypto Services - A special software security device for all cryptographic operations required
by the Netscape Internal PKCS #11 Module.

- Software Security Device - A software security device for storing your certificates and passwords that
cannot be stored on external security devices, including any CA certificates that you have installed in
addition to default CA certificates that came with the browser.

«  Built-in Roots Module controls a special security device called the Built-in Object Token.

«  Built-in Object Token - A token that stores the default CA certificates that came with the browser.

Manage Security Modules
«  Click the hamburger/ 'Open Menu' button at the top-right
«  Select 'Options' > 'Privacy and Security' > 'Security’'

«  Click 'Certificates' then 'Security Devices' button
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Device Manager x
Security Modules and Devices Details Value Log In
M55 Internal PKCS #11 Medule
Log Qut
Generic Crypto Services
Software Security Device Change Password
~Builtin Roots Medule
Builtin Object Token Load
Unload
Enable EIPS
OK

This dialog enables you to:
« View the details of existing security modules
« Log-in to a security device for using cryptographic services
» Change master passwords for the security devices
« Add security devices
» Enable FIPS Mode
To view details of a security module or a device
«  Click on the module or the device

»  The details of the module or the device is displayed in the middle pane

Device Manager X
Security Modules and Devices Details Value Log In
NS5 Internal PKCS #11 Module Module Builtin Roots Module
) ) Log Qut

Generic Crypto Services Path CA\Program Files (x86)\COMODO\ceDragonns...

Software Security Device Change Password
Builtin Roots Module

Builtin Object Token Load

Unload
Enable FIPS
OK

Login to a security device
+  Select the security device and click 'Log In'

«  Enter the Master Password for the security device and click 'OK'
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Change Master Password *

Security Device:  Generic Crypto Services

Current password: (not set)

Mew password: |""" |

Mew password (again): | ........".| |

Password quality meter

QK Cancel

Note: You need to enter the Master Password for the browser to fetch the certificates and passwords. If you haven't
set a Master Password please see the instructions on 'To set or change Password'.

You will be logged-in to the security device so that the browser can access the certificates and the passwords stored
by the security device.

« Tologout of the security device, click 'Log Out'
To set or change master password
«  Select the security device and click 'Change Password'

Change Master Password =

Security Device:  Software Security Device

Current password: | | |

Mew password: | |

Mew password (again): | |

Password quality meter

QK Cancel

«  Enter your current password in the 'Current password' field. If you are setting the 'Master Password' for the
fist time, leave this field blank

«  Enter your new password, re-enter it for confirmation in the respective fields and click 'OK'".
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Alert >

; I\ Master Password successfully changed.
Lm

oK

Add a new security device

If you want to use an external security device like a smart card, you need to first install the module software following
the instructions that came with the security device. You may have to physically connect the device to the port
specified in the instructions during installation. After installation:

+  Click the hamburger/ 'Open Menu' button at the top-right
«  Select 'Options' > Privacy and Security' > 'Security'
Click 'Certificates' then 'Security Devices' button

+  Click the 'Load" in the 'Device Manager' interface

&) Load PKCS211 Device Driver = *

Enter the information for the module you want to add.

Module Mame | [JETRA 08200 T ]

PModule filename | | Browse...

QK Cancel

»  Enter a name for the new device in order fo the browser to identify it in the '"Module Name' field.
+  Enter the path of the module file you installed with the device in the 'Module filename' field.

+ Alternatively, click 'Browse' and navigate to the location in your hard drive where you have installed the
module and click 'Open’

« Click 'OK".
Your new module will be loaded. You can set a password and login to the device for the browser to access the
certificates and passwords stored by the new device.

»  Toremove a module, select the module and click 'Unload'.

Enable FIPS Mode

Federal Information Processing Standards Publications (FIPS PUBS) 140-1 is a US government standard for
implementations of cryptographic modules - hardware or software that encrypts and decrypts data or performs other
cryptographic operations (such as creating or verifying digital signatures).

All the encryption and decryption processes of Comodo IceDragon can be configured to adhere to FIPS PUBS 140-1
through the Device Manager interface.

+  Click the hamburger/ 'Open Menu' button at the top-right

»  Select 'Options' > Privacy and Security' > 'Security'
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«  Click the 'Certificates' tab then 'Security Devices'
Click 'Enable FIPS'

7.13.  Force Secure Connections

The 'Force Secure Connections' feature allows you to specify that all future connections to a particular site are made
over a secure HTTPS connection. You can also enforce HTTPS connectivity with any sub-domains of the domain.

When you visit a site over HTTPS, Comodo IceDragon will show a padlock icon on the *right* of the address bar.

By default, the padlock is gray, meaning secure connections are not yet enforced. No additional actions will be
performed if the page is loaded again.

«  Click the ellipsis on the address bar to select the padlock icon to enforce secure connections:

Eile Edit View Higtory Bookmarks Jools Help

k= SSL Certificate #1 Secure Sock- X | =4

&« c @ @ & Comodo CA Ltd (GB) @E we f Q, searct »

3+ Most Vie ﬁ Bookmark This Page

th America @ -
% Copy Link

INSti © emiin. i@ +1 888 266 6361

b £) sendTabto Device ’ International +1 703 581 6361

ww Web Inspector

SSL Cerc___:> entity Compare SSL Enterprise
m Enforce secure connections

F— 3

\

File Edit Wiew History BookmarksgTools Help

‘.. SSL Certificate #1 Secure Socks X +

&« ¢ o @ & C.. (GB) | https/ e @ ow Ty »

4L} Most Visited T Getting Started

Secure connections enforced

www.instantssl.com erica @ ~
Connections to all pages on this host will be

lnStant SSL ht Force Hﬁ?:um-ubdumainﬁ | 3 +1 BBB 26£

by coMoDO G Options ~ Leam More

International +1 70
Don't Force HTTPS  Daone

«  The address bar padlock will turn green, meaning secure connections are enforced for this session and all
future visits

« Al information exchanged between you and this website will be encrypted using the strongest available
algorithms

»  Check 'Force HTTPS on all subdomains' box if you want secure connections throughout the domain

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 13



Comodo IceDragon - User Guide/ comono

/

« Ifyou wish to disable forced secure connections, click 'Don't force HTTPS'.

Example usage

This feature is particularly useful for websites that do not, by default, use secure connections on their login pages.
For example, the Pandora sign-in page does not ordinarily have HTTPS connections on its log-in page Note: the
address is plain HTTP instead of HTTPS - the 'S' stands for secure:

File Edit View History Bookmarks Tools Help _ 0O 4
p Pandora x ¢ HsenupHbie ykpawenna va o X | =

« C @ (@ # https;//e-pandora.com.ua? see ww g » =
I+ Most Visited [ Getting Started [ From Internet Explorer

It's possible your credentials may still be posted to HTTPS once you click the 'Sign in' button, but the absence of a
certificate on this page means you cannot verify the authenticity of the website. Furthermore, loading the sign-in
page over HTTP also means you cannot verify the page's integrity - it may have been modified by a 3rd party before
it loaded in your browser.

With a HTTPS connection, you can click the lock on the left of the address bar to view the website's SSL certificate.
Apart from encrypting the information you submit and ensuring page integrity, the certificate also contains critical
website identity information which allows you to verify that you are connected to the genuine Pandora website.

To force secure connections on the Pandora log-in page:
»  You first have to physically change www.pandora.com to https://www.pandora .com

Do this by placing your mouse cursor in the IceDragon address bar and typing 'https://' before www.pandora
.com so the full URL says https://www.pandora.com

»  Press enter. The page will re-load with a secure connection and thus make available the 'Force Secure
Connections' padlock on the right:

File Edit View History Boockmarks Tools Help _ 0 w0
' Pandora 4 +
< Cc @ @ @& https://www.pandora — we ¥y » =
L+ Most Visited T Getting Started £ From Internet Explorer

«  Click the padlock to enforce secure connections. All future visits to the Pandora log-in page will be
automatically conducted over a secure, encrypted connection:

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 14



Comodo IceDragon - User Guide / comooo

/

File Edit View History Bookmarks Tools Help — O w0
p Pandora x +

<« d @ @ https://www.pandora ses @ we Ty » =
4 Most Visited (C Getting & < Site Security

pandora & www.pandora.com

Secure Connection

Verified by: DigiCert Inc

More Information

7.14.  Website Security Indicators

+ lceDragon security indicators are shown in the website address bar and tell you about the safety of the
connection between you and the website you are visiting.

«  Transport Layer Security (TLS) and Secure Sockets Layer (SSL) are protocols which encrypt the
connection between your internet browser and the web site you are visiting.

Al data passed over an SSL/TLS connection is encrypted, so it cannot be deciphered or understood by
anybody who intercepts the communication. This prevents sensitive data like credit card numbers and
passwords from being stolen by hackers.

+ A website can implement encryption by installing an SSL/TLS certificate on their web server. Websites
protected with an SSL/TLS certificate will show a lock icon in the browser address bar.

The following table show the different types of icons you will see in the Ice Dragon address bar:

[e])] Description

D) «  The connection to the site is insecure. It does not have a TLS/SSL certificate installed.
«  The owner of the website has not been verified.

Do not submit confidential information or enter your username password to an insecure site.

"] » The green lock appears when IceDragon establishes a secure connection to a web site. Your
connection to the site is encrypted.

< The address of the site will begin with 'https://' (e.g. https://lexample.com)

« Ifthe site uses an Extended Validation SSL (EV SSL) certificate, the organization's name will
appear next to the icon with green text.

® - The page contains some insecure content. Even if a site has a certificate installed, you will see
this error if the page loads images or other content from an insecure site.

A «  The page hosts dangerous content or has an invalid certificate.

To view the security Site Setting menu and Global Default information
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«  Click on the icon at the left of the URL in the address bar to view the identity information from the drop-
down

story  Bookmarks Tools Help

Leaderin Cyb X m CMM International - Breaking | X | ==

'l' https:/fedition.cnn.com e uns 1:? (

Getting % i
& edition.cnn.com

>
- Secure Connection

) Tracking Protection

. . ir lawyer ¢
lceDragon is blocking parts of the page that may :
track your browsing. 15 betwes

Thomi _ . .
| Disable protection for this site v el
§ weddi ns bury de
.. ims big br

4<| Permissions
Y¥ou have not granted this site any special clip that's
- ermissions.

OPINN ° 2 changes

Frmmil free e e T e ey

The 'Control Central' pane displays the current connection to the site.
Click the right arrow on the Control Center to view the identity information of a certificate, the website's
owner, and change settings for the site that you are currently visit.
«  Tracking protection indicates whether or not a page contains elements that track you. See Block Websites
From Tracking Your Browsing Activities for more detailed information.

« Permissions indicates any permissions you have set to the website. You can remove permission from the
Control Center.

+  You can also manage items available from the 'Permissions' under the 'Privacy and security' section.
See View and Manage Permission Settings for more details.

7.15.  Disable Accessibility Indicator

The Ice Dragon accessibility service is designed to improve how websites are rendered for physically impaired
users. If the service is enabled, it allows 3rd party applications to inspect, monitor, visualize, and alter web page
content.
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Permissions

® Location Settings...
MM Camera Settings...
& Microphone Settings...
E Motifications Learn more Settings...

Pause notifications until lceDragon restarts

Block pop-up windows Exceptions...

+ Warn you when websites try to install add-ons Exceptions...

Prevent accessibility services from accessing your browser Learn more

» Prevent accessibility services from accessing your browser — Enable this checkbox if you do not wish
to extend these privileges to accessibility services. You may want to do this if you do not have any
physically impaired users that use your Ice Dragon installation.

7.16.  Configure IceDragon Performance and Browsing
Settings

+ lceDragon let you tweak certain hardware settings to ensure the fastest browser performance without
placing undue burden on system resources.

- Hardware acceleration, for example, can improve playback in YouTube and 3D Earth.
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Performance

égse recommended performance se‘rtingsé Learn more

These settings are tailored to your computer's hardware and operating system.

v Use hardware acceleration when available

Content process limit 4 (default) -

Additional content processes can improve performance when using multiple tabs, but will also

USE mMmare memaory.

Browsing

v Use autoscrolling
v Use smooth scrolling
v Show a touch keyboard when necessary

Always use the cursor keys to navigate within pages

Search for text when you start typing

« Use recommended performance settings automatically setups your browser with computer settings.

+ Use hardware acceleration when available - Instructs the browser to use your graphics processor to
handle graphically intensive pages, reducing the load on your main processor. This increases the
speed at which the web-pages are loaded and improves your browsing experience.

«  Content process limit — Improves performance by increasing the number of processes assigned to
handle video content. Adding more processes will also commit more memory to the task, which might
degrade the performance of other tasks that are running on your computer.

« Use auto autoscrolling - If selected, you can click the center mouse button on a web page to enable auto-
scrolling. You can then move the page up or down by simply moving your mouse. Note — make sure to click
on an 'empty’ area of the page. Middle-clicking on a link will open the linked page in a new tab.

» Use smooth scrolling — Makes the page to scroll up or down smoothly when you press the 'Page Up' or
'Page Down' Keys. This option is useful when reading lengthy pages as it makes it easier to resume from
where you left off.

«  Show a touch keyboard when necessary — Allows Ice Dragon to detect touchscreen devices. An on-
screen keyboard will appear when entering text on a touchscreen device.

To disable touch screen detection
« Type: about:config in the address bar
«  Confirm that you will be careful in the warning message
«  Enter ui.osk.detect_physical_keyboard in the text box. It will be set to false
- Always use the cursor keys to navigate within pages - Enables 'Caret browsing' within the webpage -

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 18



Comodo IceDragon - User Guide / comooo

/

displays a blinking text selection cursor that can be moved using the arrow keys in your key board. The
cursor enables you to select a piece of text from the webpage to your clipboard directly, point to links, move
from field from field and so on, using the keyboard.

« Alternatively, press F7 from your keyboard.

Caret Browsing *

9 Pressing F7 turns Caret Browsing on or off, This feature places a moveable cursor in web pages,
#  allowing you to select text with the keyboard, Do you want to turn Caret Browsing on?

[] Do not show me this dialog box again.

Yes Mo

e Click 'Yes'

+ Search for text when you start typing — Completes searches quicker by starting your search immediately
when you start typing. Search results will be shown in real-time under the search box.

«  Check your spelling as you type - If enabled, the browser will check the spelling of every word or phrase
you type into various fields of a web-form. This features requires dictionaries to be downloaded.

To download a dictionary, while typing inside a field in a web-form, right-click on the field, select 'Languages
from context sensitive menu and select 'Add Dictionaries'. You will be taken the webpage from which you
can download required dictionaries.

7.17.  Network Proxy Settings

The 'Network Proxy' area lets you configure how IceDragon should connect to internet. For example, if your
organization or internet service provider (ISP) may require you to connect to the internet through a proxy server.

You may consider using a proxy for the following reasons:
»  To anonymize your connection to the internet
»  To speed up internet access
- Toimplement access policy on a network (for example, to block undesirable websites)
»  To audit internet usage
- To scan traffic for malware prior to it entering or leaving the internal network
To set up a proxy connection
»  Click the hamburger/ 'Open Menu' at the top-right
«  Click 'Options' > 'General'

»  Scroll to the 'Network Proxy' section

Network Proxy

Configure how IceDragon connects to the Internet Settings...

»  Click 'Settings'. The 'Connection Settings' dialog will open:
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Connection Settings x

Configure Proxies to Access the Internet
No proxy
Auto-detect proxy settings for this network
® Use system proxy settings
Manual proxy configuration
HTTP Proxy Port 0

Use this proxy server for all protocols

SSL Proxy Port 0
FTP Proxy Port 0
SOCKS Host Port 0
SOCKS v4 SOCKS ¥5
Mo Proxy for

Example: .mozilla.org, .net.nz, 192.168.1.0/24

Automatic proxy configuration URL

Reload

OK Cancel Help

»  No proxy - Select if you don't want to use a proxy.

«  Auto-detect proxy settings for this network - If enabled, IceDragon will automatically detect the
proxy settings for your network.

« Use system proxy settings - If selected, you can configure proxy settings for your operating system.

«  Manual proxy configuration - If selected, allows you to set more than one proxy server. Each proxy
requires a hostname and a port number.

«  Checkbox 'Use this proxy server for all protocols' for the same proxy name and port number
used for all protocols

»  No Proxy For - List of hostnames or IP addresses that will not be proxied. Use <local> to bypass
proxying for all hostnames which do not contain periods.

» Automatic proxy configuration URL - If selected, determines to run proxy server automatically. Enter
the URL and click 'OK' to save changes and load the proxy configuration.

» Reload: Load the currently available proxy configuration.

«  Check-box 'Do not prompt for authentication if password is saved' to set your proxy credentials to enter
the proxy's username ans password.

»  Check 'Proxy DNS when using SOCKS v5' box to enable remote DNS when use SOCKet Secure v5.
+  Click 'OK' for the settings to take effect.
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8. Downloads

This section explains how to download a file from the internet, change default download location, and view/clear
download history. Click the following links to find out more:

+ Download aFile
» Change Download Location
» View download history

»  Clear download history

8.1.Download a File

When you start downloading a file from the internet, Comodo IceDragon displays the progress of the download in the
navigation toolbar (click the downward pointing arrow to view downloads).

It also scans for viruses to prevent malware downloads.

The downloads window displays information about each download, including file name, file size, time remaining
before the download is complete, where the file was downloaded from, and the time or date of the download.

«  To view the three most recently downloaded items, click the download button in the navigation toolbar

«  To view all downloads, click 'Show All Downloads'. This will open the 'Library' interface and a list of all
downloaded apps or files
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c - Inspiring Podca: X | == — O >
dnewsn e @ w1y v o» =
4 Downloads |
RK

[3Q Show Downloads Folder

cav_installer_10309_3f(2).exe

5.3 MB — com.dev — 4:32 PM

OperaSetup.exe

1.3 MB — opera.com — 4:25 PM

Show All Downloads

|
&) Library / = O *

2 Search Downloads |

!

i Organize ™  Clear Downloads

Histor_l.-'
teetup.1.2.6.exe
3 Downloads H % -
T - 21,1 MB — softonic.com — 4:39 PM
o Tags

All Bookmarks

cav_installer_10309_3f(2).exe
a

53 MB — com.dev — 432 PM

OperaSetup.exe =

1.3 ME — opera.com — 4:25 PM

«  To search for a particular download, type its name in the search box at the top of the interface
From here you can:

» Pause: Pauses any downloads currently in progress. Right-click the download and select 'Pause’. To
continue downloading files, right-click the file then select 'Resume’

« Cancel: Cancels the download. Right-click the file and select 'Cancel' button
+  Open the file: Double-clicks on the entry to open the file

«  Open the file's folder: Right-click on a download and select 'Open Containing Folder' to view the folder
that contains the file. See Change Download Location to specify other location.

« Go To Download Page: Right-click on the file and select 'Go to download page' to open the URL the file
was downloaded from

« Remove the file's entry: If you do not wish to keep a record of a particular download, right-click on the
download and select 'Remove From History'. This will not delete the file itself

» Retry: If for any reason a download does not complete, use the 'Retry' curve arrow next to the file entry and
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IceDragon will restart the download
«  Clear Downloads: Clears the whole list. This will not delete the downloaded files
«  Copy Download Link: Copies the download URL to clipboard.
Further reading related to the topic of this page:
» Change Download Location
» View Download History

» Clear Download History

8.2.Change Download Location

By default, Comodo IceDragon saves all downloaded files to C:\Users\<user name>\Downloads. You can change
this location or change settings so that you are asked for the location every time you start the download.

To change the download location
«  Click the hamburger/ 'Open Menu' button at the top-right corner
»  Click the 'Options' > Select 'General' > 'Files and Applications'

+  Under the 'Downloads' section, choose how you want to save files:

Files and Applications

Downloads

@ Save filesto ¥ Downloads Browse...

Always ask you where to save files

« Save files to - IceDragon automatically saves all downloads to the specified folder. If you want to
download the application in a location other than the default location, click 'Browse' to choose a
different location

+  Always ask me where to save file - IceDragon asks you to select a folder for every download you
wish to save

Further reading related to the topic of this page:
+ Download aFile
«  View Download History

«  Clear Download History

8.3.View Download History

You can view a list of downloaded files in the 'Downloads' page. The files are listed in chronological order.
To view your download history
»  Open the 'Library' interface by clicking the 'Download' button then select 'Show All Downloads'

«  Click on a file to open it
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»  Click 'Remove From History' to remove a specific download from the list.

«  Click 'Open Containing Folder' to see the location of the file in your computer. Please note that this will
not work if the file has been moved.

«  Click 'Go to Download Page' opens the URL from which the file was downloaded.
+  Click 'Copy Download Link' to copy the URL from which the file was downloaded.
«  Click 'Clear Downloads' to remove all downloads from the list. This will not delete the files themselves.
»  Enter the name of a download in the search box to find a specific item.
+  Use the shortcut keys 'CTRL+J to open the downloads page.
Further reading related to the topic of this page:

+ Download aFile
+ Change Download Location

+  Clear Download History

8.4.Clear Download History

Click the following links for more help:
« To remove specific items
+ To clear a history automatically
» To clear a download history manually
» To remove a single website

To remove specific items from download history

Click the 'Download' button then click 'Show All Downloads'
« Inthe 'Library' interface right-click the item and select 'Remove From History'

To clear history automatically

«  Click the hamburger/ 'Open Menu' button at the top-right then select 'Options'
« Inthe 'Privacy and Security' > 'History' section

«  Select the 'lceDragon will:' drop-down
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History

lceDragon will  Use custom settings for history e

G e Remember history

Mever remember history

v Remem

Use custom settings for history
v Remember search and form history

v Accept cookies from websites Exceptions...
Accept third-party cookies  Always .
Keep until they expire bl Show Cookies...
Clear history when IlceDragon closes Settings...

«  Remember history - Keeps a record of the pages you have visited, uses the text you have entered into the
search bar or into form fields, accepts cookies from sites until they expire

»  Never remember history - Keeps no record of your browsing history, will not remember text you enter into
form fields or the search bar, deletes cookies when you close IceDragon

« Use custom settings for history:

IceDragon will  Use custom settings for history O
@Iways use private browsing mode

Remember my browsing and download history

Remember search and form history

v Accept cookies from websites Exceptions...
Accept third-party cookies  Always bt
Keep until | close IceCragon Show Cookies...
Clear history when IceDragon closes Settings...

« Always use private browsing mode - CID will not remember any new history the next time it starts.

« Remember my browsing and download history - CID keeps a list of the pages you have visited
and a list of files you gave downloaded.

»  Remember search and form history - The text you enter into form fields or the search bar will be
remembered. For more information, see Form Autofill topic.
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»  Accept cookies from sites - CID will accept cookies from sites. Click 'Exceptions' to manages
Allow /Allow for Session or Block cookies. For more information, see Manage cookies topic.

«  Accept third-party cookies - CID accepts cookies
*  Keep until:

« they expire - Allows the sites you visit to specify how long IceDragon should keep their
cookies.

+ | close IceDragon - Removes cookies when you close CID.
+  Clear history when IceDragon closes - Saves items that will be deleted when you close IceDragon.
«  Exceptions - Displays the 'Exceptions' window
»  Show Cookies - Displays the 'Cookies' window
«  Select 'Use custom settings to history'

«  Check the box 'Clear history when IceDragon closes' > 'Settings' button next to it to manage what
items are deleted

«  The 'Settings for Clearing History' dialog will open:

Settings for Clearing History x

When I quit IceDragon, it should automatically clear all:

History
v Eﬁruwsing & Download History | v | Cookies
v'| Active Logins v | Cache

v | Form & Search History

Data
Site Preferences Dffline Website Data

OK Cancel Help

e _______________________________________________________________________________________________________ |
»  Select the items that have to be automatically cleared each time you quit.

+  Click 'OK".

To clear download history manually

»  Click the hamburger/ 'Open Menu' button at the top-right corner
«  Select 'Library' > 'History'
»  Click the 'Clear your recant history'

» Inthe 'Clear Recent History' dialog, select the period for which you want to delete the download history from
the 'Time range to clear' drop-down box

«  Click 'Details" arrow to select the type of information will get cleared
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Clear Recent History >
Tirne range to clear: | Today s
. Details

Browsing & Download History
[] Form & Search History

[] Cookies

] Cache

[] Active Logins

[] Offline Website Data

[] Site Preferences

Clear Mow Cancel

»  Click the 'Clear Now' button to delete history for the selected period and type of information. Note: Any
downloaded files will remain on your computer. This action just clears out your web data.

To remove a single website from the download history

This option deletes all history items (browsing and download history, cookies, cache, active logins, passwords, saved
form data, exceptions for cookies, images, pop-ups).

»  Click the 'Download' button and select 'Show All Downloads' then click 'History' from the left panel

«  Search the website you want to remove from your history by typing its name in the 'Search History' field in
the top-right corner.

+  Right-click on the site you want to remove, scroll down the 'Forget About This Site'
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Further reading related to the topic of this page:
+ Download a File
« Change Download Location

* View download history

9.Introduction to Add-ons

Add-ons, extensions and plug-ins help expand the basic feature set of Comodo IceDragon with additional
capabilities.

There are thousands of add-ons available, adding a wide variety of functions to IceDragon. For example, you can get
add-ons to:

»  Play certain video formats

»  Handle more file types

» Translate web pages

»  Change the IceDragon theme

+  Block adverts

»  Access your favorite shopping websites
»  Use animated mouse pointers

«  Quickly update your Facebook profile
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e ..and much more

To access the add-ons interface

»  Click the hamburger/ 'Open Menu' at the top-right > Select 'Add-ons'.

— O =
.
Q_ Search x| =
£4 Signinto Sync
E',_ Mew Window Ctrl+M
2 New Private Window Ctrl+Shift+P
Zoom - 1w 4+
Edit
I\ _Libra >
Add-ons Ctrl+ Shift+ A
-I:I- Opficns
,"” Cuftomize...
v
Eile Edit Miew History Bookmarks Tools Help — o w
C Comodo| Global Leaderin Cy % | ¥ Options ® | dg Add-ons Manager ® | =+
c @ ragen  aboutaddens o Q, s " =

{} Mozt Visited c Getting Started b Fram Intemet Explores

s Get Add-ons . .
Lo Personalize Your Firefox

*' Extensions There are thousands of free add-ons, created by developers all over
the world, that you can install to personalize your Firefox. From fun
# Themes visual themes 1o powerful tools that make browsing faster and
L safer. add-ons make your browser yours. Te help you get started,
here are some we recormmend for their stand-out performance and
il Plugins functionality.
Spring is Here oy isayTheseach d b
P A

Huower aver the irmage to preview

Comodo IceDragon enables you to install three types of Add-ons.
« Extensions - Add new features or modify existing features. Examples include extensions to block
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advertisements, to download videos from websites, to add features from other browsers and to integrate
IceDragon with websites like Facebook.

»  Themes - Change the look of overall look of the browser including buttons, menus and other browser
elements. 'Personas' decorate the menu bar and tab strip with a background image.

«  Plugins - Add support for different kinds of internet content. This includes patented formats like Flash,
QuickTime, and Silverlight that are used for video, audio, online games, presentations.

Click the links below for more help:
+ Download and Install Add-ons
+ Install Add-ons from local storage

« Configure updates for add-ons

9.1.Download, Install and Configure Add-ons
»  Click the hamburger menu button at top-right
«  Select 'Add-ons'
»  This will open the 'Get Add-ons' screen
»  Click 'See more add-ons!" at the bottom of the page to visit the Mozilla add-ons page.
»  You can search for a particular add-on or browse through the add-on categories.

»  Each add-on comes with a brief description and you can also read reviews and comments from fellow

users.
File Edit View History Bookmarks Tools Help _ O e
C Comodo | Global Leader - X ‘ -n- Options X | *- Add-ons Manager X | 4% Add-ons for Firefox X |+
C @ (@ @ https;/addons.mozilla.org/en-L ses e T Q, Search r =
I} Most Visited (T Getting Started  [3] From Internet Explorer
BXLENSIONS. Are you - - - - I _— N
interested in... Bookmarks  Password Ad blockers  Smarter  Productivity = Watching
managers Shopping Videos
Popular extensions See more popular extensions
@ Adblock Plus @ uBlock Origin Video Easy
- 2 11,900,910 4,835,807 ' DownloadHel Screenshot
USETS USEers per 2,242,647
3,259,960 USErs
Users
Featured extensions See more featured extensions
@ Pearltrees T Font Finder Fls Flash-HTMLS @ YouTube
11,017 users ~ (revived) Player for Control
18,922 users YouTube™ Center

43,851 users 7,517 users

Top-rated themes See more highly rated themes
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Once you have chosen your add-on, click 'Add to Firefox' then click 'Add" at the prompt. All Firefox
extensions can be installed to IceDragon.

The add-on will be downloaded and a notification of the successful installation will be displayed.

Some add-ons may require your browser to be restarted for the installation to take effect. If it prompts you,
click 'Restart Now'.

9.1.1. Install Add-ons from Local Storage

If you have a local copy of an add-on installer, you can install it as follows:
»  Click the hamburger button and select 'Add-ons'
»  Click 'Extensions' on the left then click the gear icon on the right

»  Select 'Install Add-on From File' from the options.

Eile Edit Miew History Bookmarks Tools Help

= O X
¥ Options X | i Add-ons Manager X | 4
« c @ eDrac aboutaddons w Q search B M =
£} Most Visited ([ Getting Started 5 From Internet Explorer
-n- = b all on
*
# Get Add-ons LCheck for Updates
SHINE for rede  Yiew Recent Updates
ﬁ Experience redd C_In=tall Add-on From File v
Debug Add-ons
,¢ Themes _
~  LUpdate Add-ons Automatically
— i Reset All Add-ons to Update Automatically
I Flugins

»  Navigate to the location of the .xpi file you want to install
»  Click 'Open'

»  The add-on will be installed. If required, restart the browser to enable the add-on.

9.1.2. Configure Updates to Add-ons

Ice Dragon can automatically check for and install updates for add-ons.
To configure updates
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»  Click the hamburger/ 'Open Menu' button at the top-right > select 'Add-ons'".
The' Add-Ons Manager' page will open in a new tab:

«  Click the gear icon on the upper-right of the screen

«  Click 'Check for Updates' to manually update your add-ons

«  Click 'View Recent Updates' to see your most recently updated add-ons

« Enable 'Update Add-ons Automatically".

File Edit Niew History Bookmarks Tools Help

- O >
-I:- Options X *- Add-ons Manager x |+
L€ ) C @ ce..gon  about:addons g » =
L} Most Visited (T Getting Started  [5] From Internet Explorer
ﬁ- - Search all add-ons jo

0¢+

Check for Updates

o

OWE

SHINE for re View Recent Updates
ﬁ Experience re Install Add-on From File...
D‘E g Sdd-on

\

.

Update Add-ons Automaticall
-— Beset All Add-ons to Update Automatically

9.2.Manage Extensions

To view installed Extensions
+  Click the hamburger button at top-right
+  Select 'Add-ons'

«  Click 'Extensions' on the left to view a list of all installed extensions.
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File Edit ¥iew History Bockmarks Tools Help — 0 W
-ﬂ- Options X *. #Add-ons Manager ¥ | W% Dark Theme for YouTube™ - 4 X +
« ¢ @ eDragon  aboutiaddons b g Q, search =M o a =
£+ Most Visited [T Getting Started From Internet Explorer
'n" JEarch all agd-ons
:@' Get Add-ons
. Amazon Quick Search
a- Extensions a Q Disable Remove
Amazon Quick Search More
J’ Themes Dark Theme for YouTube™
e Disable Remave
_— . A Dark and Smooth Theme f... More
] Plugins
SHINE for reddit (unofficial)
ﬁ Disakle Remove
Experience reddit with new ... More
uBlock Origin
@ Options [hsable Remove
Finally, an efficie.. Maore

Most extensions allow you to configure and customize them as per your requirements.
» To configure an extension, click 'Options' then edit preferences in the resulting dialog.
«  To turn an extension off, click the 'Disable' button

» To uninstall an extension, click the 'Remove' button

9.3.Customize the Appearance of IceDragon

Why not get creative? Personas and themes let you to change the entire look and feel of Comodo IceDragon.
Available through the add-on manager interface, there are two main ways to customize IceDragon's appearance:
»  'Personas' - Lightweight themes that let you customize the menu bar and tabs with background images
*  'Themes' - Enables you to customize the whole browser window
Click the links below for more help:
» Download and install Personas and Themes
» Manage Personas and Themes
Download and install Personas and Themes
+  Click the hamburger button at top-right
+  Select 'Add-ons'.
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«  Click 'See more add-ons!" at the bottom to view the Firefox add-ons website.
«  Click 'Themes' to view recently added and popular themes.
»  Use the 'Categories' on the left to narrow your search.

»  Select the theme and click 'Tap to preview' to see how a Persona will look.

Eile Edit View History Bookmarks Tools Help

ﬂ Options * “- Add-ons Manager ¥ | % Spring Garden Serenity by Mall X | =+

&« c @ @ J¢ B https;//addons.mozilla.org wes v Y Search g o | @ a

I} Most Visited (T Getting Started [ From Internet Explorer

Developer Hub & | Register or Log in

-) Firefox Add-ons

2,382 69 *hk ik
Users Ratings Overall
Rating

MaDonna
by

« Ifyou want to install a Persona, click the 'Install Theme' button
« To browse available themes, click 'See more highly rated themes'

»  Once you find a theme that you like, click it to be taken to its download page.
Manage Personas and Themes

You can easily choose which Persona or Theme you wish to use by clicking the 'Themes' link in 'Add-ons Manager":

To use a Theme or Persona, click 'Enable’. Personas will be applied immediately but Themes need the
browser to be restarted.

To restore the browser to default Theme, click 'Disable' in the row of currently applied Persona or Theme.

« Toremove a persona or theme permanently, click 'Remove' on its row.

9.4.Manage Plugins

Plug-ins are a type of add-on that enable IceDragon to handle the internet content in formats that the
browser do not support.

Examples include patented formats for documents, video, audio, online games, presentations and so
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*  Plugins to handle these formats of data are usually supplied by third-parties.

Popular plug-ins include:
» Adobe Flash
*  Windows Media Player

« Java

*  Quicktime

+  Adobe Reader
»  Silverlight

«  Adobe Shockwave

To view installed plug-ins
+  Click the hamburger button at top-right
+  Select 'Add-ons'
+  Click 'Plugins' on the left hand side.

File Edit View History Bookmarks Tools Help

- O X
-ﬂ- Options X *- Add-ons Manager ¥ | ¥ Add-ons for Firefox x | +
<« c Gr ceDragon  about:addons ﬁ O\ Search E. ﬁ D a =
I} Most Visited (T Getting Started [ From Internet Explorer
-ﬁ- - Search all add-ons j::f'
+
ﬁ Get Add-ons
* Extensions Missing semething? Seme plugins are ne longer supported by lceDragen. Learn More,
== OpenH264 Video Code... i
_'/ Themes i o Options Always Activate v
This plugin is aut... More
@l Plugins == Widevine Content Decr... )
- Options Always Activate ot
Play back protec... More
== Shockwave Flash )
Options Ask to Activate v

Shockwave Flash.., More

« To see an overview of the plugin, click the 'More' link next to the description of the plugin.

«  Select 'Never Activate' from the drop-down beside the plugin to stop the plugin from running.

10. Tools and Other Features

«  Comodo IceDragon has a number of built-in tools for specialist tasks. For example, the web page scanning
tool, spell checker and so on.

*  You can also add as many tools as you like to the browser. See Install Add-ons for more details.
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Click the following links for more help features:
» Customize applications for opening different file types
+  Search within page content
»  Form autofill
» Keyboard and mouse shortcuts for Comodo IceDragon
» Manage IceDragon in safe mode
» Scan websites for malware and blacklist using Web Inspector
»  Set up IceDragon sync information
» View Digital Rights Management

+ Improve IceDragon Performance Settings

10.1.  Customize Applications for Opening Different File
Types

«  Comodo IceDragon ships with several plug-ins to handle the different types files you may encounter online.
»  File types include audio files, video files, play lists, presentations and so on.

*  You can add additional plug-ins from third-parties and configure which app should be used to handle a
particular type of content.

To customize applications
«  Click the hamburger/ 'Open Menu' button at the top-right corner.
»  Click 'General' > scroll down to 'Files' and Applications
«  Select 'Applications' on the left.

Alist of internet content types and their associated plug-in or application will be displayed:
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Files and Applications

Downloads

® Savefilesto ¥ Downloads Browse...

Always ask you where to save files

Applications
Choose how IceDragon handles the files you download from the web or the

applications you use while browsing.

£ Search file types or applications

Content Type =~ | Action

i e L Always ask

i ircs [Z Always ask

= mallto [£] Use Thunderbird (default)
B Podcast LZ Preview in lceDragon

=L Portable Document Format (PDF) (2 Preview in lceDragon

k] Video Podcast LZ Preview in lceDragon

B Web Feed L2 Preview in lceDragon

iw webcal L2 Always ask

» Locate the content type you wish to modify in the ‘Content Type' column.

+  Click the drop-down in the 'Action’ column to review or change the application or plug-in IceDragon should
use to open the content. Plug-ins have the blue building block icon next to them:
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Content Type ~ | Action
7 Adobe Acrobat XML Uata Packa... @@ Use Adobe Acrobat (in lceUrag... .

& irc (2 Always ask
& ircs (Z Always ask i
= IPS file @ Use NVIDIA 3D Vision (in IceDra...
& mailto [I] Use Thunderbird (default)
= MPO file & Use NVIDIA 3D Vision (inlc... = r
®| PNS file [ Always ask

Podcast [i] Save File

B Use NVIDIA 3D Vision Phot...

= Use NVIDIA 3D Vision (in Ic...
Video Podcast I
Use other...

B
™ Portable Document Format (PDF)
B

»  Select 'Always Ask' if you want select which application to use each type you download the file type.
»  Select 'Save File' to automatically save files of that content type.
«  Select 'Application Details' to view more information about the application prior to your making a decision.

«  Select 'Use Other' to specify a different application which should be used to open files of that content type.
Alist of applications installed on your system will be displayed:
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Select Helper Application *

. MPO file
— image/mpo

Send this item to:

! NVIDIA 3D Vision Photo Viewer

Q Windows Media Center

m

Browse... QK Cancel

«  Select the application from the 'Select Helper Application' dialog and click 'OK'.

+  Click the 'Browse..." button to locate you application if it is not listed in the dialog.

To remove a custom application from the list in the drop-down
»  Click the 'Action’ drop-down and select 'Application Details':
7 Use thebat_32 6-7-3b.exe -

(I Always ask
[©] Use Thunderbird (default)

B Use thebat 32 6-7-36.exe

Use Yahoo! Mail

m

B Use Gmail
Use Yahoo! Mail

Use other...

Application Details...

1

«  This will open a list of applications that are capable of opening the content type. Select the application
you no longer wish to use and click 'Remove'.
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Application details x

The following applications can be used to handle mailto links.

thebat_32_6-7-36.exe

Yahoo! Mail
1 Gmail
Yahoo! Mail

This application is located at:
Fithebat_32_6-7-36.exe
OK Cancel

«  Click 'OK".

10.2.  Search within Page Content

The 'Find' features lets you search for a specific word or phrase in the web-page you are viewing. You can also
configure the browser to launch an auto-search when you start typing a keyword or phrase.

Click the following links for more help with:
» Search using the 'Find' feature
+ Launch auto-search

Search using the 'Find' feature
«  Click the hamburger/ 'Open Menu' button at the top-right corner
+  Click 'Find' or press Ctrl+F on your keyboard
«  Type your keyword/phrase in the search field at the bottom-left of the window

The first occurrence of the keyword in the page will be shown highlighted in green.
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Zero everywhere and its effects Two W bosens (observed)
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to create Higgs bosons and other particles for observation and study. On 4 July 2012,
L
..:--""'-_'—_._-__u_""‘:-\.. - PR u P - —— e o aes
(I']i_ggs pal | ~ | 3’) Highlight Al Match Case  Whole Words 1 of 28 matches X
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«  To search for successive occurrences, click 'Next'.
«  To highlight all occurrences, click 'Highlight all'.

«  Select 'Match case' to search for instances of the keyword that use the same case (upper and lower case)
as the characters you enter.

Launch Auto-search

To start an auto-search for the browser when you start typing a keyword, you need to configure the security settings
accordingly.

«  Click the hamburger/ 'Open Menu' button at the top-right corner.
«  Click 'Options' > 'select 'General' tab.

»  Check the 'Search for text when you start typing' box under the 'Browsing'.

10.3.  Form Autofill

Comodo IceDragon can save the information you enter into order forms and login screens. When you visit the same
form in future, just click on a blank field to see all the entries you made previously.

The following explains more about form auto-fill features:
+ Delete all stored form entries
* Delete individual entries
«  Configure form history

Delete all stored form entries
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«  Click the hamburger/ 'Open Menu' button at top-right
«  Select 'Library' > 'History'
OR
«  Select 'Options' > 'Privacy and Security' > 'Browser Privacy'

+  Click 'Clear Recent History' in the 'History' section.

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 142



Comodo IceDragor__1_______;_,__,LJ-Se"r"'G"'i]"i_d € coMong!

Browser Privacy

Forms & Passwords

¥ Remember logins and passwords for websites Exceptions...

Saved Logins...

v Use a master password Change Master Password...
History
IceDragon will  Remember history B

IceDragon will remember your browsing, download, form and search history, and

keep cookies from websites you visit.

You may want taf_ clear your recent histo r remove individual cookies.

'
Clear Recent History *

Time range to clear: Today .
Last Hour

-~ LEELE Last Two Hours

U] Browsing & Downl Last Four Hours

Form & Search Hi

[] Cookies Everything
L] Cache

[ Active Logins

[ Offline Website Data

L] Site Preferences

Clear Now Cancel

»  Click the 'Details' arrow to select the type of information to clear
»  Make sure 'Form & Search History' is selected

Click the time range to delete the history details in the 'Time range to clear' drop-down
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«  (Click 'Clear Now'

Delete individual entries

You can remove auto-fill from specific pages or fields while keeping it active on others. This can be useful on shared
computers.

+  Visit the webpage from which you want to remove previous form entries
«  Click on a field that has auto-fill suggestions. All previous entries will be displayed in a drop-down
»  Use the up and down arrows on your keyboard to highlight the entry you want to remove and press 'Delete’
» Repeat the process if you need to delete multiple entries.
Configure the browser for form entries
You can configure lceDragon to whether or not to remember the form entries as per your choice
«  Click the hamburger/ 'Open Menu' button at the top-right
»  Select 'Options' > 'Select 'Privacy and Security' > 'History'
* Inthe 'lceDragon will' drop-down, select 'Use custom settings for history'

«  Select or deselect 'Remember search and form history' as required

10.4.  Keyboard and Mouse Shortcuts

You can access and execute many IceDragon features and commands through keyboard and mouse shortcuts.
Click the links below to jump to the section you would like to learn more about:
+  Mouse Shortcuts
+  Keyboard Shortcuts
« Navigate Through Webpages
+  View, Print and Save Current Page
+  Edit Options
«  Search Options
+  Windows and Tabs
« View History
«  Bookmark Options
« Tools
« Miscellaneous
+ Audio/Video Shortcuts
«  PDF Viewer Shortcuts
Mouse Shortcuts

Command Shortcut

Back Shift+Scroll Down

Forward Shift+Scroll up
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Zoom In Ctrl+Scroll up
Zoom Out Ctrl+Scroll down
Close Tab Middle-click on Tab

Open link in new Tab

Middle-click on Link

New Tab

Double-Click on Tab Bar

Open in Background tab*

Ctrl+Left-click link
Middle-click link

Open in Foreground tab*

Ctrl+Shift+Left-click
Shift+Middle-click

Open in New Window

Shift+Left-click link

Copy Tab or Bookmark Ctrl+Drag tab
Reload (override cache) Shift+Reload button
Save Page As Alt+Left-click

Scroll line by line Alt+Scroll

* 'These shortcuts will work only if "When | open a link in a new tab, switch to it immediately' is enabled in 'Options' >

'General' > 'Tabs'.

Keyboard Shortcuts

Click the links below to jump to the section you would like to learn more about:

+ Navigate Through Webpages

« View, Print and Save Current Page

« Edit Options

« Search Options

+«  Windows and Tabs

* View History

«  Bookmark Options

« Tools

« Miscellaneous

Audio/Video Shortcuts
PDF Viewer Shortcuts

Navigate Through Webpages

Shortcut

Back Alt + left arrow
Backspace
Forward Alt + right arrow

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved

145



Comodo IceDragon - User Guide / comooo

/

Shift + Backspace
Home Alt + Home
Open file Ctrl+0
Reload F5

Ctrl+R
Reload (Override cache) Ctrl + F5

Ctrl + Shift + R
Stop loading Esc

View, Print and Save Current Page

Command Shortcut
Go to Bottom of Page End
Go to Top of Page Home
Move to Next Frame F6
Move to Previous Frame Shift + F6
Print Ctrl +P
Save Page As Ctrl+S
Find Ctrl+F
Zoom In Ctrl + +
Zoom Out Ctrl + -
Zoom Reset Ctrl+0

Edit Options
Command Shortcut

Copy Ctrl+C

Cut Ctrl + X

Delete Del

Paste Ctrl+V

Paste (as plain text) Ctrl + Shift + V

Redo Ctrl+Y

Select All Ctrl +A

Undo Ctrl+Z
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Search Options
Command Shortcut
Find within page Ctrl+F
Find Again F3
Ctrl+ G
Find Previous Shift + F3
Ctrl + Shift + G

Quick Find within link-text only

Quick Find

/

Close the Find or Quick Find bar

Esc (When Find and Quick Find bar is active)

Search bar - Easily choose your favorite search engine

Ctrl +K

Select or Manage Search Engines

Alt + Up arrow

Alt + Down arrow

F4

(When Search bar is active)

Windows and Tabs

Command

Shortcut

Close Tab

Ctrl + W
Ctrl + F4

These shortcuts will not work for Extensions and Add-
Ons tabs

Close Window

Ctrl + Shift + W
Alt + F4

Move Foreground Tab to Left

Ctrl + Left arrow
Ctrl + Up arrow

Move Foreground Tab to Right

Ctrl + Right arrow
Ctrl + Down arrow

Move Foreground Tab to first position Ctrl + Home
Move Foreground Tab to last position Ctrl + End
Mute/Unmute Audio Ctrl+M
New Tab Ctrl+T
New Window Ctrl +N
Next Tab Ctrl + Tab
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Ctrl + Page Down
Open Address in New Tab Alt + Enter
Previous Tab Ctrl + Shift + Tab
Ctrl + Page Up
Undo Close Tab Ctrl + Shift + T
Undo Close Window Ctrl + Shift + N
Select Tab 110 8 Ctrl+1t08
Select Last Tab Ctrl+9
Tab Groups View Ctrl + Shift + E
Close Tab Groups View Esc
Next Tab Group Ctrl +°
Previous Tab Group Ctrl + Shift +°

View History
Command Shortcut
History sidebar Ctrl +H
Library window (History) Ctrl + Shift + H

Clear browsing, search and download history

Ctrl + Shift + Del

Command

Bookmark Options

Shortcut

Bookmark All Tabs Ctrl + Shift + D
Bookmark This Page Ctrl+D
Bookmarks sidebar Ctrl +B

Ctrl +1
Library window (Bookmarks) Ctrl + Shift + B

Command Shortcut
Downloads Ctrl +J
Add-ons Ctrl + Shift + A
Toggle Developer Tools F12
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Web Console Ctrl + Shift + K
Inspector Ctrl + Shift + |
Debugger Ctrl + Shift + S
Profiler Shift + F5
Scratchpad Shift + F4
Style Editor Shift + F7
Network Ctrl + Shift + Q
Developer Toolbar Shift + F2
Responsive Design View Ctrl + Shift + M
Page Source Ctrl + U

Error Console Ctrl + Shift + J
Toggle Private Browsing - Browse the web without Ctrl + Shift + P
storing history, form entries and so on

Remove recent browsing, search and download history | Ctrl + Shift + Del

Miscellaneous

Command Shortcut

Complete .com Address Ctrl + Enter
Complete .net Address Shift + Enter
Complete .org Address Ctrl + Shift + Enter
Delete Selected Autocomplete Entry Del
Toggle Full Screen F11
Toggle Menu Bar activation (when hidden) Alt

F10
Toggle Reader Mode Ctrl +Alt +R
Show/Hide Add-on Bar Ctrl +/
Caret Browsing F7
Select Location Bar Alt+D

Ctrl+L
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Audio and Video Shortcuts
Command Shortcut
Toggle Play / Pause Space bar
Decrease volume Down Arrow
Increase volume Up Arrow

Mute audio

Ctrl + Down Arrow

Unmute audio

Ctrl + Up Arrow

Seek back 15 seconds

Left Arrow

Seek back 10 %

Ctrl + Left Arrow

Seek forward 15 seconds

Right Arrow

Seek forward 10 %

Ctrl + Right Arrow

Seek to the beginning

Home

Seek to the end

End

PDF Viewer Shortcuts
Shortcut

Next page N

J

Right Arrow
Previous page P

K

Left Arrow
Zoom in Ctrl + +
Zoom out Ctrl + -
Automatic Zoom Ctrl+0
Rotate the document clockwise R
Rotate counterclockwise Shift + R
Switch to Presentation Mode Ctrl + Alt + P
Toggle Hand Tool H
Activate the Page Number input box Ctrl +Alt+ G
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10.5.  Manage IceDragon in Safe Mode

Safe mode lets you troubleshoot issues with all add-ons disabled. For example, if IceDragon is crashing on start-up,
then disabling add-ons may fix the problem. You can enable add-ons one at a time until the problematic add-on is
found.

To start the browser in Safe mode
Click the hamburger/ 'Open Menu' button at the top-right corner
»  Select the help icon on the bottom of the menu
«  Select 'Restart with Add-ons Disabled":

- | x
w > =2 R © a »@
£3 Signinto Sync < Help
SR el lceDragon Help
&2 Mew Private Window Ctrl+Shift+P Keyboard Shortcuts
Foom —_ 100% + & Troubleshooting Information
Submit Feedhack
Edit Restart with Add-ons Disabled...
I\ Library > BGuT feebrage
2§ Add-ons Ctrl+Shift+A
| -]:i- Options

1 ,/ Customize...

Open File.. trl+C
Save Page As... Ctrl+5 i

é Print...

Q,_ Find in This Page... Ctrl+F
Mare 2
Web Developer >

>
" Exit Ctrl+Shift+Q
v

+  Click 'Restart' in the confirmation dialog.

«  Click 'Start in Safe Mode' to temporarily disable all add-ons, extensions, themes, language packs and
services.
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lcelragon Safe Mode = >
o g

Safe Mode is a special mode of lceDragon that can be used to
troubleshoot issues.

Your add-ons and custom settings will be temporarily disabled.

Start in 5afe Mode

»  To re-enable your add-ons:

«  Click the hamburger menu > 'Add-ons'
OR
»  Click the hamburger menu > 'Help' > Restart with Add-ons Enabled

10.6.  Scan Websites for Malware and Blacklist Using Web
Inspector

«  Comodo Web Inspector allows you to instantly run an on-demand malware check on any web page.

»  Web Inspector tests the target page in a sandbox environment to check whether it contains malware or
exhibits malicious behavior.

«  This allows you to test the safety of a particular website. Website admins can use the feature to test the
safety of their site from a customer's point of view.

The Web Inspector website has the following tabs:
+  'Home'- View all advantages from using Web Inspector, plans and pricing and more

«  'Online Scan' - Type the URL of the page that you want to scan in the blank box and click the 'START THE
SCAN' button

'Detection Technologies' - View identified malicious code on a web page

- 'Recent Detections' - View the list of unsafe sites that Web Inspector has scanned in the last 48 hours and
detected as malicious

«  Click 'Login' to enter your Web Inspector account
«  Click 'FAQ" at the bottom right to know more about Web Inspector

«  Click 'Support ' at the bottom right to open Comodo support page, a searchable knowledge base and
troubleshooter at https://support.comodo.com

You scan enables webpages in three ways:
» Directly scan an open page
» Scan alink to a page

» Scan a page by entering its url

To scan the currently open page

»  Click the "Web Inspector' icon at the top right of the address bar when viewing a page.
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File Edit View History Bookmarks Tools Help

C Wildcard SSL Certificates | Wh- X | &

cC @ @ @ https://ssl.com Bl e @ﬂ’ Q, search »

4} Most Visited ([ Getting Started [ From Internet Explorer

»  The web inspector report page will open in the new tab.
«  The page will be scanned for viruses and the results will be displayed.

« The results page contains a wealth of statistics about previous tests as well as important domain ownership
details.

File Edit View History Bookmarks Tools Help

C Wildcard 551 Certificates | Wh= X ‘ &, Report for https://www.comor X ‘ +

[ da o

c o @ app.webinspector.com/public/repo ses v P | Q Search

[
| 4=
11

£} Most Visited (T Getting Started [ From Internet Explorer

w web Chat with us Mow | Call us: 1-888-266-6361 | Request a Callback | Email Us

lnSpeCtor Home Online Scan  Detection Technologies = Recent Detections  Login
Inspect, Detect, Protect

Return to previous page

Report for “ https://www.comodo.com/ index page.’

_ - g .
No malicious activity or malware detected. Sl DU e T o
v Scan Time: 2018-05-08 14:01:37 UTC. B 5 3afe
Scanned single URL | Report as Malicious 0 Suspicious
B 0 High Risk
B 0 Inconclusive
Show History
Threat Report General Info
Blacklist Checking: What's This? Website: hitps:fwww.comodo.com
Phishing: Whats This? Domain: www.comodo.com
Scanned IP: 91.199.212.176
Malware Downloads: What's This? . X
Country: United Kingdom =
Drive-by-Downloads: What's This? Show Whois information
Worms: What's This?
E-commerce Safety Information
Backdoors: What's This? v
<

« Ifthe site passes the test and is safe, the message 'No malicious activity or malware detected' is shown.

« If malware is detected on the site or if the domain is listed on a major website black-list of known malicious
sites, then you will see the message: 'This is a suspicious page'.

»  We advise you not to proceed with your connection to this website.

Scan a link to a page
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+  Right-click any hyperlink then select 'Scan with Web inspector and navigate' will instruct Web Inspector to
visit the target web page and test it for malware.

»  This allows you to scan a page before you actually visit it. For example, you can scan the page right from
the results of a search engine:

File Edit View History Bookmarks Tools Help _ O w0

C Wildcard S5L Certificates | Wh=' X | \ﬁ Website Malware Scanner | Free X & japaness culture weekend - o X +

<« ¢ @ @ @ https://www.google.com/se e owe ¢ QU Search ' » =
I} Most Visited (T Getting Started = From Internet Explorer
]

Japanese Culture - Festivals - Holidays, Annual Events
https:/iwww japan-zone com/culture/holiday shtml  MepeknacTi L CTOPIHKY
The dates of some holidays, such as Adult's Day in January, have been moved to a fixed Monday in
order to have guaranteed three-day weekends.
Japanese company considers three-day weekend as country attempts ...
hitps:/fwww. independent.co.uk » New Open Link in New Tab
13 ciy 201? p -AJapanese company Open Link in New Window id for its
employees in a bid to tackle a culture o ) i

Open Link in Mew Private Window

Bookrmark This Link
Japan Week Prague 2017 aoxmate T
www japanweek.cz/en/ « MepeknacT frzliniie.
Japan Week is a festival focused on th Copy Link Location culture and art
around the world and interchange betwe Search Google for “Japanese compan...”

Send Link to Device ¥
Japanese Culture | Tokyo Ve
hitps:/fwww tokyoweekender.com/...f( CTOPIHKY
Fashion, culture. and everything odd af ¥« Scan with Web Inspector and navigate

: L

= @y Video DownloadHelper > =

The results of the scan will be shown in a new tab:
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File Edit View History Bookmarks Tools Help

C Comedo | Global Leaderin Cy X Q Report for https:/fwww.reddit. X ‘ +

<« C @ (@ @ https://app.webinspector.com/pL s ww 7 Q) Search

£¥ Most Visited (C Getting Started From Internet Explorer

[z

mHa

|4=
1

w web Chat with us Mow | Call us: 1-888-266-6361 | Request a Callback | Email Us

lnsDeCtor Home  Online Scan  Detection Technologies | Recent Detections = Login
Inspect, Detect, Protect

Return to previous page

Report for * https://www.reddit.com/ index page.’

No malicious activity or malware detected. Sl R
v Scan Time: 2018-05-11 08:36:37 UTC. B i45afe
Scanned single URL | Report as Malicious 0 Suspicious
B 0 High Risk
B 0 Inconclusive
Show History
Threat Report General Info
Blacklist Checking: What's This? Website: hitps:fiwww.reddit.com
Phishing: Whats This? Domain www.reddit.com
Scanned IP: 151.101.209.140
Malware Downloads: What's This? .
Country: United States B=
Drive-by-Downloads: What's This? City: Manchester
e R Show Whois information
Rt LLELESIITE, E-commerce Safety Information
Trojans: What's This?
m Transaction Protection v

Scan a page by typing its URL

»  Open a new tab by clicking the '+ button after the last tab on the right
»  Enter http://lapp.webinspector.com

e The 'Online Scan' tab will open:
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w web Chat with us Now | Call us: 1-888-266-6361 | Request a Callback | Email Us

lnsDeCtor Home | Online Scan Detection Technologies  Recent Detections  Login
Inspect, Detect, Protect

Free Website Malware Scanner

Enter a URL to find out whether it is malicious or not

http://suspicious.url.info/main.php

[] Check unresolved domain through the blacklists.
[To start, simply enter the URL of a webpage in the space above and click 'START THE SCAN'
Witer the scan is complete, you will be able to view a malware report

What is a Website Security Scan?

The term “website security scan” includes a number of similar but different types of website scans, including website vulnerability scanners, and webs site malware scans. We
nspector incorporates malware and vulnerability scans into a single website scanner.

How To Scan Your Website Using Comodo Web Inspector

[Scanning your website for malware is simple using Comodo Web Inspector. Justvisit hitps:/app.webinspector.com/, copy/paste your website’s url and click “Start the Scan.”
our website security scan report will be available within minutes.

To get a comprehensive website security scan report, you have to sign up with Comodo Web Inspector and add your website. For more information on signing up, please visit
his page.

«  Type the URL of the page you wish to scan and click 'START THE SCAN'.

The page will be scanned and the results will be displayed in the 'Recent Detections' tab. The statistics on this page
also provide a history of scan results for the web page in question.

10.7.  Set up Comodo IceDragon Sync Information

Synchronizing Ice Dragon with your Firefox account means you can download your Ice Dragon settings to any
computer you use. Synchronizing will copy your bookmarks, browsing history, preferences, passwords., form data,
add-ons and the last twenty five opened websites.

To set up synchronization
«  Click the hamburger/ 'Open Menu' at top-right
+  Click 'Sign in to Sync'.
OR
»  Select 'Options' then 'Firefox Account’

»  Click 'Create Account' if you do not already have an account.
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Enter your email

to continue to Firefox Sync

Email

By proceeding, you agree to the Terms of Service and
Privacy Notice.

Continue

+  Enter your email and password in the text box and click 'Sign in'".
Click the 'Verify Your Account' message to confirm your sign-in.

+  You will receive a confirmation mail to your account email address. Click the link in the mail to verify
your sign-in.

»  Click 'Confirm sign-in'. The IceDragon will start sync immediately.

- After successfully logging in, the sync settings page will show all items currently synced with your
account.

» Please review these settings and deselect items that you do not wish to sync.
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Firefox Account

testuser720@gmail.com Disconnect...

Manage account

Sync Settings

Choose what to synchronize on your devices using lceDragon.

¥ Open Tabs v History
v Bookmarks v Add-ons
¥ Logins v Preferences

Device Name

yuliya.bashkatova's lceDragon on Plohnson-PC Change Device Name...

Terms of Service

Privacy Motice

Manage IceDragon Sync information

Click the hamburger/ 'Open Menu' at the top-right > 'Sign in to Sync'.
OR
»  Click 'Options" 'Firefox Account'.
The general interface lets you setup and disconnect from your account

«  Click 'Disconnect' to stop syncing. Note: your Google account will retain data that has already been
uploaded BUT will not update with any further changes you make.

Disconnect from Sync?

Your browsing data will remain on this computer, but it will no longer sync with your
account.

Disconnect Cancel
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«  Click the 'Manage Account' link to change your account appearance and password and preferences.

testuser720@gmail.com

Account picture

Display name

Secondary email

Devices & apps

Communication preferences

Password

Delete account

Add...

Add...

Add...

Show

Change...

Change. .

Delete. .

»  Select items you want to sync across all devices
The 'Device Name' area lets you view and change the name of the device you synced.
+  Click 'Change Device Name' to rename a device, then click 'Save'
Change a password
»  Click the hamburger/ 'Open Menu' at the top-right
»  Click 'Options"> 'Firefox Account'
»  Click the 'Manage Account' link
»  Click the 'Change’ link beside the 'Password'".
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«  Type your an old password, then re-type it again and click '‘Change".
Delete an account

«  Click the hamburger/ 'Open Menu' at the top-right.

»  Click 'Options" 'Firefox Account'

+  Click the 'Manage Account' and select 'Delete account' button.
Reset IceDragon sync every time | close IceDragon

Click the hamburger/ 'Open Menu' at the top-right

Click 'Options' then the 'Privacy and Security' tab.

* Inthe 'History' > IceDragon will:' select 'Use custom settings for history

»  Uncheck 'Clear history when IceDragon closes'

10.8.  View Digital Rights Management

Digital rights management (DRM) allows online video and audio services to protect the content they provide from
piracy.

IceDragon implements HTML5 playback of DRM content by first decrypting it with a 'Content Decryption Module'
(CDM). IceDragon currently supports Adobe Primetime and Google Widevine CDM systems.

If you opt-out of DRM playback, then all downloaded CDMs will be deleted so you will not be able to play DRM
content in future.

To disable DRM playback
»  Click the hamburger/ 'Open Menu' at the top-right
+  Click 'Options' > 'General'
+  Go to the 'Digital Rights Management (DRM) Content'

« Deselect the 'Play DRM-controlled content' checkbox

Digital Rights Management (DRM) Content

v | Play DRM-controlled content Learn more

« If sites requires this type of DRM to operate properly, turn DRM playback on again.
10.9.  Improve IceDragon Performance Settings

IceDragon allows you to use hardware acceleration to improve video playback. For example, hardware acceleration
improves playback on YouTube and 3D Earth view in Google maps.

To configure performance settings
«  Click the hamburger/ 'Open Menu' at top-right
+  Click 'Options' > 'General’

+ Scroll to the 'Performance' section

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 160



COMODO

Creating Trust Online®

'I:I' General
Q Search

a Privacy & Security

E Firefox Account

PO Languages

Performance

|| Use recommended performance settings Learn more
These settings are tailored to your computer’s hardware and operating system
v Use hardware acceleration when available

Content process limit 4 {default) -

Additional content processes can improve performance when using multiple tabs, but will

also use more memory.

« Use hardware acceleration when available - If selected, Ice Dragon will use the 3d acceleration features
of your graphics card to improve video playback. Restart the browser for the settings take effect.

»  Content process limit — Improve performance by increasing the number of processes assigned to handle
video content. Adding more processes will also commit more memory to the task, which could degrade
performance in other tasks that are running on your computer.

11. Web Developer Tools

Comodo IceDragon has a number of built-in tools that allow web-devs to developer and test website code.
You can use the tools to debug code, run java scripts, view and change styles, find java script related errors

and much more.
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Click the links below for more help on using developer tools:
»  Open the Tools console
* Inspect Page Elements
« Use the Web Console
» Remove Inconsistencies with HTML, CSS and Javascript
» View and Run Experimental Style Sheets on a Webpage
» Improve Web Page/Web Application Performance
*  Memory Tool

»  Network Monitoring
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» Use the Developer Toolbar

» Use the WebIDE

« Browser Console

» Responsive Design View

+ Eyedropper

*  Run Experimental Java Scripts on Page
» View Page Source

* Add More Web Development Tools
« Service Worker

«  Connect Remote Device

* Add More Web Development Tools
»  Work Offline

11.1.  Open the Tools Console

To access the console interface
»  Click the hamburger/ 'Open Menu' at the top-right

»  Select' Web Developer' > "Toggle Tools'

& Developer Tools - Options - about:preferences?entrypoint=menupanel#general — O X
[¥ 3 Inspector Console [ Debugger {1} StyleEditor (& Performance 4 Memory = Network & Storage BB H & OO
=+ Search HTML & Rules Computed Layout Animations Fonts  #
ASLLIOLMNBUUTIULE LU= pPRLDUrNuULE SLE Lnrome. s S pPLppRL ~ P
/locale/pippki.properties”»</stringbundle> Filter Styles + o
<stringbundle id="browserBundle" src="chrome://browser element £} { inline
flocale/browser.properties"»</stringbundle> H
<stringbundleset id="appManagerBundleset">[) s root 1 preferences.css: 11
</stringbundleset> W --in-content-category-background: #fafafc;
Frtark Flaw="T1"% }
page —— r ————— —_———— e
W % Filter output |:|Per5|st Logs
Erors | Wamings  Logs | nfo | Debug I 55 | R Requests
UDJELL { fadime; Qermdr , SErveErFdur:  NLLp /S UURILUUE . COMUUD . COmy LLEUNULYUN UPUU LEY LUNYUULYE 306/ UE. XpL ldllgudEes, |5 LiD14

localeMName: “de", action: [..]. userActionm: "™ }

« Developer Tool - Options — Click the 'cog' icon on the right to set overall preferences:

& Developer Tooks - Options - about: preferencesTentrypoint=menupanel®general = x

8 [ Inspector [ Console  Debugger { ) StyleEditor & Pedformance #k Memory = MNetwork B Storage B~ E .

Default Developer Tools Themes
[ Style Editer () Dark @) Light () Firebug
[ Shader Editor
Inspector
] Canvas

e [ show Browser Styles

CA Teoimratn MOBA atbrilu oor h

W % Filter output [ Persist Logs
ErnE

Object { name: "Portuguese®, serverPath: “hitp://downlood.comodo.com/icedrogon/updote/longuoge languages.js:1151:4
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«  Default Developer Tools — Enable or disable tools using the check-boxes.

« Available Toolbox Buttons — Choose which tools will be displayed on the toolbar.
«  Theme - Allows you to switch between a Light and a Dark theme.

* Inspector

«  Show browser styles — Determines whether or not the style applied by the browser will be
displayed in the Inspector's Rules view

Default color unit: drop down — Select the colors will be presented in the inspector. Available:

*  Hex
« HSL(A)
+  RGB(A)

«  Color Names
« Web Console - Enable timestamps - If enables, the console clears the output when you navigate to a
new page.
»  Style Editor — Allows you to view and manage original sources and auto-complete CSS
- Screenshot Behavior - Define how Ice Dragon should handle screenshots.
» Editor Preferences — Defines which items will be used in developer tools
»  Detect indentation: Auto-indent new lines based on the current indentation
»  Autoclose brackets
* Indent using spaces
- Tab size = 2 (By Default)
+  Keybindings: drop down - Select CodeMirror keybindings or keybindings:
e Vim
« Emacs
«  Sublime Text
« Advanced settings
« Enable Source Maps — Maps your browser inspector's line numbers to the original source.
«  Show Gecko platform data — Display Gecko platform symbols
« Disable HTTP Cache (when toolbox is open) - Allows you to disable session caching
- Disable JavaScript - Loads the current tab with JavaScript disabled

« Enable Service Workers over HTTP (when toolbox is open) — Allows you to service worker
registrations from insecure web sites

« Enable browser chrome and add-on debugging - Allows you to use developer tools in the
context of the browser itself
« Enable remote debugging - Allows you to debug code running remotely in a different process or
on a different device
»  Restart your browser for the settings to take effect.
« Inspector — Analyze the layout of a web page and find/fix web page issues. It allows developers to see
which elements in the source files (including server-side code) have produced the HTML markup to be

rendered in the browser. Page Inspector also lets you modify CSS properties and DOM element attributes
to see the changes reflected immediately in the browser.

«  Web Console - Logged information and other error messages. Allows developers to upload/download files
to/from server, edit text files directly on a server and much more.

»  Debugger - Finds errors in other programs. A debugger allows a web developers to stop a program at any
point and examine and change the values of variables.
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- Style Editor - Allows developers to edit a style sheet to apply a style of your own choice to required
elements.

» Performance - Allows developers to find and eliminate bottlenecks in your JavaScript code.
»  Memory — Take a snapshot of the current page memory.
»  Network - List all network requests made while loading the page.

»  Other tools on the web developer toolbar are available:

letw Stof: (" B @ 0O &8 X

-~

« 'Select an iframe as the currently targeted document'. You can enable/disable it from the developer
settings by clicking the cog icon at far top right. Lists all nested frames in the file and in the main
document.

»  Toggle split console — Displays an extra console underneath the web developer tools interface.

« Responsive Design Mode — Makes it easy to see how your designs will look on different sized
screens such as mobile phones or tablets. Use the resize handle at the lower right of the content area
to change the size of the content area.

»  Dock to side of browser window / Dock to bottom of browser window - Move and pin the panel to the
side or top of the browser as per your preference.

«  Show in separate window — Opens a separate web developer tools.

+  Click on the 'X' at the far right to close the tool bar.

11.2.  Inspect Page Elements

The 'Inspector' tool allows web developers to analyze the layout and structure of a web page.
To inspect a page

«  Open the web-page you want to inspect

«  Click the hamburger/ 'Open Menu' at top-right

»  Select 'Web Developer' > 'Inspector'

« OR

« Right-click on the page and select 'Inspect Element' from the context sensitive menu. You can right-click on
specific items on the page to open the inspector at the relevant place.
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- Move your mouse cursor over the page content to view information about the content in the inspector.
«  Click on a page element if you want to work on it.

The 'Inspector’ consists of two parts: HTML pane and CSS pane.

All parent elements are on the the left and child elements on the right.

- The left side pane is HTML pane - The top-level element in the hierarchy of all nested elements, is at the
left of the toolbar.

«  Allows you to view the HTML code of the selected element.
«  Use the arrow keys in the left and right to navigate to the elements in the tool bar.
«  Theright side pane is for CSS and divided into 5 elements:
* Rules - Show all the rules that apply to the selected elements. The most recently applied styles are

listed first. Styles are grouped by source. The 'inline' group lists styles applied using the HTML style
attribute.

»  Computed - Indicates the computed CSS for the specific element.

«  Box Model' show the total space taken by the element on the page. It provides information about
the currently selected page element's layout: the outside numbers displays an amount of padding
is on each side of the element. The numbers in squares on the borders displays the border of each
side. The margins around the element and the center, is the size of the element's content.

«  Layout —Apply a grid overlay while inspecting the element.
< Animations - Animations to specific element.
»  Fonts - Displays all the fonts in use by the selected element.
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11.3.  Use the Web Console

The web console is a very useful tool for web developers which displays logged information and other error
messages. It also allows developers to check Javascript and acts as a debugging tool for web applications or web
sites.

To access Web Console
Click the hamburger/ 'Open Menu' at the top-right

+  Select 'Web Developer' > "Web Console'.

& Developer Tools - Options - about:preferences?entrypoint=menupanel#general — O X
@ {7 Inspector Console [ Debugger {1} StyleEditor (@ Performance  k Memory = Metwork 8 Storage BB R &OO
W ¥ Filter output [ Persist Logs

Erors | Waring | Logs i | Debug I C55 | X | Reguess

UpjeETL 1 fidineg ermdr , Serverrdin:  NLLED// UUWHLUUL . COMUUL . COmy L EUrUyUn, UPUU LEY LUNYUULEy 38/ UE. XpPL lamgudEes. J>: LiDL 4
localeName: “"de™, action: [..], userfction: "™ }

Object { name: “Spanish®, serverPath: "http://download.comodo.com/icedragon/update/longuage/58/es-E5.xpi”, languages.js:1151:4
localeName: "es-ES™, action: [..], userfction: ™" }

Object { name: “French", serverPath: "http://downlood.comodo.com/icedragon/update/Longuage/58/fr.xpi", languages.js:1151:4
localeName: “"fr", action: [..], userfiction: "" }

Object { name: "Italian", serverPath: "http://downloed.comodo.com/icedrogon/update/longuage/58/1t.xpi”, languages.js:1151:4

localeName: “"it™, action: [..], userfction: ™" }

Object { name: “Portuguese", serverPath: “http://downlood.comodo.com/icedragon/update/Llonguage/58/pt-PT.xpi", languages.js:1151:4
localeName: “"pt-PT", action: [..1, userAction: ™" }

>

»  Use the 'Position’ drop-down menu beside the box to place the Web Console above or below.
«  Use the 'Filter output' box to search for particular item(s) in the list.
The Web Console displays messages about Network requests, CSS, JavaScript, Logs.

«  Errors | Warnings — View all errors related to the current page. This includes HTML/CSS, javascript and
other warnings and messages. This is useful for web developers to check the pages that they have
developed.

« Logs - These are outputs of JavaScript code executed on the console object in IceDragon.

« Network Request — Displays messages about network requests generated by your web browser. Click on
network request log to view full its details such as request headers and response headers.

« CSS Messages - IceDragon generates these messages for CSS errors that occurred while loading a web
page.

- JavaScript Messages - IceDragon generates these messages for JavaScript errors that occurred while
rendering a JavaScript code.

«  Security Messages - IceDragon generates these messages for security warnings and errors that occurred
during runtime.

+  XHR (xmlHttpRequest) — Shows data which has been transferred via HTTP. Uses for XML and Json.

Messages that are generated multiple times are listed only once with an indication in the right displaying how many
times the message was output in the Web Console.

You can choose what information should be displayed in the log area by selecting the respective item, that is,
Network, CSS, JS, Security and Logging. You can further filter them from the drop-down menu to display messages
about errors, warnings, info and log.

Below the log information area, a command line box allows you to execute JavaScript in real-time.
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11.4. Remove Inconsistencies with HTML, CSS and
Javascript

The debugger feature lets you analyze a web page's code line by line.
To open debugger element tool

»  Click the hamburger/ 'Open Menu' at the top-right

«  Select 'Web Developer' then 'Debugger'

Y L7} Inspector [ Console (I} Debugger {} StyleEditor €5 Performance = Metwork EH-B8 B & 0 E X
n ~ 3 Search scripts (Ctri+P) b @
Call Stack 1 if {"undefined" == typeof (MySidebar)}) { |~

) . 2 var MySidebar = {}; |
chrome://browser = 3|3
. 4
contentSearchULjs H 5 !
. 6 MySidebar.Common = {
LIELT 7 init: function(setting) {
DnD@comodo.com 8 this.setting = setting;
9 Fa
.on/scripts/classCommon.js 1a ¥
. 11 MySidebar.Common.init.prototype = {
12 animate: function animate(elem, style, unit, from, to, time) { b

The debugger toolbar consists of:
» Pause/Resume - Pauses or resumes execution of the script you're debugging.
- Step Over - Steps across the current line of JavaScript code.
- Step Into - Steps into the function call on the current line of JavaScript code.
»  Step Out - Runs the script until the current function exits.

«  Script Chooser - This pop-up menu lets you select one of the running scripts in order to read its code, set
breakpoints, and so forth.

- Script Filter - The script filter (which doubles as a search box) lets you type a string to filter what scripts
should appear in the Script Chooser.

«  Expand Panes - Expands or contracts the window to show or hide the sidebar panels.
« Debugger Options - Pops-up a menu to configure the debugger.
«  Auto Prettify Minified Sources - If enabled, the debugger will automatically detect minified JS files
and pretty-print them.

« Pause on Exceptions - If enabled, execution of script will automatically pause whenever a JavaScript
exception is thrown.

« Ignore Caught Exceptions - If enabled, the debugger will automatically pause the execution of the
script whenever a JavaScript exception is thrown.

«  Show Panes on Startup - If enabled, the debugger's two sidebar panes are visible when you first start
the debugger; by default, they are not.

«  Show Only Enumerable Properties - If enabled, allows you to filter the displayed list of variables after
the "Filter variables" search box to will be added the variables panel.

« Show Variables Filter Box - If enabled, do not display non-enumerable JavaScript properties

« Show Original Sources - If enabled, allows you to use source maps to see the original source for
code.

- Automatically Back Box Minified Sources - If enabled, URLs with 'min.js' at the end will
automatically be black boxed.
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11.5.  View and Run Style Sheets on a Web-page

The 'Style editor' tool allows web-developers to experiment with different style sheets and preview page design 'in-
browser' before final deployment. The editor allows web-developers to view a list of cascading style sheets (css)
used in the current web-page. You can also save style sheets and import CSS to a page.

Click the links below for more help:
» View and edit style sheets in a webpage

»  Apply your style sheet to a webpage

To view style sheets used in the currently web-page
«  Click the hamburger/ 'Open Menu' at the top-right
«  Select 'Web Developer' > 'Style Editor’

[d L1 Inspector 3 Console (@ Debugger PRERSIAILTEIN ) Performance = Network B3 B £ 0 & X
Mew Import... & 1 If== This Source Code Form is subject to the té * @media rules
> 2 * License, v. 2.8. If a copy of the MPL was [ . .
Pos global.css + file, You can obtain one at http://mozills (-moz-os-version: windows-xp), 1335

59 rules. ave (-moz-os-version: windows-vista),

(-moz-os-version: windows-win7)

contentSearchULcss

m | »
(= I I RN [ SR T

© == Styles that appl
23 rU|E5' EEEESESSSESSSSSSSSSSSSSSSSSSSSSSSSSSSS=SS=S=S==SS :35?
o newTab.css
a1 rules 9 /* all localizable skin settings shall live
: 18 @import url{"chrome://global/locale/intl.css’
o hewTab.css 11
35 rules. 12 @namespace url("http://www.mozilla.org/keymas:
13
© content_style2.css 14 FE eunee YRl himddmae eoese &7 -
11 rules Tl 45 1 UL s

The list of external and inline style sheets used for the webpage will be displayed in the left hand side pane and the
rules defined in the style sheet selected from the LHS pane will be displayed on the right.

- To view the elements and styles defined for the elements in a style sheet, click on the style sheet listed in
the left hand side navigation pane.

« To switch and preview the page with and without the application of a selected style sheet, click on the 'eye'
icon beside the style sheet name in the LHS pane.

- To edit and experiment with styles, find the style rule applied to the desired element from the right hand side
pane and change the parameters as you wish. The changes will be immediately reflected in the webpage
viewed. But these changes are temporary and will be lost when the page is reloaded.

Tip: To identify the rule applied to a desired element, right-click on the element and select 'Inspect element' from
the context sensitive menu. The lower pane in the window will display the 'div id' of the element. Search for the 'div
id" in the style editor window by pressing Ctrl+F from the keyboard and entering the div id in the 'Find..." dialog

To save a style sheet
«  Select the style sheet from the LHS pane and click 'Save' link beside it

» Navigate to the location in your computer and enter a file name with .css extension in the 'Save as' dialog.

Apply a style sheet to a web-page

You can create your own style sheet for element(s) in a page and apply to them and have a preview. This is useful
for web-developers to experiment of different style sheets for different elements before deciding the final style.

To apply an external style sheet
«  Click 'Import’, navigate to the location in your system where you have saved the .css file and click '‘Open’
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The style sheet will be imported and the style rules will be applied to the elements defined in the sheet immediately
for a preview.

11.6.  Improve Web Page/Web Application Performance

The performance tool lets developers optimize their code by testing the performance of a page within a set timeline.

On executing the code, the performance samples the state of the JS engine and records the code stacks at various
time points. The performance then calculates the time spent by the browser to execute each stack and displays a
statistical report. The report enables the web developer to analyze and identify the bottlenecks in the code.

To run the Performance
Click the hamburger/ 'Open Menu' at the top-right

«  Select 'Web Developer' > 'Performance’

[« {1 Inspector [ Console (0} Debugger {}St}rleEditDr = Networkk EH- B0 H @ 0 & X
T @ Impot. ¥ &

There are no profiles yet.

Start Recording Performance

«  Execute your code in IceDragon and click 'Start Recording Performance' to commence the sample.

« Leave the profiler to record the samples for required time period and click the 'Stop' button to stop the
recording.

The 'Performance’ will compile the results and display the report.

&) Developer Tools - Options - about: preferences?entrypoint=menupanel#general — O d
e LT Inspec Cons: [ Debur {1} StyleEc (T Peform: £k Mem = Metw Store: (3 F B 2 0 O
W @ & W X

) 12800 m= 25800 ms 38400 m=
Recording #1 L

In progress...

avg Ofps

Stop Recording Performance

T 8 Filter output [ Persist Logs

CErors | Wamings | Logs | info | Debug [ C55 | xR | Requests

Fupdote/sLoanguoge/58/de.xpi", localeMame: “de", action: [..], userAction: "

Understand the Report

The recording left hand pane of the report displays a list of captured profiles which can be loaded at any time. The
right hand pane displays the currently loaded profile.
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[ Inwert Call Tree

«  Click the 'clock' icon at the top-left of interface and repeat recording the samples and generate several
profile reports.

«  Click the 'Import' and navigate the folder to upload the profiles
«  Click 'Clear" to remove all profiles.
« 'Invert Call Tree' checkbox - If checkboxed, the profiler report will,

» make a list of all stack frames with a Self Cost greater than zero: that is, stack frames which were
actually execute when the sample was taken

« order the list by the number of samples taken while in that stack frame
- for each entry in the list, show the call stack backwards to the top-level function.
The profile contains four main sections provides:
*  breadcrumb trail
+ frame rate timeline
« timeline for platform code execution

+ detailed output of the JavaScript sampling profiler

Breadcrumb trail

The upper half of the loaded profile displays a time verses call stack size bar-graph of the profile. The call stack
represents the amount of active functions at the time when the sample was taken.

0 ms — 354177 ms

You can analyze the response for the stacks for a specific time range too. Selecting a portion of the graph, by
dragging the mouse cursor displays a new tab above the graph indicating the selected portion. Clicking the new tab
opens the enlarged view of the selected portion.

To click and drag in the frame rate timeline or the sampling profiler timeline, will

 highlight the section of the timeline
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» show samples that were recorded in that section

- appear "+"in the toolbar at the top. Click the '+' to view the highlighted expanded section. You will see a
separate breadcrumb nail the toolbar at the top.

You can switch between the complete profile and the section using the breadcrumbs, zoom in on a subsection within
the section.

Frame rate timeline
This item allows you to view the browser's responsiveness within the period covered by the profile. The x-axis is time

over the profile period and contains three annotations: the target frame rate (always 60 frames per second), the
average frame rate, and the lowest frame rate.

0 ms 8400 ms= 12800 ms 15200 ms 25800 ms 32000 ms: 38400 ms 44800
[ ]! | (] 1] I Il u | I N | InEn
T max &0fps awg 5933 fps
" min 2047fps

Timeline for platform code execution

Category Description

Network Sending and processing network requests and responses.
JIT JavaScript code compilation.

GC Garbage collection.

Inputs & events Events such as mouse or DOM events.

Styles Parsing CSS.

Graphics Includes handling reflows and repaints as well as WebGL.
Storage Most often this is IndexedDB.

Gecko Indicates items that doesn't fit into any of the other categories.

Hover over the color key for a current category will fade all other categories.

Detailed output of the JavaScript sampling profiler

The lower half display the details of the profile.
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Total Time (ms) | Total Cost Self Tirne (ms) Self Cost  Samples  Function
352972 100% 0 0% 1313 (root)

352972 100%: 0 0,22% 1313 Startup:XRE... :4172 Gedio

352957 a7,860% 0 0% 1285 Tirmer:Fires563 Gedo

352926 95,96% 0 0% 1260 P js:RunScript @

Ei 1,67% ] 0% 22 nsR... :1113 Graphics

] 0,22% 0 0,22% 3 nsCycleC... :4174 GC

15 1,90% 0 0,07% 25 ns...:726 Input B Brents

15 1,29% ] 0% 17 Pres...:4220 Graphics

] 0,53% ] 0,15% T 403 Input & Brents

The 'Total Time (ms)' display the break down view of the stacks that contained specific active functions and their
share in total number of stacks in percentage in the first column, the number of stacks called by the functions in the
second column and a tree structure view of the functions in the third column.

The 'Total Cost' indicates the number of samples to be taken in which the corresponding "Function”
appeared in the call stack.

The 'Running Time' indicates the total number of samples executed within the recording time followed by
the percentage of stacks that executed the active functions.

The 'Self Cost' indicates the number of stacks that were called while executing the active functions, and not
the stacks that called the function.

The 'Self Time (ms)' indicates the amount of time spent executing the function, exclusive of any functions
called by this function in the percentage of stacks that executed the active functions.

The 'Samples' indicates the number of samples to be taken in which the corresponding "Function”
appeared in the call stack.

The 'Function’ displays the function name, source file, line number and domain that served the file. To
debug a specific function, hover the mouse cursor over the function and click on the right arrow that
appears at the end of the line.

11.7.  Memory Tool

The 'Memory' tool lets you visualize how web-page elements use memory. Memory allocation is represented as a
tree of nested rectangles.

To access the memory interface
«  Click the hamburger/ 'Open Menu' at top-right
«  Select 'Web Developer' > 'Memory'

+  Click the "Take snapshot' button or click the camera icon at top-right
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[@ 13 Inspecte B Consel: [ Debugge {} StyleEditc (5 Performanc ik Memor = Networl sterage (- B £ 0 O

W 3 @y [JRecord call stacks  View:

. objects 2MiB 43847 count
05/11/18, 14:52:36 Aray 417KIB 5121 count Function 870KIE 24103 count

2.29 MB

GCsll

Object 712KiB 8804 count

soripts 3MiB 18754 count

T SF Filter output [ Persist Logs
Errors  Warnings Logs Info Debug CS5 XHR Requests

«  Click 'Save' link to save the snapshot. Navigate to the locate to save the entry with the extension
fxsnapshot.

»  Click X" next to entry to delete a snapshot.
»  Click 'Import' to load the snapshot from the extension .fxsnapshot file.
»  Click the 'Compare snapshot'.

»  Select the snapshot to use as basis then the snapshot to compare.
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&) Developer Tools - Armazon.com: Online Shopping for Electronics, Apparel, Computers, Books, DVDs & more - https://w... - O >
¢ L7 Inspecto Consol: [ Debugge {} StyleEditc (G Perfformanc £k Memor = Networ sterage (- B £ 0 O
W e @ My [JRecord call stacks  Group b)r: Filter
. 05/11/18, 14:52:36 Eytes Count Total Bytes Total Count Group
+1 217 536 +15% +38 848 +35% +1 217 536 +15% +38 848 +35% DOMPoint ad
Baseline -695 192 -8% -5 677 -5&% -695 132 -8% -5 677 -G% P strings
-638 968 -8R -8 321 -8% -638 968 -8R -8 321 -8% jsuShape
= 4661384 566 488 7% 7 573 7% 566 488 7% -7 572 -7% p Object
_ : -537 368 -&% -3 375 -3% +579 456 +8% +1 188 +1% 155cript
Lomparison -452 338 -5k -11 968 -11% -452 338 -5k -11 968 -11% p Function
-419 844 -5R -348 8% -419 844 -5R -348 ak jsujitulitCode
-381 784 -5k -4 548 -4% -381 784 -5k -4 543 4% p Array
+38E 976 +4% +3 593 +9% +38E 976 +4% +3 593 +9% DOMGuad
-174 236 -2% 3 446 3% -174 236 -2% -3 446 -3% P jsuScope
-137 728 -2% 2 151 -2% +59 £96 +1% +916 +1% JjsulazyScript
-135 712 -2% -2 @88 -2% -135 712 -2% -2 @88 -2% p Call
-118 528 -1% -4 714 -4% -118 528 -1% -4 714 -4% jsuObjectGroup
+188 224 +1% +3 382 +3% +188 224 +1% +3 382 +3% p C555tyleRule
+26 488 a% -1 a% +26 488 a% -1 a% Window
-13 364 8% -2 8k -13 364 8% -2 8% ) jsuRegExpShared
+11 456 % +358  @% +11 456 % +358  @% ) CS552Properties
-9 7280 e 285  @% -9 7280 e -285 8% ) jsuBaseShape
-9 228 ek -127  e% -9 228 ek -127  @% p HIMLDivElement
-6 272 @ -196  e% -6 272 @ -196  @% p HIMLImageElement
-4 896 @% -127  e% -4 896 @% -127 @%b HTMIIIFIament N
T ¢ Filter output []Persist Logs
Errors  Warnings Logs Info  Debug CS5 XHR Requests

You also can store information about the subroutines of a computer program and allows you to view results in
different ways along as group your data

» Record call stacks
»  View: Tree Map, Dominators, or Aggregate

«  Group by: Type, Call Stack or Inverted Call Stack

& Developer Tocls - Amazon.com: Online Shopping for Electronics, Apparel, Computers, Books, DVDs & more - https://w... — ] x

@ 3 inspecte [ Consol: [ Debugge {1} StyleEditc (& Pedformanc £k Memor = Networl B Storage ("] H 2 8 O

W By @ M [JRecord call stacks  View: | Aggregate |~ | Group by Filter
05/11/18, 14:52:36 Bytes g ENE Type Group
: 1 989 @99 24% Aggregate say Call Stack o A ISScript A
8.29 MB 3 1 245 48@ 15% | Dominators 1 345 apg Imverted Call Stack 17 & strings
1 865 224 13% 15 554 18% 1 BES 224 13% 19 664 18% & js=Shape

11.8.  Network Monitoring

The 'Network Monitoring' tool allows developers to view network activity on a site.
To view the page source

»  Click the hamburger/ 'Open Menu' at the top-right

«  Select 'Web Developer' > 'Network'

«  Click the stopwatch icon to run the performance analysis tool.
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The 'Network' tab loads the site twice. First with an empty browser cache, then again with a primed cache. This
simulates the initial visit and a subsequent visit to the site.

& Developer Tools - Comodo | Global Leader in Cyber Security Solutions - https://www.comodo.com/ — O *

@ {1insper & Consi [ Debug {} StyleEd (@ Peforme B Mem: = Netw 8 Store (- B & O O
Il @ [ HTML CS5 JS XHR Fonts Images Media WS Other [Persistlogs [ Disable cache '

Filter URLs I=
St... M... File Domain Ca... T.. Tra... S 0 ms d2s ~

304 GET I b21.png B www.co.. img png cached 378B — 409 ms
304 GET |E freeforensicanalysis-... WWW.CO... img png cached 9.52 KB — 410 frs
304 GET usd_prices,js B secure.co.. script s cached 9340 KB - 93 ms

® 200 POST ntm.php B www.co... xhr html 271 KB 2B 408 ms
34  GET  ~% menu-arrow.png # www.co.. img png cached 815B - 99 ms
34 GET threat-bg,jpg WWWLCO., img Jpeg cached 32,68 KB - 92 ms
304 GET top-product-banner... @ www.co... img jpeg cached 35332 KB = 90 ms
3 GET B banner-v2.jpg WWW.CO... img jpeg cached 209.71 KB 83ms

(€ 101 requests = 2.06 MB/1.49 MB transferred  Finish: 5.33s = DOMContentLoaded: 5.34 s load: 5.69 s

The results will be summarized in the table and as a pie chart.

» Toreturn to the list of the Network monitoring, click '‘Back' request on the left.

»  To open the current network run with a filter automatically applied, click the slice pie.
The Network table displays,

- Status - The HTTP status code returned. Hover over the icon to see the exact code. Green color-coded
icon - success (2XX codes), orange - redirection (3XX), or red - errors (4XX and 5XX).

*  Method: Shows the HTTP request method.
»  File: Shows the basename of the file requested.
«  Domain - Shows the domain of the path requested.

« Cause - Reason the network request appeared. (XHR request, <img>, script, script requesting an image,
etc.)

«  Type - Shows Content-type of the response.
« Transferred - Displays the number of bytes transferred to load the resource.
»  Size - Shows the size of the response.
« Timeline - Displays a timeline for the different parts of each request.
Each column can be sorted by ascending or descending.
The toolbar will be displayed at the top of the pane and allows you to switch between different pages:

» Headers - Provides information about the request: URL, status code, the HTTP request and sent response
headers.

The filter header field allows you to filter the headers.
« Cookies - Provides full details of any cookies sent with the request or response.
« Params - Displays the GET parameters and POST data of a request.

» Response - Displays the complete content of the response. Depending of the type of response, it will be
displayed in HTML, JS, or CSS as text, JSON as an object, an image will be shown as a preview.

«  Timings - Provides detailed timeline bar for the request showing how the total wait time is split into the
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various stages.

The developers can also sort their certain type of files by HTML, by JS, by XHR, by Fonts, by Images, by Media or
by Flash type.

«  Click the buttons in the network toolbar to filter the list by type. This is also allows you to find out the total
size and download time for a particular type of file.

11.9.  Use the Developer Toolbar

The developer toolbar is a command-line interface which lets web-devs issue commands to pages and IceDragon
itself.

To open the developer toolbar
+  Click the hamburger/ 'Open Menu' at the top-right

«  Select 'Web Developer' > 'Developer Toolbar'.

|

«  Press F1 to open the pop-up help.
OR
» Toview a list of supported commands, type 'help'.
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GCLIis an experiment to create a highly usable command line for web developers.
Awailable Commands:
addon - Manipulate add-ons | = help addon
appcache - Application cache utilities = help appcache
break - Manage breakpoints = help break
calllog - Commands to manipulate function call logging = help calllog
clear - Clear the output area | » help clear
cansole - Commands to contral the canzole = help console
context - Concentrate on a group of commands | = help context
cockie - Display and alter cookies = help cookie
dbg - Manage debugger = help dbg
edit - Tweak a page resource = help edit
export - Export rescurces = help export
eyedropper - Grab a color from the page | » help eyedropper
folder - Open folders | » help falder
help - Get help on the available commands = help help
highlight - Highlight nodes | = help highlight
inject - Inject cornmon libraries into the page = help inject
inspect - Inspect a node  » help inspect
jsb - JavaScript beautifier = help jsb
listen - Open a remote debug port | = help listen
measure - Measure a portion of the page = help measure
media - 55 media type emulation = help media
pagemod - Make page changes | = help pagemod
paintflashing - Highlight painted area = help paintflashing
pref - Commands to control settings = help pref
gsa - Perform querySelectorAll on the current document and return number of matches = help qgsa
resize - Control Responsive Design Mode = help resize
restart - Restart lceDragon = help restart
rulers - Toggle rulers for the page = help rulers
screenshot - Save an image of the page = help screenshot
security - Display supported security and privacy features = help security
unhighlight - Unhighlight all nodes | » help unhighlight

unlisten - Close all remote debug ports = help unlisten

11.10. Use the WebIDE

The WebIDE allows developers to manage runtimes and develop through the Firefox simulator or a real Firefox OS
device.

The WebIDE provides three steps to run and debug the application:
+  setting up a runtime
+  creating an app or open an existing app
 installing the app on runtime
To open WebIDE
»  Click the hamburger/ 'Open Menu' at the top-right
»  Select 'Web Developer' > ' WebIDE'
«  Alternatively, click the 'Customize' button from the menu on the bottom-right
»  Select the WeblDE icon from the 'Additional Tools and Features' and dock it at the navigation bar

»  Click 'Exit Customize' to save the changes.
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Project Runtime View

© New App... <

%= Open Packaged © can't see your device?

App...
Q Open Hosted App...

(4] Install Simulator

L1 Remote Runtime
Chrome Desktop

o Safari, Firefox, and
other WebViews on i0S

«  The sidebar on the left displays existing apps or lets you to create an app

«  The sidebar on the right allows you to select a runtime or set a new runtime.

To set up a runtime
You can manage the runtime on the right of the sidebar. Runtimes are grouped into four types:
«  USB devices - Displays OS devices connected over USB.
«  WI-FI DEVICES - Displays OS devices connected over Wi-Fi
«  SIMULATORS - Displays instances that you've installed
»  OTHER - Allows WebIDE to connect to host and port to runtime remotely.
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© can't see your device?

L+ Install Simulator

D

Remote Runtime

D

Chrome Deskiop

D

Safari, Firefox, and
other WebViews on 105

B = g
H Pe 5T a
:Q : fal o eferenresc
f:‘ : o e B
I'E.‘I _: eg
To add a new application
«  Click the of the three options:
»  Create anew app
©Q New App...

= Open Packaged
App...

3 Open Hosted App...

«  Open a packaged app
»  Open ahosted app
» Toremove a project, click the 'Project’ menu > 'Remove Project’.

11.11. Browser Console

The 'Browser Console' tool is advanced logging & debugging features that is executed in the context of IceDragon
itself.

«  Click the hamburger/ 'Open Menu' at the top-right
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»  Select 'Web Developer' > 'Browser Console'.

& Developer Tools - Options - about:preferences?entrypoint=menupanel#general — O X
¥ 3 Inspector Console [ Debugger {1} StyleEditor (@ Performance £k Memory = Network & Storage == = = |
W ¥ Filter output [ Persist Logs
o | arings | Logs | nto | Debug J cs5 | R | Request
voJELL { fding:  UeErmdr , SErVErPdLUN: NMLLE// UURNLUUU . CUMUUT . CLmy LLEUNULUN UPUULEY LUNYUUYE) 387 UE KDL 1drpudEes . JS1i30% ~
localeName: “"de™, action: [..], userfiction: "" }
Object { name: “"Spanish", serverPath: "http://downlood.comodo.com/icedrogon/update/longuoge/58/es-E5. xpi®, languages.js:1151:4
localeName: “"es-ES", action: [..], userfction: " }
Object { name: “French", serverPath: "http://downlood.comodo.com/icedragon/update/Longuage/58/fr.xpi", languages.js:1151:4
localeName: "fr", action: [..], userAction: "" }
Object { name: "Italian“, serverPath: "http://downlood.comodo.com/icedragon/update/longuage/58/1it. xpi”, languages.js:1151:4
localeName: "it™, action: [..], userfction: "" }
Object { name: "Portuguese", serverPath: "http://downlood.comodo.com/icedragon/update/language/58/pt-PT.xpi", languages.js:1151:4
localeName: "pt-PT", actien: [..], userAction: "" } e

>

From here you can:
»  View all JavaScript errors
»  View logs in the browser
+ Log any object directly to the console

»  Provides helper console

11.12. Responsive Design View

'Responsive Design View' tool helps web developers to view, read and navigate designs on different screen sizes
without changing the overall size of his browser window.

To open responsive design view
»  Click the hamburger/ 'Open Menu' at the top-right

«  Select 'Web Developer' > 'Responsive Design View'.

Comodo IceDragon User Guide | © 2018 Comodo Security Solutions Inc. | All rights reserved 181



COMODO

Creating Trust Online®

Eile Edit View History Bookmarks Tools Help _ O w

C Comodo | Global Leader in Cyl X +

G (@ @ httpsy/fwww.comodo.com see ww 99 | | QU Search » =

L} Most Visited T Getting Started 5] From Internet Explorer

Responsive Design Mode Mo throttling + DPR 1+ $y[E X

320 = 480

no device selected : fans

cCOMODO

Creating Trust Online®

PERSONAL v

SSL CERTIFICATES v

ENTERPRISE v
PARTNERS v
SUPPORT v

CONTACT US

11.13. Eyedropper

The 'Eyedropper' tool helps web developers to select colors in the current page. Hover the magnifying glass over the
page and you will see the color value for the current pixel you have selected in the Inspector web tools.

To open Eyedropper tool
Click the hamburger/ 'Open Menu' at the top-right
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»  Select 'Web Developer' > 'Eyedropper'
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To use the eyedropper
«  Select a color from the page and copy it to the clipboard
OR

»  Change a color value in the Inspector's Rules view
11.14.  Run Experimental Java Scripts on Page

The 'Scratchpad' tool allows you to run experimental Java Script code for that page.
»  You can use to try out various ideas and execute them on the web page before final implementation.
»  You can use to edit and run Java Script codes but is limited to executing a single line of code at a time.

*  You can use to execute many lines of code at a time. Some of the uses of 'Scratchpad' include testing new
code, debugging and to run saved reusable java script codes.

To open 'Scratchpad' tool
+  Click the hamburger/ 'Open Menu' at the top-right
«  Select 'Web Developer'> 'Scratchpad'.

The 'Scratchpad' editor will open. This contains some brief information about how to use it.
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& Scratchpad = O >
File Edit View Execute Epvircnment Help
Open File... Save Save As.. Run Inspect Display Pretty Print
1« J*
2 * This is a JavaScript Scratchpad.
3 i
4 * Enter some JavaScript, then Right Click or choose from the Execute Menu:
5 ¥ 1. Run to evaluate the selected text (Ctrl+R),
6 # 2. Inspect to bring up an Object Inspector on the result (Ctrl+I), or,
7 # 3. Display to insert the result in a comment after the selection. {(Ctrl+l)
B8 *F
9
18
Line 10, Col 1

After you have written the code in the Scratchpad, select it and right-click to execute or from the menu bar select
'Execute’. You have three choices to output the code:

»  Open File - Opens JavaScript files.
« Save/ Save As - Saves JavaScript code snippets.
*  Run - Executes the code in the page.

« Inspect - In addition to executing the code in the page, an object inspector will be displayed that will help
you to analyze the returned value.

- Display - After executing the code in the page, the results are inserted in the Scratchpad window as a
comment. This will help you to keep track of the changes made in the page.

*  Pretty Print — Allows you to print a code.
11.15.  View Page Source

Comodo IceDragon enables you to view the source code of the wepage you are viewing.

«  This is useful for web developer to analyze the codes and style rules while they are developing their own
web pages.

To view the page source
»  Click the hamburger/ 'Open Menu' at the top-right

«  Select 'Web Developer> 'Page Source'
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<!doctype html>
<html class="no-js" lang="e=n">
<head>

<script src="https://cdn.optimizely.com/Js/7343700018.js"></script>
<meta charset="utf-g8" />
<meta http-eqgquniv="content-language" content="en-us">
<meta http-equiv="X-UL-Compatible" content="IE=sdges" />
<link rel="canonical" href="https:,//www.comodo.com/" />
<title>Comodo | Global Leader in Cyber Security Solutions</title>
<meta name="description" content="Comodo, the leading S5L Provider offers
<meta name="keywords" content="Comodo, Internet Security, S55L Certificace’
<meta name="rocbots" content="index, follow, noydir, noodp"/>
<meta name="viewport" content="widch=device-width, initial-scale=1.0, maxi
<meta property="og:type" content="website" />
<meta property="og:url" content="comodo.com" />
<meta property="og:site name" content="comodo.com" S
<meta property="og:imags" content="/comodo-icon.jpg" />
<meta property="og:title" content="Free Internet Security and Antivirus |
<meta property="og:description” content="Comodo, the leading Internet Seci
<meta name="p:domain verify" content="ea9dlc4az6Zed2T8abeZBE64T7abET7a38" £
<link rel="image src" href="/default-image.jpg" />
<link rel="apple-touch-icon"™ href="/apple-touch-icon.png" />
<link rel="stylesheet” href="/css/normalize.ca3™ />
<link rel="stylesheet" href="/css/owl.carcusel.min.css" [ >
<link rel="ztylesheset" href="/cez/owl.thems.defaulc.min.css3" />
<link rel="styleshest" href="/cs=s/main-vZ.css" />
<link rel="stylesheet" href="/includes/szlider/scyle.css" />
<link rel="stylesheset" href="/cs=s/hero-=lider.css" />
<goript sro="/j=/vendor/modernizr-2.8.3.min.ja"></2cript>
<!--Start Google Analytics Tracking-->

<soript> v

11.16. Service Workers

Through the IceDragon you can develop and debug extensions (e.g, scripts, popups, content scripts, sidebars and
push notifications code). You can debug: '‘Add-ons', 'Tabs' and "Workers'.

» The sections will be updated automatically as workers get registered.
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File Edit View History Bookmarks Tools Help

(C Comodo | Global Leader in €y X | Debugging with Firefox Developer X +

c (@ about:debugging#workers see v % | Q Search 9 a & &+ =

L+ Most Visited (T Getting Started £ From Internet Explorer

Workers

*. Add-ons

A Service Worker debugging is not compatible with multiple content processes at

M Tabs the moment.
The preference "dom.ipc.multiOptOut” can be modified to force a single content
A Workers process for the current version.

Opt out of muldiple content processes

Service Workers

MNothing yet.

Shared Workers

MNothing yet.

Other Workers

ﬁ resource:///modules/sessionstore/SessionWoarker.js Debug
5{‘ resource://gre/modules/osfile/osfile_async_worker.js Debug

5{‘ resource://gre/modules/PageThumbsWorker s Debug

To view the service worker
»  Click the hamburger/ 'Open Menu' at the top-right
«  Select 'Web Developer> 'Service Worker'

Open Addons to start debugging addons

The 'Add-ons' page lists all bootstrapped add-ons that are currently installed.
«  Click the 'Add-ons' tab

»  Checkbox 'Enable add-on debugging to load an add-on temporarily from disk
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Add-ons

v Enable add-on debugging Learn more

Temporary Extensions

Nothing yet.

Extensions

*- Activity Stream

Extension ID activity-stream@mozilla.org

Debug

9§ ADB Helper

@ You can use web-ext to load temporary WebExtensions from the command line. Learn more

Load Temporary Add-on

« Navigate to the directory to upload the add-on file

« Selectitin directory and click 'Open'.
Note: Addon will be available until you restart your browser.

»  Click 'Debug' link to accept an incoming connection.

»  Click 'OK' to start the debugger in a separate window.
Open Tabs to start debugging currently opened pages

«  Click the 'Add-ons' tab > 'Tabs'

»  Select the page you want to debug and click 'Debug' button next to it.
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Tabs

Tabs
C Comodo | Global Leader in Cyber Security Solutions

@} Debugging with Firefox Developer Tools
@} aboutdevtools-toolbox?type=tab&id=2147483649

(5‘ reddit: the front page of the internet

Debug
Debug
Debug

Debug

Open Workers to start debugging workers
«  Click the 'Add-ons' tab > 'Workers'

«  The 'Workers' tab allows you to debug 'Service workers', Shared Workers and Other Workers.

Workers

Service Workers

Mothing yet.

Shared Workers

Mothing yet.

Other Workers

‘R‘ resource:///modules/sessionstore/SessionWorker,|s

‘R“ resource.//gre/modules/osfile/osfile_async_worker.js

Debug

Debug

«  Select the page you want to debug and click 'Debug' button next to it.

+ To send a push notification, run a service worker. You will see two buttons next to it: 'Debug' and 'Push'.

Tip:The 'Service worker' are not available as follows:
» If service set to false in about:config

+ If private browsing mode is run

» Ifyou set 'Never Remember History or Always use private browsing mode in the the 'History' section.
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11.17. Connect Remote Device

IceDragon lets you debug code remotely that is run in other browser.

Connect to remote device

Host: | localhost |

Port | B |

Connect

Firefox Developer Tools can debug remote devices (Firefox for Android and Firefox O35, for example).
Make sure that you have tumed on the ‘Remote debugging’ option in the remote device. For more,
see the documentation.

« Inthe opened interface, enter the host name and port though the which IceDragon console can be
accessed.

»  Click 'Connect' to confirm your choice.
This tool is available when 'Enable remote debugging' is selected.
To do this:

»  Click the hamburger/ 'Open Menu' at the top-right

«  Select 'Web Developer> "Web Console'

«  Click the cog icon at the top-right of the console pane.

«  Scroll to 'Advanced settings' then select 'Enable remote debugging'.
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BT T mm—— [TPTay camera shutter sound

[ Toggle paint flashing
Editor Preferences

[ Scratchpad

Responsive Design Mode (Ctrl+Shift+ M) Detect indentation
[J Take a screenshot of the entire page [ Autoclose brackets
(] Toggle rulers for the page ] Indent using spaces
DMeasureapDr‘ciun of the page Tab size

Keybindings | Default v

Advanced settings

Enable Source Maps

[]Show Geckao platform data

(] Disable HTTP Cache (when toolbox is open)
[ Disable JavaScript *

1 Enable Service Workers over HTTF (when toolbox is
apen)

= Enable browser chrome and add-on debugging
toolboxes

nal::lle remote debugging

* Current session only, reloads the poge

11.18. Add More Web Development Tools

To add more web development tools
+  Click the hamburger button at the top-right corner
»  Select 'Web Developer' > 'Get More Tools'
*  You will be taken to a Mozilla page from which you can download web-dev add-ons

«  See Install Add-ons if you need help to install add-ons.

11.19. Work Offline

In 'Offline Mode' you are not connected to the internet but are still able to view cached and saved web pages.
You can:

» View cached and saved web pages.

»  Open locally saved files and images

«  Configure Ice Dragon
You cannot:

*  Access the internet

«  Send/receive mail

»  Download new files

To enable offline mode:
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»  Click the hamburger/ 'Open Menu' button at the top-right corner
«  Select 'More' > 'Work Offline'

Offline mode

Firefox is currently in offline mode and can't browse the
Web.

® Press "Try Again” to switch to online mode and
reload the page.

Try Again

12.  Troubleshooting

This section explains how to resolve problems that might arise when you are using Comodo IceDragon.

« Error: "Your connection is not secure"

12.1.  Error: "Your connection is not secure"

IceDragon may show this message when there are problems with a website's TLS/SSL certificate. You are advised
not to visit the site in question, especially if you plan to submit confidential details such as login information or

personal data.
To create an exception for the site

«  When the error appears, click the 'Add Exception' button at the bottom of the warning:
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Your connection is not secure

The owner of expired.badssl.com has configured their website improperly. To protect your information
from being stolen, IceDragon has not connected to this website,

Learn more...

Report errors like this to help Mozilla identify and block malicious sites

expired.badssl.com uses an invalid security certificate.

The certificate expired on Monday, April 13, 2015, 2:59 AM. The current time is Friday, April 27, 2018,
5:41 PM.

Error code: SEC_ERROR_EXPIRED_CERTIFICATE

Add Exception...

The 'Add Exception' dialog will open.
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Add Security Exception >

You are about to override how lceDragon identifies this site.

‘ r I! . Legitimate banks, stores, and other public sites will not ask you to do this.

Server

Location: | https://expired.badssl.com/ Get Certificate

Certificate Status

This site atternpts to identify itself with invalid infermation.

QOutdated Information

The certificate is not currently valid. [t may have been stolen or lost, and could be used by
somecne to impersonate this site,

Permanently store this exception

Confirm Security Exception Cancel

«  The 'Get Certificate’ button allows you to inspect the certificate in detail

«  Check the 'Permanently store this exception' box to trust the certificate on all future visits
»  Click 'View' to open the certificate view

«  Click 'Confirm Security Exception' to apply your choice.

13. Reporta Bug

Comodo continually updates its products and intends to keep them bug-free. If you find any bug or have questions,
please submit a bug report post them in the Feedback section of the Comodo IceDragon forum at:

http://forums.comodo.com/bug-reports-cid-b284.0/

If you haven’t done so already, please create an account before posting.
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Comodo Security Solutions

Comodo Security Solutions is a global innovator of cybersecurity solutions, protecting critical information across the
digital landscape. Comodo provides complete, end-to-end security solutions across the boundary, internal network
and endpoint with innovative technologies solving the most advanced malware threats. With over 80 million
installations of its threat prevention products, Comodo provides an extensive suite of endpoint, website and network
security products for MSPs, enterprises and consumers.

Continual innovation and a commitment to reversing the growth of zero-day malware, ransomware, data-breaches
and internet-crime distinguish Comodo Security Solutions as a vital player in today's enterprise and home security
markets.

About Comodo Cybersecurity

In a world where preventing all cyberattacks is impossible, Comodo Cybersecurity delivers an innovative
cybersecurity platform that renders threats useless, across the LAN, web and cloud. The Comodo Cybersecurity
platform enables customers to protect their systems and data against even military-grade threats, including zero-day
attacks. Based in Clifton, New Jersey, Comodo Cybersecurity has a 20-year history of protecting the most sensitive
data for both businesses and consumers globally. For more information, visit comodo.com or our blog. You can also
follow us on Twitter (@ComodoDesktop) or Linkedin.

1255 Broad Street

Clifton, NJ 07013

United States

Tel : +1.888.266.636

Tel : +1.703.581.6361
https:/lwww.comodo.com

Email; EnterpriseSolutions@Comodo.com
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